Bug 28033 - Search notification in different language than the rest of Xamarin Studio
Summary: Search notification in different language than the rest of Xamarin Studio
Status: VERIFIED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Shell (show other bugs)
Version: 5.7
Hardware: PC Windows
: Normal normal
Target Milestone: master
Assignee: Vsevolod Kukol
URL:
: 28279 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-03-14 10:46 UTC by domen
Modified: 2016-09-20 14:07 UTC (History)
6 users (show)

See Also:
Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Search notification (10.98 KB, image/png)
2015-03-14 10:46 UTC, domen
Details

Description domen 2015-03-14 10:46:10 UTC
When searching in Xamarin Studio, part of the notification is written in different language than the rest of Xamarin Studio.

See attached image. My Windows language is Slovene and my Xamarin Studio language is English. Message "4 matches found v 110 datotekah" is partly English ("4 matches found") and partly Slovene ("in 110 datotekah"), which should not happen.


My Xamarin version data:

Xamarin Studio
Version 5.7.2 (build 7)
Installation UUID: 59a6b98a-f16f-4f0a-9aa9-e5192209be89
Runtime:
	Microsoft .NET 4.0.30319.34209
	GTK+ 2.24.22 (MS-Windows theme)
	GTK# 2.12.26

Xamarin.Android
Version: 4.20.0 (Indie Edition)
Android SDK: [...]
	Supported Android versions:
		4.0.3 (API level 15)
		4.1   (API level 16)
		4.4   (API level 19)
		5.0   (API level 21)
Java SDK: [...]
java version "1.7.0_71"
Java(TM) SE Runtime Environment (build 1.7.0_71-b14)
Java HotSpot(TM) Client VM (build 24.71-b01, mixed mode, sharing)

Build Information
Release ID: 507020007
Git revision: dcf3f486177d3e625349b51a8f3be807e3fa7712
Build date: 2015-02-24 05:29:53-05
Xamarin addins: ea7c65bb7876e4a876ab365208e94acdf8f330ef
Comment 1 domen 2015-03-14 10:46:31 UTC
Created attachment 10337 [details]
Search notification
Comment 2 Prashant manu 2015-04-29 06:17:44 UTC
Checked with latest stable build and not getting this issue. 
Screencast: http://www.screencast.com/t/frFAwGBVC

Could you please recheck this at your end with latest stable builds. If you are still encountering same issue, Please provide us the test steps you followed. Also add the logs from following places:
IDE log: Location: C:\User\AppData\Local\Xamarin\Log\ (Devenev file with latest timestamp)


Environment Info:
Xamarin Studio
Version 5.8.3 (build 1)
Installation UUID: a11fadb0-d7b1-4e4b-b5dd-787b243e880f
Runtime:
	Microsoft .NET 4.0.30319.0
	GTK+ 2.24.22 (MS-Windows theme)
	GTK# 2.12.26

Xamarin.Android
Version: 4.20.2 (Enterprise Edition)
Android SDK: E:\android-sdk
	Supported Android versions:
		2.1    (API level 7)
		2.2    (API level 8)
		2.3    (API level 10)
		3.1    (API level 12)
		4.0    (API level 14)
		4.0.3  (API level 15)
		4.1    (API level 16)
		4.2    (API level 17)
		4.3    (API level 18)
		4.4    (API level 19)
		4.4.87 (API level 20)
		5.0    (API level 21)
Java SDK: C:\Program Files\Java\jdk1.7.0_67
java version "1.7.0_67"
Java(TM) SE Runtime Environment (build 1.7.0_67-b01)
Java HotSpot(TM) 64-Bit Server VM (build 24.65-b04, mixed mode)

Xamarin Android Player
Version: 0.3.7.2
Location: C:\Program Files\Xamarin Android Player\DeviceManager.exe

Build Information
Release ID: 508030001
Git revision: 6e8e725e0d689351901c2c70453bfa4ea25e293b
Build date: 2015-04-06 15:20:49-04
Xamarin addins: 051cd5f8c1b5dbfc87eaef80a74aec03f34c60a8

Operating System
Windows 6.1.7601.65536 (64-bit)
Comment 3 domen 2015-04-29 19:08:21 UTC
Yes, notification is still partly in Slovene language.

From the screencast it's clear that your Windows interface is not in Slovene (or any other) language. It's in English language.
Comment 4 Sadik Ali 2015-04-30 09:41:32 UTC
Could you please confirm Windows OS language version you are using. As this issue is not reproducible by changing only windows language/System locale to Slovene. It seems issue might be related to the Win OS language. 
Variable we checked: 
Xamarin Studio Language selected: English
Window machine Language and system locale setting: Slovenian(Slovenia)
Win OS Language: English

Screencast: http://www.screencast.com/t/orif7xip

Also please add the logs from following places:
IDE log: Location: C:\User\AppData\Local\Xamarin\Log\ (Devenev file with latest
timestamp)
Comment 5 domen 2015-04-30 10:26:51 UTC
My Windows OS language is Slovenian. My Windows interface, menus, explorer, control panel etc. are in Slovenian language.
Comment 6 domen 2015-08-27 12:31:24 UTC
Changing bug status; issue still present in Xamarin Studio 5.9.5.
Comment 7 Lluis Sanchez 2015-08-27 12:43:32 UTC
This happens because the slovenian translation is not complete. Translations are being maintained by the MonoDevelop community, and not all of them are up to date.
Comment 8 domen 2015-08-27 12:55:18 UTC
I have already mentioned that my Xamarin Studio language is English. Not Slovenian. This is also evident from the screenshot ...
Comment 9 Lluis Sanchez 2015-08-27 15:14:46 UTC
Hmm, missed that part.
Comment 11 xamarin-release-manager 2016-07-15 12:17:27 UTC
Fixed in version 6.2.0.190 (master)

Author: Vsevolod Kukol
Commit: bb3d385137a4e19905ac29e90a22c26435eac8e9 (mono/monodevelop)
Comment 12 Vsevolod Kukol 2016-07-15 12:25:59 UTC
*** Bug 28279 has been marked as a duplicate of this bug. ***
Comment 13 xamarin-release-manager 2016-07-15 13:00:02 UTC
Fixed in version 6.1.0.5251 (cycle8)

Author: Vsevolod Kukol
Commit: fa7454bd2c346e36d26c782d033797b3c47c527d (mono/monodevelop)
Comment 14 Akhilesh kumar 2016-09-20 14:04:43 UTC
I have checked this issue on Mac and Windows both XS, now this issue is working fine. Search notification is in same language as the rest of Xamarin Studio.

Windows XS: http://www.screencast.com/t/484L8pNdX
Mac XS: http://www.screencast.com/t/lxEkx4nX

So i am closing this issue.

**********************************************

=== Xamarin Studio Community ===

Version 6.2 (build 558)
Installation UUID: 56d71809-da7f-4350-923d-8bf412047138
Runtime:
	Microsoft .NET 4.0.30319.42000
	GTK+ 2.24.26 (Light theme)
	GTK# 2.12.38

=== NuGet ===

Version: 3.4.3.0

=== Xamarin.Profiler ===

Not Installed

=== Xamarin.Android ===

Version: 7.0.99.77 (Xamarin Studio Community)
Android SDK: E:\AndroidSDK\android-sdk
	Supported Android versions:
		2.3    (API level 10)
		4.2    (API level 17)
		4.3    (API level 18)
		4.4    (API level 19)
		4.4.87 (API level 20)
		5.0    (API level 21)
		5.1    (API level 22)
		6.0    (API level 23)
		7.0    (API level 24)

SDK Tools Version: 25.1.7
SDK Platform Tools Version: 24.0.1
SDK Build Tools Version: 23.0.3

Java SDK: C:\Program Files\Java\jdk1.8.0_77
java version "1.8.0_77"
Java(TM) SE Runtime Environment (build 1.8.0_77-b03)
Java HotSpot(TM) 64-Bit Server VM (build 25.77-b03, mixed mode)

Android Designer EPL code available here:
https://github.com/xamarin/AndroidDesigner.EPL

=== Xamarin Android Player ===

Not Installed

=== Build Information ===

Release ID: 602000558
Git revision: 6a5dab73580fa9c5084a1db6dbe4376758e774c7
Build date: 2016-09-20 08:35:05-04
Xamarin addins: 0e8d396f2c535ef75e95730d6a42330d8b56882c
Build lane: monodevelop-windows-master

=== Operating System ===

Windows 10.0.10240.0 (64-bit)

=== Enabled user installed addins ===

Gist Ide Information 1.0.2

***************************************

Note You need to log in before you can comment on or make changes to this bug.