Bug 27776 - Debugger crashes after deploy to iPhone5 with reference to Android
Summary: Debugger crashes after deploy to iPhone5 with reference to Android
Status: RESOLVED FIXED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Debugger (show other bugs)
Version: 3.9
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2015-03-09 10:58 UTC by Fredy Wenger
Modified: 2016-12-20 12:44 UTC (History)
7 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Details to bug (167.60 KB, application/pdf)
2015-03-09 10:58 UTC, Fredy Wenger
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Fredy Wenger 2015-03-09 10:58:48 UTC
Created attachment 10219 [details]
Details to bug

Debugger crashes after deploy to iPhone5 (device) with reference to Android.
=> Details see attachment
This don't occur, if  deploy to a iPad (device)
Comment 1 Brendan Zagaeski (Xamarin Team, assistant) 2015-03-25 01:27:20 UTC
Thanks for the report.

To make the text content of this bug report a bit more searchable for future reference, I'll transcribe some of the content from the PDF attachment.



## Transcribed stack trace from the second image in the attachment from comment 0

> Exception in OnUnhandledException:
> 
> Mono.Debugging.Evaluation.EvaluatorException: Value not available
>   at Mono.Debugging.Soft.VariableValueReference.get_Value()
>   at Mono.Debugging.Soft.SoftDebuggerAdaptor.GetHoistedLocalVariables(SoftEvaluationContext cx, ValueReference vthis)
>   at Mono.Debugging.Soft.SoftDebuggerAdaptor.<GetLocalVariables>d__b.MoveNext()
>   at System.Collections.Generic.List`1.InsertRange(Int32 index, IEnumerable`1 collection)
>   at Mono.Debugging.Evaluation.BaseBacktrace.GetFrameInfo(Int32 frameIndex, EvaluationOptions options, Boolean ignoreEvalStatus)
>   at Mono.Debugging.Evaluation.BaseBacktrace.GetException(Int32 frameIndex, EvaluationOptions options)
>   at Xamarin.VisualStudio.Debugger.ExceptionsAdapter.GetExceptionInfo(Backtrace backTrace, EvaluationOptions options)
>   at Xamarin.VisualStudio.Debugger.ExceptionsAdapter.OnExceptionThrown(Object sender, TargetEventArgs args)
>   at Mono.Debugging.Client.DebuggerSession.OnTargetEvent(TargetEventArgs args)
>   at Mono.Debugging.Soft.SoftDebuggerSession.HandleBreakEventSet(Event[] es, Boolean dequeuing)
>   at Mono.Debugging.Soft.SoftDebuggerSession.HandleEventSet(EventSet es)
>   at Mono.Debugging.Soft.SoftDebuggerSession.EventHandler()



## Service trace viewer claims that this error is from the "Xamarin.VisualStudio.Android.XamarinAndroidPackage"?

The third image in the attached PDF shows that the exception message is supposedly a message from the "Xamarin.VisualStudio.Android.XamarinAndroidPackage".



## Additional information to add

If you like, here are a few more good "standard" pieces of information to add to help make the bug report easy to "jump into" when anyone who isn't yet familiar with the problem starts reading through it.


a) Does the problem happen with a "new from template" iPhone app project?


b) If the problem only happens with a particular existing project, you're welcome to zip up and attach the full project (or a trimmed down version of it that shows the problem) directly on this bug report. (You can optionally mark it "private" so that only that Xamarin team will be able to view it.) You can delete the `bin`, `obj`, `Components`, and `Packages` folders before zipping up the project to save some space. (Xamarin's Bugzilla limits direct attachments to something like 10-20 MB.)


c) You can add your current version information from the Mac build host and the Windows machine, either directly in a comment or as an attachment. (In particular, feel free to correct the following if it is inaccurate: based on some previous discussion in the forums, I believe the problem has been happening since at least XamarinVS 3.9.236 (and I think also 3.8.150), and has not yet stopped as of XamarinVS 3.9.483 (and probably not XamarinVS 3.9.530 either). Also, the Mac build host versions have always being upgraded in sync with the XamarinVS versions.)


(Just for easier reference for any other users who might notice these "additional information" suggestions on this bug and find them helpful when filing other bugs, note that they approximately match with some of the "best practice" suggestions on https://kb.xamarin.com/customer/portal/articles/1910343-when-and-how-should-i-file-a-bug-report-)
Comment 2 Chris Hardy [MSFT] 2015-06-03 12:02:54 UTC
Does this happen with a brand new iPhone project or is this something unique to the project? If it's unique to the project, then we'd need to take a look at the csproj and maybe the whole project to work out what's happening.

As ever, please include all your version information as mentioned above to help us know what versions of VS / Xamarin that you are using.

Thanks!
Comment 3 Fredy Wenger 2015-06-03 12:24:23 UTC
As I have started with XF, I don't had this problem (I was able to debug to my iPhone- and also iPad-Device).
Since a longer time now, I am not able to debug to the iPhone device anymore.
Since the update to 3.11.576, I'm also not able to debug to the iPad.
I don't know, if this also happens with a new project as I have only one (and don't need another).
Today I - unfortunately - have updated to the latest 3.11.586.0.
The problems with iPhone and iPad are the same, but I now also have brand new strange problems with debugging to the emulator (SIGABRT never had / seen before, other debugger-errors never seen before). 

My ACTUAL Version - information's (after latest update):

Microsoft Visual Studio Professional 2013
Version 12.0.30501.00 Update 2
Microsoft .NET Framework
Version 4.5.51641

Installierte Version: Professional

LightSwitch für Visual Studio 2013   06177-004-0446016-02937
Microsoft LightSwitch für Visual Studio 2013

Office Developer Tools - Mai 2014 Update DEU   06177-004-0446016-02937
Microsoft Office Developer Tools für Visual Studio 2013 - Mai 2014 Update DEU

Rechtschreibprüfung für die Visual Studio 2013-Codeanalyse   06177-004-0446016-02937
Rechtschreibprüfung für die Microsoft® Visual Studio® 2013-Codeanalyse

Teile des International CorrectSpell™-Rechtschreibprüfungssystems © 1993 von Lernout & Hauspie Speech Products N.V. Alle Rechte vorbehalten.

The American Heritage® Dictionary of the English Language, Third Edition Copyright © 1992 Houghton Mifflin Company. Elektronische Version lizenziert von Lernout & Hauspie Speech Products N.V. Alle Rechte vorbehalten.

Team Explorer für Visual Studio 2013   06177-004-0446016-02937
Microsoft Team Explorer für Visual Studio 2013

Visual Basic 2013   06177-004-0446016-02937
Microsoft Visual Basic 2013

Visual C# 2013   06177-004-0446016-02937
Microsoft Visual C# 2013

Visual C++ 2013   06177-004-0446016-02937
Microsoft Visual C++ 2013

Visual F# 2013   06177-004-0446016-02937
Microsoft Visual F# 2013

Windows Phone SDK 8.0 - DEU   06177-004-0446016-02937
Windows Phone SDK 8.0 - DEU

Allgemeine Azure-Tools   1.1
Bietet allgemeine Dienste für die Verwendung durch Azure Mobile Services und Windows Azure Tools.

ASP.NET und Webtools   2013.2.50425
Microsoft Web Developer Tools enthält die folgenden Komponenten:
Unterstützung beim Erstellen und Öffnen von ASP.NET-Webprojekten
Browserlink: Ein Kommunikationskanal zwischen Visual Studio und Browsern
Editor-Erweiterungen für HTML, CSS und JavaScript
Seitenprüfung: Prüfungstool für ASP.NET-Webprojekte
Gerüstbau: Ein Framework zum Erstellen und Ausführen von Codegeneratoren
Server Explorer-Erweiterungen für Windows Azure-Websites
Webpublishing: Erweiterungen zum Veröffentlichen von ASP.NET-Webprojekten für Hostinganbieter, lokale Server oder Windows Azure

ASP.NET Web Frameworks and Tools 2012.2   4.1.21001.0
For additional information, visit http://go.microsoft.com/fwlink/?LinkID=309563

ASP.NET Web Frameworks and Tools 2013   5.1.20409.0
For additional information, visit http://www.asp.net/

Gizmox Visual WebGui   10.0.2
Gizmox Visual WebGui Version 10.0.2

Microsoft Advertising SDK for Windows Phone   
Microsoft Advertising SDK for Windows Phone
Build 

NuGet-Paket-Manager   2.8.50926.663
NuGet-Paket-Manager in Visual Studio. Weitere Informationen zu NuGet finden Sie unter "http://docs.nuget.org/".

PreEmptive Analytics Visualizer   1.2
Microsoft Visual Studio-Erweiterung zur Visualisierung aggregierter Zusammenfassungen vom PreEmptive Analytics-Produkt.

SQL Server Data Tools   12.0.30919.1
Microsoft SQL Server Data Tools

Windows Azure Mobile Services Tools   1.1
Windows Azure Mobile Services Tools

Windows Phone 8.1 SDK-Integration   1.0
Dieses Paket integriert die Tools für das Windows Phone 8.1 SDK in die Menüs und Steuerelemente von Visual Studio.

Workflow Manager Tools 1.0   1.0
Dieses Paket enthält die erforderlichen Visual Studio-Integrationskomponenten für Workflow Manager.

Xamarin   3.11.586.0 (a91e30d)
Visual Studio extension to enable development for Xamarin.iOS and Xamarin.Android.

Xamarin.Android   5.1.2.1 (4ab8d98a62adf8f28223cef18fa63f06e87835a9)
Visual Studio plugin to enable development for Xamarin.Android.

Xamarin.Forms Intellisense   1.0
Provides intellisense for Xamarin.Forms in the XML editor.

Xamarin.iOS   8.10.1.0 (fce006eae308515fc1eaf85fcc0f90699d9c7e8b)
Visual Studio extension to enable development for Xamarin.iOS.

Xamarin.iOS Unified Migration   1.0
Automated migration for Xamarin iOS Classic projects to Unified

Xamarin.TestCloud.Integration   1.0
Early preview of Xamarin Test Cloud integration

AddInRessourcen_Vs2013
Erstellt von F. Wenger / 12.2013 für VS2013
Copyright (c) 2013 Matrix Solutions AG
Comment 4 Chris Hardy [MSFT] 2015-06-03 13:25:13 UTC
Are you seeing the exact same error message with both the iPhone and iPad now? If it's a different issue, it might be worth filing a new issue (as this bug should really be focused on the scenario of the Android debug issue when deploying to a iOS device).

Can you create a new iPhone project and see if that gives you the same issue, and if so, can you try using Xamarin Studio directly on the Mac to see if that reproduces the problem, so we can figure out if it's just a Visual Studio issue or a iOS/Device issue.

Thanks!
Comment 5 Fredy Wenger 2015-06-03 13:45:26 UTC
It seems as it is the same problem with iPhone and iPad.
I have at least the same error message for both devices in VS.
To find out the details, I have to export the logs, open it and search the bug in the log every time.
As I wrote in my last message, I now have NEW problems (with the latest update) that have to be solved first (we are shortly before release the app to the stores).
So I have to try to solve the new problems first (now idea what it is).
THEN, I can try to create a new .Forms app and deploy it to the iOS-devices to see, if it also shows the bug or not.
Comment 6 Joaquin Jares 2016-12-20 12:44:32 UTC
We have unified Android and iOS debuggers and that will have solved this. I'm closing this issue for verification. The unified debuggers are in alpha right now.