Bug 27485 - UnicastAddress.IPv4Mask throws NotImplementedException when coding Xamarin.Forms app from Visual Studio 2013 on Windows
Summary: UnicastAddress.IPv4Mask throws NotImplementedException when coding Xamarin.Fo...
Status: RESOLVED DUPLICATE of bug 30880
Alias: None
Product: Class Libraries
Classification: Mono
Component: System.Net.Http (show other bugs)
Version: 4.0.0
Hardware: PC Windows
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2015-02-26 19:33 UTC by curtis.harrison@wavetronix.com
Modified: 2016-05-25 10:25 UTC (History)
5 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 30880

Description curtis.harrison@wavetronix.com 2015-02-26 19:33:07 UTC
I'm attempting to call 'IPv4Mask' on an IPAddress object and get System.NotImplementedException: The requested feature is not implemented.

I found bugs for Linux from 2 years ago.  Is this feature going to get implemented?  Also, is there a simple workaround to get the SubnetMask for a given IPAddress ?
Comment 1 Daniel Cazzulino 2016-05-11 15:06:16 UTC
Moving to Mono product since it's not a VS-specific bug but a class library one.
Comment 2 Marek Safar 2016-05-25 10:25:49 UTC

*** This bug has been marked as a duplicate of bug 30880 ***