Bug 27460 - [Android] Frame OutLine color requires a Padding to be visible
Summary: [Android] Frame OutLine color requires a Padding to be visible
Status: RESOLVED ANSWERED
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms (show other bugs)
Version: 1.3.4
Hardware: PC Mac OS
: Normal normal
Target Milestone: ---
Assignee: Bugzilla
URL:
: 37206 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-02-26 11:42 UTC by John Miller [MSFT]
Modified: 2018-01-11 15:17 UTC (History)
18 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED ANSWERED

Description John Miller [MSFT] 2015-02-26 11:42:18 UTC
**Overview:**

   A Frame does not show the OutlineColor unless there is at least a Padding value >= 1. 

**Steps to Reproduce:**

   <Frame OutlineColor="Red"
			Padding="0">
   //... Add some content here
   </Frame>

**Actual Results:**

   No outline color is shown on Android. 

**Expected Results:**

   There should be a Red outline. On iOS it will show the expected results. 

**Build Date & Platform:**

   XF 1.3.4
   Android API 19
Comment 1 John Miller [MSFT] 2015-02-26 11:42:41 UTC
Workaround:

<Frame OutlineColor="Red"
			IsClippedToBounds="true"
			Padding="1"

Have at least a padding >= 1 and the outline will show.
Comment 2 asimk 2015-02-27 12:20:41 UTC
I have checked this issue with the help of Bug description and not able to reproduce this issue. I observed that when I set padding value >=1 Red outline color is shown on android Device and Emulator both.
Please review the screencast and let us know what additional steps we need to follow to reproduce this issue.
Screencast: http://www.screencast.com/t/susR1nZg5o6

Ide log: https://gist.github.com/saurabh360/d2d438d6192cb42ff202

Also it would be great if you provide Ide log.

Environment Info:
=== Xamarin Studio ===

Version 5.7.2 (build 8)
Installation UUID: 0b7eaebc-a0ed-4b58-81df-91e378cad28c
Runtime:
	Mono 3.12.0 ((detached/b8f5055)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 312000077

=== Xamarin.Android ===

Version: 4.20.0.28 (Indie Edition)
Android SDK: /Users/Admin_Mac/Desktop/Anddk/android-sdk-macosx
	Supported Android versions:
		2.1    (API level 7)
		2.2    (API level 8)
		2.3    (API level 10)
		3.1    (API level 12)
		4.0    (API level 14)
		4.0.3  (API level 15)
		4.1    (API level 16)
		4.2    (API level 17)
		4.3    (API level 18)
		4.4    (API level 19)
		4.4.87 (API level 20)
		5.0    (API level 21)
Java SDK: /usr
java version "1.7.0_25"
Java(TM) SE Runtime Environment (build 1.7.0_25-b15)
Java HotSpot(TM) 64-Bit Server VM (build 23.25-b01, mixed mode)

=== Apple Developer Tools ===

Xcode 6.2 (6770)
Build 6C121

=== Xamarin.iOS ===

Version: 8.6.2.26 (Trial Edition)
Hash: 9905782
Branch: 
Build date: 2015-02-26 11:05:07-0500

=== Xamarin.Mac ===

Version: 1.12.0.8 (Indie Edition)

=== Build Information ===

Release ID: 507020008
Git revision: 64a4266f0a82f7558472383d8ae66a526b3b881d
Build date: 2015-02-25 11:22:12-05
Xamarin addins: 1cb443ca2dddd9933d748e035560f06cf9c246bd

=== Operating System ===

Mac OS X 10.10.2
Darwin Admin-Macs-Mac-mini.local 14.1.0 Darwin Kernel Version 14.1.0
    Thu Nov 13 18:36:56 PST 2014
    root:xnu-2782.10.65~2/RELEASE_X86_64 x86_64
Comment 3 E.Z. Hart [MSFT] 2016-04-08 19:03:56 UTC
Thank you for your bug report. As we have not received the information requested, we cannot properly triage your bug and are marking it resolved.

Warm regards,
Xamarin Forms Team
Comment 4 zafar 2017-05-23 19:09:56 UTC
The bug still seems to exist with Android. Following are the properties I am using in XAML

<Frame CornerRadius="4" Padding="2" OutlineColor="Red" HasShadow="True">
  <Label VerticalOptions="Center" Text="I must be framed"/>
</Frame>

I am using latest stable XF version 2.3.4.247 running on Android Lollipop
Comment 5 Alberto 2017-07-21 08:14:40 UTC
@E.Z. Hart can you please update on this? The bug happens on EVERY frame in Android AppCompat. It's easy to reproduce.

The border is never shown in Xamarin Forms 2.3.4+.
Comment 6 Michael Henke 2017-08-16 20:42:04 UTC
This is my XAML:

<Frame
    HasShadow="false"
    Margin="40, 18"
    HeightRequest="23"
    x:Name="searchBox"
    Padding="20"
>
...
</Frame>

Shows an outline on iOS, no outline on Android.
Comment 7 predalpha 2017-09-06 16:13:15 UTC
I confirm that bug on Android Platform.
 + Android Nougat
 + Xamarin Forms 2.3.4.270

<Frame OutlineColor="{DynamicResource accentColor}" CornerRadius="0" Padding="10" BackgroundColor="Transparent">
...
</Frame>

Probably renderer is not good.
Is this issue solved with the new FastRenderers ?
Comment 8 David Ortinau [MSFT] 2017-09-07 14:00:35 UTC
*** Bug 37206 has been marked as a duplicate of this bug. ***
Comment 9 predalpha 2017-09-07 16:57:02 UTC
John Miller workaround doesnt work for me.

This issue is from 2015-02-26 11:42:18 UTC.

@Xamarin Teams : will you handle that for next release avoiding people to create a new control for a border color ?
Comment 10 thomas 2017-10-30 14:27:04 UTC
Just stumbled upon the same bug

Forms: 2.5.0.19271-pre2
Comment 11 David Ortinau [MSFT] 2017-12-07 14:41:27 UTC
Moved to https://github.com/xamarin/Xamarin.Forms/issues/1347
Comment 12 Rui Marinho 2018-01-03 18:50:06 UTC
Should be fixed on 2.6.0-pre1