Bug 27375 - Selecting multiple tests and running them only runs the first test in the selection
Summary: Selecting multiple tests and running them only runs the first test in the sel...
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: NUnit (show other bugs)
Version: unspecified
Hardware: Macintosh Mac OS
: Low normal
Target Milestone: master
Assignee: Mike Krüger
URL:
: 4614 40940 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-02-24 14:26 UTC by David Karl
Modified: 2017-10-05 13:58 UTC (History)
5 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Sample Project (4.52 KB, application/zip)
2015-02-27 00:51 UTC, Sadik Ali
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description David Karl 2015-02-24 14:26:12 UTC
Steps:
1. Left click on a Test (not a TestFixture) in the Unit Tests window of Xamarin Studio.
2. Shift+Left click on another Test within the same TestFixture (to select multiple tests).
3. Right click on any of the selected tests.
4. Click on Run Test.

Expected results:
All of the selected tests are run.

Actual results:
Only the first test in the selection is run.

Further notes:
I thought this might be intentional behaviour, since the right-click menu still says "Run Test" singular; I would have expected it to say "Run Tests" when there were multiple tests selected. Perhaps this behaviour could be added as part of resolving this issue?
Comment 1 Sadik Ali 2015-02-27 00:48:25 UTC
 
I have checked this issue and able to reproduce this issue with the help of bug description.

Steps I have followed:

1. Create a Nunit Library project in Xamarin Studio.
2. Add multiple test case i.e : https://gist.github.com/Arpit360/23f12e8bfbe9f85052ef
3. Open Unit Tests window from View->Unit Testing.
4. Select multiple Test through Shift.
5. Right click on Selected Test.

We observed that when we select multiple Test through shift and right click getting option of ‘Run Test’ ,When we select ‘Run Test’ only first selected Test runs.

Screencast: http://www.screencast.com/t/G2JSg6QkxTz

Environment Info:
Nunit version: 2.6.3
=== Xamarin Studio ===

Version 5.7.2 (build 7)
Installation UUID: 3d25a767-a003-4a7d-9f5e-e57987cf6cf0
Runtime:
	Mono 3.12.0 ((detached/b8f5055)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 312000077

=== Apple Developer Tools ===

Xcode 6.1 (6602)
Build 6A1052c

=== Xamarin.iOS ===

Version: 8.6.2.26 (Indie Edition)
Hash: 9905782
Branch: 
Build date: 2015-02-26 11:05:07-0500

=== Xamarin.Android ===

Version: 4.20.0.28 (Indie Edition)
Android SDK: /Users/mac360_xamarin/Library/Developer/Xamarin/android-sdk-macosx
	Supported Android versions:
		2.1   (API level 7)
		2.2   (API level 8)
		2.3   (API level 10)
		3.1   (API level 12)
		4.0.3 (API level 15)
		4.4   (API level 19)
		5.0   (API level 21)
Java SDK: /usr
java version "1.7.0_71"
Java(TM) SE Runtime Environment (build 1.7.0_71-b14)
Java HotSpot(TM) 64-Bit Server VM (build 24.71-b01, mixed mode)

=== Xamarin.Mac ===

Version: 1.10.0.18 (Indie Edition)

=== Build Information ===

Release ID: 507020007
Git revision: dcf3f486177d3e625349b51a8f3be807e3fa7712
Build date: 2015-02-24 09:14:27-05
Xamarin addins: ea7c65bb7876e4a876ab365208e94acdf8f330ef

=== Operating System ===

Mac OS X 10.10.0
Darwin mac360-xamarins-Mac-mini.local 14.0.0 Darwin Kernel Version 14.0.0
    Fri Sep 19 00:26:44 PDT 2014
    root:xnu-2782.1.97~2/RELEASE_X86_64 x86_64
Comment 2 Sadik Ali 2015-02-27 00:51:33 UTC
Created attachment 10071 [details]
Sample Project
Comment 3 Lluis Sanchez 2017-10-05 13:57:54 UTC
This is already fixed.
Comment 4 Lluis Sanchez 2017-10-05 13:58:26 UTC
*** Bug 4614 has been marked as a duplicate of this bug. ***
Comment 5 Lluis Sanchez 2017-10-05 13:58:45 UTC
*** Bug 40940 has been marked as a duplicate of this bug. ***