Bug 2727 - Wrapper script removes DYLD_FALLBACK_LIBRARY_PATH default
Summary: Wrapper script removes DYLD_FALLBACK_LIBRARY_PATH default
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Mac Add-in (show other bugs)
Version: 2.8.4.1
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: ---
Assignee: Miguel de Icaza [MSFT]
URL:
Depends on:
Blocks:
 
Reported: 2012-01-03 17:06 UTC by Jean-Louis Fuchs
Modified: 2012-02-07 09:05 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Jean-Louis Fuchs 2012-01-03 17:06:20 UTC
Version: MonoDevelop 2.8.5 (not selectable)

Symptom: System libraries not found (System.DllNotFoundException: libc.dylib) when a mono created .app is started outside of MonoDevelop.

In the wrapper-script created by mono develop: MyApp.app/Contents/MacOS/MyApp DYLD_FALLBACK_LIBRARY_PATH is set without including default. Since an empty  DYLD_FALLBACK_LIBRARY_PATH means the default this will remove default. System libraries cannot be found.

Please see: http://developer.apple.com/library/mac/#documentation/Darwin/Reference/Manpages/man1/dyld.1.html

In my opition the line should be:

	export DYLD_FALLBACK_LIBRARY_PATH="$MONO_FRAMEWORK_PATH/lib:$DYLD_FALLBACK_LIBRARY_PATH:$(HOME)/lib:/usr/local/lib:/lib:/usr/lib"

Or a check if DYLD_FALLBACK_LIBRARY_PATH is empty would be even better.
Comment 1 Miguel de Icaza [MSFT] 2012-01-03 19:43:19 UTC
Good observation Jean-Louis.

The fix has been added.
Comment 2 Rolf Bjarne Kvinge [MSFT] 2012-02-07 06:16:03 UTC
The wrapper-script now says:

line 20: HOME: command not found

shouldn't it be ${HOME} instead of $(HOME)?
Comment 3 Jean-Louis Fuchs 2012-02-07 07:36:17 UTC
Yes. That way the ~/lib doesn't work. It's on line 20 and line 51.

(Hmm, it is wrong in man dyld)
Comment 4 Rolf Bjarne Kvinge [MSFT] 2012-02-07 09:05:00 UTC
Thanks, fixed.