This is Xamarin's bug tracking system. For product support, please use the support links listed in your Xamarin Account.
Bug 27194 - Possible Memory Leak with ContextAction
Summary: Possible Memory Leak with ContextAction
Status: RESOLVED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms (show other bugs)
Version: 1.3.4
Hardware: PC Mac OS
: Normal normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2015-02-18 16:10 UTC by Cody
Modified: 2017-07-04 07:21 UTC (History)
7 users (show)

See Also:
Tags: all contextactions memory
Is this bug a regression?: ---
Last known good build:


Attachments

Description Cody 2015-02-18 16:10:24 UTC
### Description

There is a possible memory leak in the following app, in that list view count is not cleared when a list view is cleared

### Test Case

http://we.tl/UlshhtwKpP

### Video

https://www.dropbox.com/s/04d9c2kly7y7gvh/MemLeak.mov?dl=0

### Steps to Reproduce

1. Download linked test case 
2. Start the App and click page 2.
3. Navigate back to back to page1 click refresh twice
4. Repeat steps 1 - 3

### Expected Results

The instance count should revert to zero

### Actual Results

The instance count is equal to that of how many times you went to page 2

### Version

=== Xamarin Studio ===

Version 5.7.1 (build 17)
Installation UUID: 33d88ac5-6a46-48da-ae18-b355ffac4d9e
Runtime:
	Mono 3.12.0 ((detached/de2f33f)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 312000076

=== Apple Developer Tools ===

Xcode 6.1.1 (6611)
Build 6A2008a

=== Xamarin.iOS ===

Version: 8.6.1.20 (Business Edition)
Hash: 3b3ef43
Branch: 
Build date: 2015-01-24 09:42:21-0500

=== Xamarin.Mac ===

Version: 1.12.0.4 (Business Edition)

=== Xamarin.Android ===

Version: 4.20.0.28 (Business Edition)
Android SDK: /Users/codybeyer/Library/Developer/Xamarin/android-sdk-macosx
	Supported Android versions:
		2.1   (API level 7)
		2.2   (API level 8)
		2.3   (API level 10)
		3.1   (API level 12)
		4.0.3 (API level 15)
		4.1   (API level 16)
		4.4   (API level 19)
		5.0   (API level 21)
Java SDK: /usr
java version "1.7.0_71"
Java(TM) SE Runtime Environment (build 1.7.0_71-b14)
Java HotSpot(TM) 64-Bit Server VM (build 24.71-b01, mixed mode)

=== Build Information ===

Release ID: 507010017
Git revision: 0bc7d3550b6b088ac25b08dcf7bbe73bcc8658b3
Build date: 2015-02-03 19:43:29-05
Xamarin addins: f7b7d34419c9ec24501bfa7c658e80a6305613e0

=== Operating System ===

Mac OS X 10.10.2
Darwin Codys-MBP.router 14.1.0 Darwin Kernel Version 14.1.0
    Mon Dec 22 23:10:38 PST 2014
    root:xnu-2782.10.72~2/RELEASE_X86_64 x86_64
Comment 1 Atin 2015-02-19 06:05:19 UTC
I am also getting this issue, after following the steps mentioned in Bug description, the instance count is equal to that of how many times we went to page 2 in application.

Hence marking this as Confirmed.

Supplement info:
ide logs: https://gist.github.com/Parmendrak/9e8ba4264c9e167d3504
iOS device log: https://gist.github.com/Parmendrak/6e7b0374570e9747694a

Environment info:
=== Xamarin Studio ===

Version 5.7.2 (build 2)
Installation UUID: 3dbf10c4-ed30-4e55-8a8b-1704777c7b5f
Runtime:
	Mono 3.12.0 ((detached/de2f33f)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 312000076

=== Apple Developer Tools ===

Xcode 5.1.1 (5085)
Build 5B1008

=== Xamarin.iOS ===

Version: 8.6.2.19 (Business Edition)
Hash: d508c8e
Branch: 
Build date: 2015-02-15 22:17:46-0500

=== Xamarin.Android ===

Version: 4.20.0.28 (Business Edition)
Android SDK: /Users/apprpject/Desktop/android-sdk-macosx
	Supported Android versions:
		2.1    (API level 7)
		2.2    (API level 8)
		2.3    (API level 10)
		3.1    (API level 12)
		4.0    (API level 14)
		4.0.3  (API level 15)
		4.1    (API level 16)
		4.2    (API level 17)
		4.3    (API level 18)
		4.4    (API level 19)
		4.4.87 (API level 20)
		5.0    (API level 21)
Java SDK: /usr
java version "1.7.0_65"
Java(TM) SE Runtime Environment (build 1.7.0_65-b17)
Java HotSpot(TM) 64-Bit Server VM (build 24.65-b04, mixed mode)

=== Xamarin.Mac ===

Version: 1.10.0.18 (Business Edition)

=== Build Information ===

Release ID: 507020002
Git revision: d6231e6325f274cea59da478410f561312c5b401
Build date: 2015-02-17 19:04:38-05
Xamarin addins: b212fd66838b0d6e2435966e541e66ab9c988698

=== Operating System ===

Mac OS X 10.8.5
Darwin localhost 12.5.0 Darwin Kernel Version 12.5.0
    Sun Sep 29 13:33:47 PDT 2013
    root:xnu-2050.48.12~1/RELEASE_X86_64 x86_64
Comment 2 Cody 2015-03-02 11:30:58 UTC
http://we.tl/Yhp9sivkUk
Comment 3 adrianknight89 2016-10-22 01:25:09 UTC
Looks like the download link no longer works.
Comment 4 Rui Marinho 2017-01-26 14:31:17 UTC
Should be fixed in 2.3.5-pre1
Comment 5 Neha Kharbade 2017-07-04 07:21:37 UTC
Hi Cody,

I dont have access to link http://we.tl/UlshhtwKpP / Testcase, it would be great if you can provide me the access / sample to test.

Note You need to log in before you can comment on or make changes to this bug.