Bug 27192 - Visual Studio locking project dll.mdb file
Summary: Visual Studio locking project dll.mdb file
Status: RESOLVED FIXED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Android (show other bugs)
Version: unspecified
Hardware: PC Windows
: Normal normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2015-02-18 15:20 UTC by Allie Miller
Modified: 2016-12-22 21:51 UTC (History)
11 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Comment 2 Sunil Kumar 2015-02-19 11:38:58 UTC
I have tried to reproduce this issue but unable to reproduce. I am able to Build then Rebuild the solution successfully without any error. As shows in screencast: http://www.screencast.com/t/getaagg7vr

Please let me know if I have to follow any other steps to reproduce this issue.

Also if possible could you please provide Ide log and Build output.
For Ide log, Location: VS-> Help-> Zip Xamarin Logs
For Build Output, Location: VS-> View-> Output-> Select Build in drop down list and copy logs.

Environment Info:
Microsoft Visual Studio Professional 2013
Version 12.0.31101.00 Update 4
Microsoft .NET Framework
Version 4.5.51641

Xamarin   3.9.289.0 (39a70ae)
Xamarin.Android   4.20.0.34 (49a04b966feb40dfdba49d57ba16249b66d606a6)
Xamarin.iOS   8.6.1.0 (3b3ef438017c7ecf486defa9e01567a5f2b3cb2a)
Xamarin.iOS Unified Migration   1.0
Comment 3 Brendan Zagaeski (Xamarin Team, assistant) 2015-02-23 14:13:27 UTC
I'll add a couple similar-looking bugs here to help keep them all coordinated in case they have the same underlying cause.

Possible duplicate: bug 19708.
Likely duplicate: bug 26841.
Comment 5 Ian 2015-03-10 19:46:21 UTC
This happens for me every time also, if I turn on Debug / Exceptions / Common Language Runtime exceptions
Comment 6 Ian 2015-03-10 19:50:40 UTC
I'll have to retract that... it did work a couple of times ok after turning that off but then it came back. Coincidence I think.
Comment 7 Jose Gallardo 2016-12-22 21:51:29 UTC
Hi,
As we've introduced several improvements since the bug was reported, I'll mark the bug as resolved fixed tentatively, so QA can verify.
Please feel free to reopen it if you can still reproduce the issue with current bits.
Thanks!