Bug 27076 - Can't build with unicode characters in sln or sdk path.
Summary: Can't build with unicode characters in sln or sdk path.
Status: RESOLVED DUPLICATE of bug 14918
Alias: None
Product: Android
Classification: Xamarin
Component: MSBuild (show other bugs)
Version: 5.0
Hardware: PC Windows
: Normal normal
Target Milestone: ---
Assignee: Jonathan Pryor
URL:
Depends on:
Blocks:
 
Reported: 2015-02-15 11:53 UTC by João Vitor
Modified: 2015-07-20 12:12 UTC (History)
2 users (show)

See Also:
Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Logs from Xamarin.Studio (8.46 KB, application/zip)
2015-02-15 11:53 UTC, João Vitor
Details

Description João Vitor 2015-02-15 11:53:10 UTC
Created attachment 9842 [details]
Logs from Xamarin.Studio

When my project is located inside my user directory (which contains unicode characters) I cannot build the project.

My user directory:
C:\Users\JoãoVitor

(Created automatically by Windows)

C:\Program Files (x86)\MSBuild\Xamarin\Android\Xamarin.Android.Common.targets(2,2): Error XA0000: Unexpected error - Please file a bug report at http://bugzilla.xamarin.com. Reason: System.UnauthorizedAccessException: Access to the path "C:\Users\JoãoVitor" is denied. (XA0000) (AndroidTest)


Moving the project outside my home dir I receive yet another similar problem:

C:\Program Files (x86)\MSBuild\Xamarin\Android\Xamarin.Android.Common.targets(3,3): Error XA0000: Unexpected error - Please file a bug report at http://bugzilla.xamarin.com. Reason: Could not find SDK directory 'C:\Users\JoãoVitor\AppData\Local\Android\android-sdk'.  Is --sdk-dir set appropriately? (XA0000) (Xamarin.Forms.Droid)

I had no problems building with Visual Studio, but my license expired and I am limited to Xamarin.Studio for now.
Comment 1 Rajneesh Kumar 2015-02-16 06:16:03 UTC
I have checked this issue but not able to reproduce. To reproduce this issue I have followed the steps give below:

1. Create an android application in XS.
2. Copy project in folder named "JoãoVitor".
3. Reopen the project in XS and build it.

I observed that I am able to build it successful. Here is the screencast or the same: http://www.screencast.com/t/gInOXIwO

Could you please provide us your full environment info? also please let me know that what steps I am missing to reproduce this issue. That will be very helpful to reproduce this issue at our end.

You can get Environment Info here Help=>About=>Show details=>Copy Information.

XS Logs: https://gist.github.com/Rajneesh360Logica/195730a1a0a03970643f

Environment info:

=== Xamarin Studio ===

Version 5.7.1 (build 17)
Installation UUID: fd157f48-7924-4d8e-b8a8-845aaad94233
Runtime:
	Microsoft .NET 4.0.30319.18408
	GTK+ 2.24.22 (MS-Windows theme)
	GTK# 2.12.26

=== Xamarin.Android ===

Version: 4.20.0 (Business Edition)
Android SDK: E:\android-sdk
	Supported Android versions:
		2.1    (API level 7)
		2.2    (API level 8)
		2.3    (API level 10)
		3.1    (API level 12)
		4.0    (API level 14)
		4.0.3  (API level 15)
		4.2    (API level 17)
		4.3    (API level 18)
		4.4    (API level 19)
		4.4.87 (API level 20)
		5.0    (API level 21)
Java SDK: C:\Program Files (x86)\Java\jdk1.6.0_39
java version "1.6.0_39"
Java(TM) SE Runtime Environment (build 1.6.0_39-b04)
Java HotSpot(TM) Client VM (build 20.14-b01, mixed mode)

=== Build Information ===

Release ID: 507010017
Git revision: 0bc7d3550b6b088ac25b08dcf7bbe73bcc8658b3
Build date: 2015-02-03 19:51:07-05
Xamarin addins: f7b7d34419c9ec24501bfa7c658e80a6305613e0

=== Operating System ===

Windows 6.2.9200.0 (64-bit)
Comment 2 João Vitor 2015-02-16 09:08:00 UTC
Hi, thanks for investigating this issue,
here is the requested Environment Info.

Xamarin Studio
Version 5.7.1 (build 17)
Installation UUID: 639db206-d18d-4d7e-a390-ca6f9fed5eda
Runtime:
	Microsoft .NET 4.0.30319.0
	GTK+ 2.24.22 (MS-Windows theme)
	GTK# 2.12.26

Xamarin.Android
Version: 4.20.0 (Indie Edition)
Android SDK: C:\Users\JoãoVitor\AppData\Local\Android\android-sdk
	Supported Android versions:
		2.1   (API level 7)
		2.2   (API level 8)
		2.3   (API level 10)
		3.1   (API level 12)
		4.0.3 (API level 15)
		4.4   (API level 19)
		5.0   (API level 21)
Java SDK: C:\Program Files (x86)\Java\jdk1.6.0_39
java version "1.6.0_39"
Java(TM) SE Runtime Environment (build 1.6.0_39-b04)
Java HotSpot(TM) Client VM (build 20.14-b01, mixed mode, sharing)

Build Information
Release ID: 507010017
Git revision: 0bc7d3550b6b088ac25b08dcf7bbe73bcc8658b3
Build date: 2015-02-03 19:51:07-05
Xamarin addins: f7b7d34419c9ec24501bfa7c658e80a6305613e0

Operating System
Windows 6.2.9200.0 (64-bit)
Comment 3 Rajneesh Kumar 2015-02-17 11:01:18 UTC
@João, Thanks a lot for providing the environment info.

I have checked this issue and now I am able to reproduce this. To reproduce this issue I have followed the steps as I mentioned in comment 1 and observe that this issue exists for "INDIE", "TRIAL" and "STARTER" user. However, user is able to build the application using Business and Enterprise licence.

So "INDIE", "TRIAL" and "STARTER" user is unable to build the android project which contains unicode characters in Solution name or solution path folder name.

Screencast: http://www.screencast.com/t/vrD3AazYtE

Error Details: https://gist.github.com/Rajneesh360Logica/31f484847e6c5fc9a16f
Ide Logs: https://gist.github.com/Rajneesh360Logica/b3d171e57395d28c5a9c
Android tools Log: https://gist.github.com/Rajneesh360Logica/6a922a2bfebb742a3d3c
Comment 4 Jonathan Pryor 2015-07-20 12:12:19 UTC

*** This bug has been marked as a duplicate of bug 14918 ***

Note You need to log in before you can comment on or make changes to this bug.