Bug 27074 - System.IO.FileNotFoundException: Could not load assembly 'Newtonsoft.Json, Version=, Culture=neutral, PublicKeyToken=null'. Perhaps it doesn't exist in the Mono for Android profile?
Summary: System.IO.FileNotFoundException: Could not load assembly 'Newtonsoft.Json, Ve...
Status: RESOLVED DUPLICATE of bug 14918
Alias: None
Product: Android
Classification: Xamarin
Component: MSBuild (show other bugs)
Version: 5.1
Hardware: PC Windows
: Normal normal
Target Milestone: ---
Assignee: Jonathan Pryor
URL:
: 31749 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-02-15 10:34 UTC by Pierre BELIN
Modified: 2015-07-09 12:09 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Full build log (54.22 KB, text/plain)
2015-02-15 10:34 UTC, Pierre BELIN
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 14918

Description Pierre BELIN 2015-02-15 10:34:06 UTC
Created attachment 9840 [details]
Full build log

The following error :
System.IO.FileNotFoundException: Could not load assembly 'Newtonsoft.Json, Version=, Culture=neutral, PublicKeyToken=null'. Perhaps it doesn't exist in the Mono for Android profile? 
happens when trying to compile the XamarinStore sample on my PC (Win8.1, VS2013).

I tried the following without success :
- manually removing and re-adding JSON.net via the Component Store
- manually removing the component and adding the latest version of JSON.net via Nuget
Comment 1 Matt Ward 2015-02-16 04:32:32 UTC
It seems to be a problem with the characters used in the project directory Téléchargements. If you replace the é characters in the directory Téléchargements with plain ASCII e characters then the build will work. With the é characters in the directory the build seems to create another Téléchargements directory on disk using the incorrectly encoded characters and this is being used as the path to Newtonsoft.Json.dll which is not in that directory so the build is failing.

Looking at a similar bug #3943 there seems to be a problem with the Android tools when non-English characters are used in the path. Although the error message from the bug #3943 is different from the error you are seeing.
Comment 2 Rajneesh Kumar 2015-07-09 08:40:44 UTC
*** Bug 31749 has been marked as a duplicate of this bug. ***
Comment 3 Jonathan Pryor 2015-07-09 12:09:17 UTC

*** This bug has been marked as a duplicate of bug 14918 ***