Bug 27063 - Navigation not always returning to the proper page.
Summary: Navigation not always returning to the proper page.
Status: VERIFIED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms (show other bugs)
Version: 1.3.4
Hardware: Macintosh Mac OS
: Normal normal
Target Milestone: 1.4.0
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2015-02-13 17:13 UTC by Jon Goldberger [MSFT]
Modified: 2015-03-03 14:18 UTC (History)
7 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Jon Goldberger [MSFT] 2015-02-13 17:13:33 UTC
## Description

After pushing a few pages onto the Navigation Stack, sometimes (seems to be based on how quickly the navigation buttons are tapped) going back does not always return to the proper page. 

I tested on Forms 1.3.3 and 1.3.4-pre4. Same results on both.

## Steps to reproduce

1. Open the attached MasterDetail sample project.
2. Set the iOS app as the startup project and launch to a simulator (I did not test on device)
3. Once the app launches, click on one of the rows and then quickly tap the colored "Go to next page" buttons.
4. Click the Back button to go all the way back to the home page with the table view.

Expected result: Will be able to navigate all the way back to hoe page with list view.

Actual Result: Back navigation gets stuck at Page 1.

If not able to reproduce, make sure to click the "Got to next page" button on each page as quickly as possible. If you give it time, the issue does not occur. 


## Notes

I saw this release note in the 1.3.4-pre4 forum thread that I believe this issue may be related to: 
http://forums.xamarin.com/discussion/32570/xamarin-forms-1-3-4-pre4-released/p1
 "Navigation push/pops will now auto-queue if done before the last one completes. This helps handle some race conditions."
so I made sure to test on 1.3.4-pre1. Updating to that package did not resolve the issue.
Comment 4 Parmendra Kumar 2015-02-24 10:35:41 UTC
I have recheck this issue with Xamarin.Forms version 1.3.5.6333-pre1 and I am also getting same behavior mentioned in the bug description.
Comment 5 Jason Smith [MSFT] 2015-03-02 09:50:13 UTC
This issue seems to not be possible to reproduce on device. There is a consistency issue with the simulator where we are seeing slightly different order of operations on calls. If you have a reproduction on device we are happy to tackle it :)
Comment 6 Parmendra Kumar 2015-03-02 11:50:47 UTC
Hi Jason,

I have checked this issue with device 5s (iOS version 8.1.2) and am getting same behavior mentioned in the bug description.

Hence I am reopen this issue.

Environment info:

Xamarin.Forms version 1.3.5.6333-pre1

=== Xamarin Studio ===

Version 5.7.1 (build 17)
Installation UUID: 1a096c6f-0678-402e-89b2-a2c10f7e80e4
Runtime:
	Mono 3.12.0 ((detached/de2f33f)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 312000076

=== Apple Developer Tools ===

Xcode 6.1.1 (6611)
Build 6A2008a

=== Xamarin.iOS ===

Version: 8.6.1.26 (Business Edition)
Hash: 98ee412
Branch: 
Build date: 2015-02-11 04:37:05-0500

=== Xamarin.Mac ===

Version: 1.10.0.18 (Business Edition)

=== Xamarin.Android ===

Version: 4.20.0.28 (Business Edition)
Android SDK: /Users/360_macmini/Desktop/android-sdk-macosx
	Supported Android versions:
		2.1    (API level 7)
		2.2    (API level 8)
		2.3    (API level 10)
		3.1    (API level 12)
		4.0    (API level 14)
		4.0.3  (API level 15)
		4.1    (API level 16)
		4.2    (API level 17)
		4.3    (API level 18)
		4.4    (API level 19)
		4.4.87 (API level 20)
		5.0    (API level 21)
Java SDK: /usr
java version "1.8.0_31"
Java(TM) SE Runtime Environment (build 1.8.0_31-b13)
Java HotSpot(TM) 64-Bit Server VM (build 25.31-b07, mixed mode)

=== Build Information ===

Release ID: 507010017
Git revision: 0bc7d3550b6b088ac25b08dcf7bbe73bcc8658b3
Build date: 2015-02-03 19:43:29-05
Xamarin addins: f7b7d34419c9ec24501bfa7c658e80a6305613e0

=== Operating System ===

Mac OS X 10.9.4
Darwin ShrutiMac.local 13.3.0 Darwin Kernel Version 13.3.0
    Tue Jun  3 21:27:35 PDT 2014
    root:xnu-2422.110.17~1/RELEASE_X86_64 x86_64
Comment 7 Vikash Gupta 2015-03-02 11:57:03 UTC
Hi Jason,

The simple steps to reproduce defect is: 
1. Navigate to 4-5 screen level
2. Click any navigation link [say back]
3. Quickly click again on navigation link [say back]
4. Pause for 2-3 seconds and then click on navigation link [say back]

Hope this helps.

Regards,
Vikash
Comment 8 Jason Smith [MSFT] 2015-03-02 12:12:09 UTC
Thank you that let me reproduce it!
Comment 9 Jason Smith [MSFT] 2015-03-02 13:46:43 UTC
Should be fixed in 1.4.0-pre1
Comment 10 Parmendra Kumar 2015-03-03 05:04:16 UTC
I have checked this issue with Xamarin.Forms version 1.4.0.6336-pre1 and its working fine at my.

Hence I am closing this issue.