Bug 26923 - [CorDebugger] Cannot inspect objects with proxies When debugging unit tests
Summary: [CorDebugger] Cannot inspect objects with proxies When debugging unit tests
Status: CONFIRMED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Debugger (show other bugs)
Version: 5.7
Hardware: PC Windows
: Low normal
Target Milestone: master
Assignee: David Karlaš
URL:
Depends on:
Blocks:
 
Reported: 2015-02-10 15:26 UTC by Mikayla Hutchinson [MSFT]
Modified: 2017-09-01 14:24 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report for Bug 26923 on Developer Community or GitHub if you have new information to add and do not yet see a matching new report.

If the latest results still closely match this report, you can use the original description:

  • Export the original title and description: Developer Community HTML or GitHub Markdown
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments

Related Links:
Status:
CONFIRMED

Description Mikayla Hutchinson [MSFT] 2015-02-10 15:26:29 UTC
When debugging a unit test, if I try to inspect an object with a proxy type, I get the error "A supplied object to type belongs to the wrong AppDomain".

Worse, this failure prevents inspecting any of the real members of the project.
Comment 1 Jeffrey Stedfast 2015-03-06 11:51:27 UTC
Is this the CorDebugger or the SDB backend?
Comment 2 Mikayla Hutchinson [MSFT] 2015-03-11 15:20:05 UTC
CorDebugger
Comment 3 Arpit Jha 2015-08-25 08:45:33 UTC
I have checked this issue and unable to reproduce this issue.

Could you please provide us a test steps, So that We can able to reproduce this issue at our end.
Comment 4 Mikayla Hutchinson [MSFT] 2015-08-25 14:50:24 UTC
This demonstrates it: http://screencast.com/t/CVxe3jN3
Comment 5 Mikayla Hutchinson [MSFT] 2015-08-26 11:53:30 UTC
.
Comment 6 Arpit Jha 2015-08-27 01:21:04 UTC
I have checked this issue with issue and able to reproduce with the help of comment 4.

I reproduced this issue with Nunit Library project template.
I observed this issue only on windows

Screencast: http://www.screencast.com/t/Jv0Lnb6zVt

Environment Info:
Xamarin Studio
Version 5.9.6 (build 20)