Bug 26501 - Context Actions cause views to be hidden on iOS after re-use
Summary: Context Actions cause views to be hidden on iOS after re-use
Status: VERIFIED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms (show other bugs)
Version: 1.3.2
Hardware: Macintosh Mac OS
: Normal normal
Target Milestone: 1.3.3
Assignee: Bugzilla
URL:
: 26626 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-01-28 08:43 UTC by tim.ahrentlov
Modified: 2015-02-04 08:12 UTC (History)
8 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Test case to reproduce bug (71 bytes, text/plain)
2015-01-28 08:49 UTC, tim.ahrentlov
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description tim.ahrentlov 2015-01-28 08:43:18 UTC
When you add context actions to a cell, itemsource bindings are not working correctly.

To reproduce:

1. Load and run test case
2. Press refresh
3. Notice that the space occupied by the previous dataset is now blank.

4. Open FamilyCell.cs
5. Comment out AddContextActions () in the constructor.
6. Save and run project
7. Press refresh.
8. Notice that the refresh is now working.
Comment 1 tim.ahrentlov 2015-01-28 08:49:24 UTC
Created attachment 9532 [details]
Test case to reproduce bug
Comment 2 tim.ahrentlov 2015-01-29 03:28:59 UTC
Bug is still present on 1.3.2 pre2
Comment 3 Sunil Kumar 2015-01-29 05:36:40 UTC
I have checked this issue and I am able to reproduce this issue.

Screencast: http://www.screencast.com/t/3qrG2MvwM0

Build output: https://gist.github.com/saurabh360/790190a551e397272696
Application Output: https://gist.github.com/anonymous/b0421475e8f6a1dc1bbd

Environment Info:

Xamarin.Forms 1.3.2.6309-pre2

=== Xamarin Studio ===

Version 5.7.1 (build 15)
Installation UUID: 6ea47b0d-1852-4aaf-808d-373ff0a5002b
Runtime:
	Mono 3.12.0 ((detached/a813491)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 312000068

=== Apple Developer Tools ===

Xcode 6.1 (6604)
Build 6A1052d

=== Xamarin.iOS ===

Version: 8.6.1.20 (Business Edition)
Hash: 3b3ef43
Branch: 
Build date: 2015-01-24 09:42:21-0500

=== Xamarin.Android ===

Version: 4.20.0.28 (Business Edition)
Android SDK: /Users/jatin66/Desktop/Backup/android-sdk-macosx
	Supported Android versions:
		1.6    (API level 4)
		2.1    (API level 7)
		2.2    (API level 8)
		2.3    (API level 10)
		3.1    (API level 12)
		4.0    (API level 14)
		4.0.3  (API level 15)
		4.1    (API level 16)
		4.2    (API level 17)
		4.3    (API level 18)
		4.4    (API level 19)
		4.4.87 (API level 20)
		5.0    (API level 21)
Java SDK: /usr
java version "1.7.0_65"
Java(TM) SE Runtime Environment (build 1.7.0_65-b17)
Java HotSpot(TM) 64-Bit Server VM (build 24.65-b04, mixed mode)

=== Xamarin.Mac ===

Version: 1.12.0.4 (Business Edition)

=== Build Information ===

Release ID: 507010015
Git revision: ce24e991948c7f3d88b0194a14fc1996d848ef51
Build date: 2015-01-26 16:42:20-05
Xamarin addins: 6895e3222bfa6910524708aa0633ff3db99bc3a0

=== Operating System ===

Mac OS X 10.10.0
Darwin Jatin66s-iMac.local 14.0.0 Darwin Kernel Version 14.0.0
    Fri Sep 19 00:26:44 PDT 2014
    root:xnu-2782.1.97~2/RELEASE_X86_64 x86_64
Comment 4 Eric Maupin 2015-02-02 12:57:38 UTC
*** Bug 26626 has been marked as a duplicate of this bug. ***
Comment 5 Jason Smith [MSFT] 2015-02-03 16:52:38 UTC
Should be fixed in 1.3.3-pre1
Comment 6 Udham Singh 2015-02-04 08:10:10 UTC
I have checked this issue with following builds.

Environment Info :

Mac OS X 10.9.5
Xamarin Studio 5.7.1 (build 17)
Mono 3.12.0 ((detached/a813491)
GTK+ 2.24.23 (Raleigh theme)
Xcode 6.1.1 (6611)
Xamarin.iOS  8.6.1.24 (Business Edition)
Xamarin.Android  4.20.0.28 (Business Edition)

Now this issue is working fine, Hence closing this issue.

Screencast : http://www.screencast.com/t/jwf4dNhJ7
Comment 7 Udham Singh 2015-02-04 08:12:38 UTC
An update to comment 6 : Verified this issue with Xamarin.Forms 1.3.3.6321-pre2.

Thanks!