Bug 26493 - Portable Class Libraries (PCL) don't exist for xbuild
Summary: Portable Class Libraries (PCL) don't exist for xbuild
Status: RESOLVED DOWNSTREAM
Alias: None
Product: Installers
Classification: Mono
Component: General (show other bugs)
Version: unspecified
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: ---
Assignee: Duncan Mak
URL:
Depends on:
Blocks:
 
Reported: 2015-01-28 04:54 UTC by henrik
Modified: 2015-08-07 02:38 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DOWNSTREAM

Description henrik 2015-01-28 04:54:07 UTC
Steps to reproduce:

 1. brew install mono
 2. Create a new PCL library
 3. xbuild new_lib.fsproj

/usr/local/Cellar/mono/3.12.0/lib/mono/4.5/Microsoft.Common.targets:  warning : Unable to find framework corresponding to the target framework moniker '.NETPortable,Version=v4.5,Profile=Profile7'. Framework assembly references will be resolved from the GAC, which might not be the intended behavior.
/usr/local/Cellar/mono/3.12.0/lib/mono/4.5/Microsoft.Common.targets: error : PCL Reference Assemblies not installed.
Comment 1 Marek Habersack 2015-01-28 09:40:27 UTC
I don't believe it's our packaging issue. Homebrew likely create their own distribution, you should probably take the issue up with them instead. Duncan, what do you think?
Comment 2 Mikayla Hutchinson [MSFT] 2015-01-28 14:35:10 UTC
Yes. The PCL reference assemblies are not part of the mono build, but are bundled into our pkg installer (along with a bunch of other things, like F#, GTK#, etc).

homebrew needs to package them.
Comment 3 evolvedmicrobe 2015-08-07 02:38:18 UTC
Just stumbled across this while trying to create a build script on linux using a mono tarball.

Regarding "packaging" the PCL libraries, if we are on linux and using a mono from the tarball and find the message:

    error : PCL Reference Assemblies not installed.

Does anyone know how we can install them?