Bug 26408 - Application hangs
Summary: Application hangs
Status: NEW
Alias: None
Product: Runtime
Classification: Mono
Component: Debugger (show other bugs)
Version: 2.10.x
Hardware: PC Linux
: --- normal
Target Milestone: ---
Assignee: Zoltan Varga
URL:
Depends on:
Blocks:
 
Reported: 2015-01-26 02:37 UTC by Roman
Modified: 2015-03-02 15:45 UTC (History)
3 users (show)

See Also:
Tags:
Is this bug a regression?: ---
Last known good build:


Attachments

Description Roman 2015-01-26 02:37:04 UTC
It's happens sometimes after install last version Monodevelop 5.7
During work of application in debug mode my application hungs moreover I don't see any error in debugger and when I stop debug pressing button in Monodevelop application is not closing. I necessary to kill process using terminal
Comment 1 Roman 2015-01-26 03:42:48 UTC
But when I start application without debugding application work without problem. I guess that problems is not resolving and my forecast for mono is such: if mono will not stable after 2 years so that it doomed to falling. Because I see more bugs which is not resolved from 2012 and from another side of Microsoft where all Net.Framework is exellent licked.
Comment 2 Jeffrey Stedfast 2015-02-20 12:16:25 UTC
You're using a version of Mono (2.10.x) from many years ago. Try upgrading to 3.12
Comment 3 Roman 2015-02-22 05:02:37 UTC
Oh, thanks, but I have already tried this. Result was bad because application working on mono 3.0 has lost link to memory after some hours. I press button, it is pressed by it happens nothing, I guess it is wrong work of garbage collector. In order to I return to version 2.10
Comment 4 Alexander Kyte 2015-03-02 10:56:57 UTC
If you feel that we are falsely freeing memory, please provide some way to reproduce this bug and we will address it.
Comment 5 Roman 2015-03-02 15:45:25 UTC
I can not reproduce deliberately this bug, it happens once and after some time. Type application is Monogame 2.5

Note You need to log in before you can comment on or make changes to this bug.