Bug 26327 - TabbedPage PropertyChanged event fires twice
Summary: TabbedPage PropertyChanged event fires twice
Status: RESOLVED DUPLICATE of bug 13538
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Debugger (show other bugs)
Version: 5.7
Hardware: PC Mac OS
: Normal normal
Target Milestone: master
Assignee: Jeffrey Stedfast
URL:
Depends on:
Blocks:
 
Reported: 2015-01-23 04:36 UTC by Christopher Svanefalk
Modified: 2015-04-29 07:36 UTC (History)
9 users (show)

See Also:
Tags:
Is this bug a regression?: ---
Last known good build:


Attachments

Description Christopher Svanefalk 2015-01-23 04:36:45 UTC
See the following project:

https://github.com/csvan/TabbedPageDemo

When clicking among the tabs on an Android device, the application output becomes something like:

Nearby
Nearby
Sundays
Sundays
About
About
Sundays
Sundays
Nearby
Nearby
Locality
Locality

The above would indicate that the event is firing twice, rather than just once.
Comment 1 Christopher Svanefalk 2015-01-23 05:13:08 UTC
UPDATE: It turns out this is not a problem with Xamarin.Forms, but rather Xamarin Studio for some reason prints the Debug output twice. Closer investigation with the debugger shows that the event is indeed only fired once, even though XS duplicates the debug output for the same breakpoint.

Posting my install information below for reference.

Xamarin Studio
Version 5.7 (build 661)
Installation UUID: fb249e80-2b94-4e1a-bb82-1f0a76379e63
Runtime:
	Mono 3.12.0 ((detached/a813491)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 312000068

Apple Developer Tools
Xcode 6.1.1 (6611)
Build 6A2008a

Xamarin.Mac
Not Installed

Xamarin.Android
Version: 4.20.0.28 (Business Edition)
Android SDK: /Users/csvanefalk/Library/Developer/android-sdk-osx
	Supported Android versions:
		1.6    (API level 4)
		2.1    (API level 7)
		2.2    (API level 8)
		2.3    (API level 10)
		3.1    (API level 12)
		4.0    (API level 14)
		4.0.3  (API level 15)
		4.1    (API level 16)
		4.2    (API level 17)
		4.3    (API level 18)
		4.4    (API level 19)
		4.4.87 (API level 20)
		5.0    (API level 21)
Java SDK: /usr
java version "1.8.0_25"
Java(TM) SE Runtime Environment (build 1.8.0_25-b17)
Java HotSpot(TM) 64-Bit Server VM (build 25.25-b02, mixed mode)

Xamarin.iOS
Version: 8.6.0.51 (Business Edition)
Hash: dfb682f
Branch: 
Build date: 2015-01-08 13:39:32-0500

Build Information
Release ID: 507000661
Git revision: b70bab61da996da29045ea8ee8aed1a6faedbe78
Build date: 2015-01-05 16:31:31-05
Xamarin addins: 82f6c71490562d6cd125a09287f441902fdac3d7

Operating System
Mac OS X 10.10.1
Darwin Christophers-MacBook-Pro.local 14.0.0 Darwin Kernel Version 14.0.0
    Fri Sep 19 00:26:44 PDT 2014
    root:xnu-2782.1.97~2/RELEASE_X86_64 x86_64
Comment 2 Danish Akhtar 2015-01-23 07:37:18 UTC
I have checked this issue by following the steps mentioned in Bug, we are also getting this issue When we clicking among the tabs on an Android device, the application output
becomes something like:
Nearby
Nearby
Sundays
Sundays
About
About
Sundays
Sundays
Nearby
Nearby
Locality
Locality

Hence marking this as Confirmed.

Supplement info:
adb locat: https://gist.github.com/Mohit-Kheterpal/f03104837a5c03e1dc58
ide logs: https://gist.github.com/Mohit-Kheterpal/3afcb501576226c55006
application output: https://gist.github.com/Mohit-Kheterpal/7264ea3b2c44fdd81b6f

Environment details:
=== Xamarin Studio ===

Version 5.7 (build 661)
Installation UUID: 3dbf10c4-ed30-4e55-8a8b-1704777c7b5f
Runtime:
	Mono 3.12.0 ((detached/a813491)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 312000068

=== Apple Developer Tools ===

Xcode 5.1.1 (5085)
Build 5B1008

=== Xamarin.Mac ===

Version: 1.12.0.4 (Starter Edition)

=== Xamarin.iOS ===

Version: 8.6.1.19 (Trial Edition)
Hash: 80971a6
Branch: 
Build date: 2015-01-21 17:42:51-0500

=== Xamarin.Android ===

Version: 4.20.0.28 (Trial Edition)
Android SDK: /Users/apprpject/Desktop/android-sdk-macosx
	Supported Android versions:
		2.1    (API level 7)
		2.2    (API level 8)
		2.3    (API level 10)
		3.1    (API level 12)
		4.0    (API level 14)
		4.0.3  (API level 15)
		4.1    (API level 16)
		4.2    (API level 17)
		4.3    (API level 18)
		4.4    (API level 19)
		4.4.87 (API level 20)
		5.0    (API level 21)
Java SDK: /usr
java version "1.7.0_65"
Java(TM) SE Runtime Environment (build 1.7.0_65-b17)
Java HotSpot(TM) 64-Bit Server VM (build 24.65-b04, mixed mode)

=== Build Information ===

Release ID: 507000661
Git revision: b70bab61da996da29045ea8ee8aed1a6faedbe78
Build date: 2015-01-05 16:31:31-05
Xamarin addins: 82f6c71490562d6cd125a09287f441902fdac3d7

=== Operating System ===

Mac OS X 10.8.5
Darwin localhost 12.5.0 Darwin Kernel Version 12.5.0
    Sun Sep 29 13:33:47 PDT 2013
    root:xnu-2050.48.12~1/RELEASE_X86_64 x86_64

Xamarin.Forms 1.3.2.6299
Comment 3 David Karlaš 2015-04-29 07:36:18 UTC

*** This bug has been marked as a duplicate of bug 13538 ***

Note You need to log in before you can comment on or make changes to this bug.