Bug 26045 - Camera Preview First time black screen
Summary: Camera Preview First time black screen
Status: CONFIRMED
Alias: None
Product: Android
Classification: Xamarin
Component: General (show other bugs)
Version: 4.20.0
Hardware: PC Windows
: Normal normal
Target Milestone: ---
Assignee: Jonathan Pryor
URL:
Depends on:
Blocks:
 
Reported: 2015-01-14 20:34 UTC by arash
Modified: 2016-03-12 04:51 UTC (History)
2 users (show)

See Also:
Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
the simple xamarin project for demo. please unzip and follow the reproduce steps above. (724.05 KB, application/zip)
2015-01-14 20:39 UTC, arash
Details

Description arash 2015-01-14 20:34:53 UTC
Hi Xamarin Team,

In my project I found a very annoying bug where there is always a black screen flash for about a second when first time I switch to a view with Camera preview . After that if i switch back and forth between the first view and second view (which is camera preview) it works fine and no black flash happening. It only happens when i leave and exit app by back button and go to it again and go to view with camera preview.


I attached a xamarin project which is very simple to demo this.

Steps to reproduce:

Use a android device (mine is galaxy s3 api level 18)

run the attached app. You will see the first view which is green background with a button. Press the button to go to camera preview. . You will see a second full black screen and then the camera preview shows up. 

now press on back button and go back to first view (with green background) now click on button again to go back again to camera view . This time you notice there is no black flash screen anymore. Now if you exit the app with back button and go to app again . You will see after press the button to go to camera preview again the black flash appears. 

My application we really care about polished UI for gaining the user's popularity so I really need some help to resolve this as our product really depends on this issue and it is a deal breaker for us.

Regards,
Arash
Comment 1 arash 2015-01-14 20:39:21 UTC
Created attachment 9359 [details]
the simple xamarin project for demo. please unzip and follow the reproduce steps above.

the simple xamarin project for demo. please unzip and follow the reproduce steps above.
Comment 2 Naqeeb 2015-01-15 05:57:39 UTC
I have checked this issue with sample attached in bug description and also getting the reported behavior.I have observed that when we click first time on 'go to Camera' it gives black screen and when we click second time on it then black screen do not appear.

Hence marking this as Confirmed.

Supplement info:
Application output: https://gist.github.com/saurabh360/b8c1fb2687c04d56b0b9
IDE logs: https://gist.github.com/saurabh360/2637d491d8711042a6d9
adb logcat:https://gist.github.com/Mohit-Kheterpal/5823ad3dfbbe01aff69d



Environment info:
=== Xamarin Studio ===

Version 5.7 (build 661)
Installation UUID: a984b906-a6b3-414c-81f5-68fb983ac835
Runtime:
	Microsoft .NET 4.0.30319.18449
	GTK+ 2.24.22 (MS-Windows theme)
	GTK# 2.12.26

=== Xamarin.Android ===

Version: 4.20.0 (Trial Edition)
Android SDK: D:\MonoForAndroid\AndroidSDK
	Supported Android versions:
		1.6    (API level 4)
		2.1    (API level 7)
		2.2    (API level 8)
		2.3    (API level 10)
		3.1    (API level 12)
		4.0    (API level 14)
		4.0.3  (API level 15)
		4.1    (API level 16)
		4.2    (API level 17)
		4.3    (API level 18)
		4.4    (API level 19)
		4.4.87 (API level 20)
		5.0    (API level 21)
Java SDK: C:\Program Files (x86)\Java\jdk1.7.0_60
java version "1.7.0_60-ea"
Java(TM) SE Runtime Environment (build 1.7.0_60-ea-b15)
Java HotSpot(TM) Client VM (build 24.60-b09, mixed mode, sharing)

=== Build Information ===

Release ID: 507000661
Git revision: b70bab61da996da29045ea8ee8aed1a6faedbe78
Build date: 2015-01-05 11:27:37-05
Xamarin addins: 82f6c71490562d6cd125a09287f441902fdac3d7

=== Operating System ===

Windows 6.2.9200.0 (64-bit)
Comment 3 arash 2016-03-12 04:51:53 UTC
Hi Xamarin Team. 

Did anyone fixed this bug? I opened it a year ago and seems no one if looking into this. it shows it is assigned to Jonathan but not sure what is the status of fix?
I need this urgently for my product it is a big show stopper for my application.

Arash

Note You need to log in before you can comment on or make changes to this bug.