Bug 26033 - Set next statement(CMD_THREAD_SET_IP) + stepping doesn't work as expected
Summary: Set next statement(CMD_THREAD_SET_IP) + stepping doesn't work as expected
Status: RESOLVED FIXED
Alias: None
Product: Runtime
Classification: Mono
Component: Debugger (show other bugs)
Version: unspecified
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Zoltan Varga
URL:
Depends on:
Blocks:
 
Reported: 2015-01-14 15:42 UTC by David Karlaš
Modified: 2015-01-15 19:14 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments

Description David Karlaš 2015-01-14 15:42:29 UTC
Set next statement doesn't work as expected on Mono...
It seems to me like every time when I do SetNextStatment and step method is executed until end of method.

This is how it works on .Net: http://youtu.be/O6dNS-GmSPk
This is how it works on Mono: http://youtu.be/IN46BmHewUo

In .Net video it steps again on line where breakpoint is but Mono just runs until end of method...

Code:
class Program
{
  static void Main()
  {
    System.Console.WriteLine ("Hi");
  }
}
Comment 1 Zoltan Varga 2015-01-15 16:49:00 UTC
This happens because the single stepper starts the current ip as the starting point instead of the ip set by set-next-statement.
Comment 2 Zoltan Varga 2015-01-15 19:14:27 UTC
Fixed in mono master 3a4c4766fa00d259c0fa750734341ae8b316e266.

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.


Create a new report for Bug 26033 on Developer Community or GitHub if you have new information to add and do not yet see a matching report.

  • Export the original title and description: Developer Community HTML or GitHub Markdown
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments


Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Related Links: