Bug 25869 - CarouselPage flicker when it moves to current page on iOS
Summary: CarouselPage flicker when it moves to current page on iOS
Status: VERIFIED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms (show other bugs)
Version: 1.3.0
Hardware: Macintosh Mac OS
: Normal normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2015-01-09 07:56 UTC by tim.ahrentlov
Modified: 2015-01-23 07:11 UTC (History)
5 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Test case to reproduce the bug (4.11 MB, application/zip)
2015-01-09 07:57 UTC, tim.ahrentlov
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description tim.ahrentlov 2015-01-09 07:56:57 UTC
On iOS, the CarouselPage visibly goes through all pages when it navigates to the current page upon receiving focus. 

To reproduce load and run attached project on iOS. The try this:

1. Swipe left until purple page is reached.
2. Press menu and choose detail 2.
3. Press menu and choose detail 1.

Notice the flickering "scrollto" effect as the CarouselPage animates it's way through the pages to the current purple page.

This bug has been present since 1.2.x

Android does not have this bug. I do not know about windows.
Comment 1 tim.ahrentlov 2015-01-09 07:57:54 UTC
Created attachment 9299 [details]
Test case to reproduce the bug
Comment 3 Jason Smith [MSFT] 2015-01-16 22:05:57 UTC
Should be fixed in 1.3.2-pre1
Comment 4 Parmendra Kumar 2015-01-23 07:11:27 UTC
I have checked this issue with 1.3.2.6299-pre1 and its working fine at my end.

So I am going to verify this issue.

Environment info:

=== Xamarin Studio ===

Version 5.7.1 (build 14)
Installation UUID: 1a096c6f-0678-402e-89b2-a2c10f7e80e4
Runtime:
	Mono 3.12.0 ((detached/a813491)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 312000068

=== Apple Developer Tools ===

Xcode 6.1 (6602)
Build 6A1052c

=== Xamarin.iOS ===

Version: 8.6.1.19 (Business Edition)
Hash: 80971a6
Branch: 
Build date: 2015-01-21 17:42:51-0500

=== Xamarin.Mac ===

Version: 1.10.0.18 (Business Edition)

=== Xamarin.Android ===

Version: 4.20.0.28 (Business Edition)
Android SDK: /Users/360_macmini/Desktop/android-sdk-macosx
	Supported Android versions:
		2.1    (API level 7)
		2.2    (API level 8)
		2.3    (API level 10)
		3.1    (API level 12)
		4.0    (API level 14)
		4.0.3  (API level 15)
		4.1    (API level 16)
		4.2    (API level 17)
		4.3    (API level 18)
		4.4    (API level 19)
		4.4.87 (API level 20)
		5.0    (API level 21)
Java SDK: /usr
java version "1.7.0_65"
Java(TM) SE Runtime Environment (build 1.7.0_65-b17)
Java HotSpot(TM) 64-Bit Server VM (build 24.65-b04, mixed mode)

=== Build Information ===

Release ID: 507010014
Git revision: a4dd61ad7f8b3695be4b17bcb5c3ae6b81438cf7
Build date: 2015-01-19 15:21:09-05
Xamarin addins: 081208fe3bbf40e24a562867c6c7fba20a9b94b6

=== Operating System ===

Mac OS X 10.9.4
Darwin ShrutiMac.local 13.3.0 Darwin Kernel Version 13.3.0
    Tue Jun  3 21:27:35 PDT 2014
    root:xnu-2422.110.17~1/RELEASE_X86_64 x86_64