This is Xamarin's bug tracking system. For product support, please use the support links listed in your Xamarin Account.
Bug 25841 - Xamarin Studio Classic iOS Project build fails with error "No valid iPhone code signing keys found in keychain" against default simulator
Summary: Xamarin Studio Classic iOS Project build fails with error "No valid iPhone co...
Status: VERIFIED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: iOS add-in (show other bugs)
Version: 5.7
Hardware: Macintosh Mac OS
: --- major
Target Milestone: 5.7.1
Assignee: Jeffrey Stedfast
URL:
Depends on:
Blocks:
 
Reported: 2015-01-08 13:47 UTC by Rob DeRosa
Modified: 2015-01-15 09:48 UTC (History)
3 users (show)

See Also:
Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Screenshot (127.94 KB, image/png)
2015-01-08 14:05 UTC, Rob DeRosa
Details

Description Rob DeRosa 2015-01-08 13:47:01 UTC
In the current beta and alpha channels, new Classic iOS projects will not build against a simulator.

I marked this as a major since a default project template doesn't build out of the box. Feel free to modify as necessary knowing this is a Classic project template and may be considered deprecated.


Steps to reproduce:

1) Add a new Classic Empty iOS Project to a solution
2) Select the default simulator (example: iPhone 6  iOS 8.1)
3) Build the project
4) Get 'code signing cert' error

This works fine with a Unified iOS project - no build error w/ same simulator selected.

---------------------------------------

=== Xamarin Studio ===

Version 5.7 (build 661)
Installation UUID: b29db709-b812-4371-835d-d804f0165289
Runtime:
	Mono 3.12.0 ((detached/a813491)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 312000068

=== Apple Developer Tools ===

Xcode 6.1.1 (6611)
Build 6A2008a

=== Xamarin.iOS ===

Version: 8.6.0.50 (Enterprise Edition)
Hash: 561dfed
Branch: 
Build date: 2015-01-06 17:56:14-0500

=== Xamarin.Android ===

Version: 4.20.0.28 (Enterprise Edition)
Android SDK: /Users/Rob/Library/Developer/Xamarin/android-sdk-macosx
	Supported Android versions:
		2.1   (API level 7)
		2.2   (API level 8)
		2.3   (API level 10)
		3.1   (API level 12)
		4.0   (API level 14)
		4.0.3 (API level 15)
		4.3   (API level 18)
		4.4   (API level 19)
		5.0   (API level 21)
Java SDK: /usr
java version "1.6.0_65"
Java(TM) SE Runtime Environment (build 1.6.0_65-b14-466.1-11M4716)
Java HotSpot(TM) 64-Bit Server VM (build 20.65-b04-466.1, mixed mode)

=== Xamarin.Mac ===

Version: 1.10.0.18 (Enterprise Edition)

=== Build Information ===

Release ID: 507000661
Git revision: b70bab61da996da29045ea8ee8aed1a6faedbe78
Build date: 2015-01-05 16:31:31-05
Xamarin addins: 82f6c71490562d6cd125a09287f441902fdac3d7

=== Operating System ===

Mac OS X 10.10.1
Darwin Robs-MacBook-Pro.local 14.0.0 Darwin Kernel Version 14.0.0
    Fri Sep 19 00:26:44 PDT 2014
    root:xnu-2782.1.97~2/RELEASE_X86_64 x86_64
Comment 1 Jeffrey Stedfast 2015-01-08 13:51:14 UTC

*** This bug has been marked as a duplicate of bug 25406 ***
Comment 2 Rob DeRosa 2015-01-08 13:55:04 UTC
Just wanted to note that the error message for this issue is different from that of https://bugzilla.xamarin.com/show_bug.cgi?id=25406.

I also tried the recommended workaround mentioned in 25406 and it did not work - build error persists.
Comment 3 Rob DeRosa 2015-01-08 14:05:07 UTC
Created attachment 9287 [details]
Screenshot
Comment 4 Jeffrey Stedfast 2015-01-08 14:20:37 UTC
Ah, yea, it is a different issue.
Comment 5 Jeffrey Stedfast 2015-01-08 14:29:22 UTC
fixed in git master
Comment 6 Shruti 2015-01-15 01:39:14 UTC
I have checked this issue with latest master build and getting same issue. Here is the screencast regarding same . In this screencast, first I reproduced issue with builds given in comment(0). Then verify the same with latest master builds.
http://www.screencast.com/t/k2OOX7DEhv


IDE Log : https://gist.github.com/Shruti360/bd586eae6ef194176bcd


Environment Info:
=== Xamarin Studio ===

Version 5.8 (build 208)
Installation UUID: 67eaf3b4-f8a7-4ab4-a9df-3197350ca5dc
Runtime:
	Mono 3.12.0 ((detached/a813491)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 312000068

=== Xamarin.Android ===

Version: 4.20.0.28 (Enterprise Edition)
Android SDK: /Users/ixamarin78/Desktop/android-sdk-macosx
	Supported Android versions:
		2.1    (API level 7)
		2.2    (API level 8)
		2.3    (API level 10)
		3.1    (API level 12)
		4.0    (API level 14)
		4.0.3  (API level 15)
		4.1    (API level 16)
		4.2    (API level 17)
		4.3    (API level 18)
		4.4    (API level 19)
		4.4.87 (API level 20)
		5.0    (API level 21)
Java SDK: /usr
java version "1.8.0_25"
Java(TM) SE Runtime Environment (build 1.8.0_25-b17)
Java HotSpot(TM) 64-Bit Server VM (build 25.25-b02, mixed mode)

=== Xamarin Android Player ===

Version: Unknown version
Location: /Applications/Xamarin Android Player.app

=== Apple Developer Tools ===

Xcode 6.1.1 (6611)
Build 6A2008a

=== Xamarin.iOS ===

Version: 7.5.99.136 (Enterprise Edition)
Hash: 92ce6f2
Branch: 
Build date: 2014-08-29 17:01:50-0400

=== Xamarin.Mac ===

Version: 1.11.3.0 (Enterprise Edition)

=== Build Information ===

Release ID: 508000208
Git revision: af2ecb3305d213b204c229856b6000e45ffc2ffe
Build date: 2015-01-14 14:52:56-05
Xamarin addins: 0e980c35c87117d4a9a698adc5c9adc30ce2d269

=== Operating System ===

Mac OS X 10.10.0
Darwin XamnewiMac.local 14.0.0 Darwin Kernel Version 14.0.0
    Fri Sep 19 00:26:44 PDT 2014
    root:xnu-2782.1.97~2/RELEASE_X86_64 x86_64
Comment 7 Shruti 2015-01-15 02:36:04 UTC
Adding more observation with XS 5.7.1.4,  Getting same issue with this build.
Screencast regarding same : http://www.screencast.com/t/MLFjPdWU

Complete Environment Info :
=== Xamarin Studio ===

Version 5.7.1 (build 4)
Installation UUID: 67eaf3b4-f8a7-4ab4-a9df-3197350ca5dc
Runtime:
	Mono 3.12.0 ((detached/a813491)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 312000068

=== Apple Developer Tools ===

Xcode 6.1.1 (6611)
Build 6A2008a

=== Xamarin.iOS ===

Version: 8.6.0.52 (Enterprise Edition)
Hash: 7c4c2c5
Branch: 
Build date: 2015-01-08 22:29:16-0500

=== Xamarin.Android ===

Version: 4.20.0.28 (Enterprise Edition)
Android SDK: /Users/ixamarin78/Desktop/android-sdk-macosx
	Supported Android versions:
		2.1    (API level 7)
		2.2    (API level 8)
		2.3    (API level 10)
		3.1    (API level 12)
		4.0    (API level 14)
		4.0.3  (API level 15)
		4.1    (API level 16)
		4.2    (API level 17)
		4.3    (API level 18)
		4.4    (API level 19)
		4.4.87 (API level 20)
		5.0    (API level 21)
Java SDK: /usr
java version "1.8.0_25"
Java(TM) SE Runtime Environment (build 1.8.0_25-b17)
Java HotSpot(TM) 64-Bit Server VM (build 25.25-b02, mixed mode)

=== Xamarin.Mac ===

Version: 1.11.3.0 (Enterprise Edition)

=== Build Information ===

Release ID: 507010004
Git revision: b46fa13b30e60eb2318c06f2e320c76a5822b40c
Build date: 2015-01-14 17:48:56-05
Xamarin addins: 90f47f436cbffe4b2a158cb3c7b407d257400216

=== Operating System ===

Mac OS X 10.10.0
Darwin XamnewiMac.local 14.0.0 Darwin Kernel Version 14.0.0
    Fri Sep 19 00:26:44 PDT 2014
    root:xnu-2782.1.97~2/RELEASE_X86_64 x86_64
Comment 8 Jeffrey Stedfast 2015-01-15 09:01:28 UTC
According to the screencasts, it works perfectly fine with Simulator builds which is all we care about.
Comment 9 Shruti 2015-01-15 09:48:11 UTC
My fault to reopen this issue.  

We have checked that we are able to deploy application on simulator on a machine having no provisioning profile and certificates.

Screencast regarding verification:
http://www.screencast.com/t/fJDphDct4
http://www.screencast.com/t/MLFjPdWU


Hence, Closing this issue

Note You need to log in before you can comment on or make changes to this bug.