Bug 25751 - sgen-cementing-test randomly crashes
Summary: sgen-cementing-test randomly crashes
Status: RESOLVED NOT_REPRODUCIBLE
Alias: None
Product: Runtime
Classification: Mono
Component: GC (show other bugs)
Version: unspecified
Hardware: PC Mac OS
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2015-01-06 14:20 UTC by Zoltan Varga
Modified: 2017-07-12 23:09 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NOT_REPRODUCIBLE

Description Zoltan Varga 2015-01-06 14:20:23 UTC
The following crashes on master after a while:
while true; do MONO_GC_PARAMS="major=marksweep-conc" ./mono --optimize=all --debug sgen-cementing-stress.exe || break; done

This also happens on wrench.

Stacktrace:

  at <unknown> <0xffffffff>
  at (wrapper managed-to-native) object.__icall_wrapper_mono_gc_alloc_obj (intptr,intptr) <IL 0x0000e, 0xffffffff>
  at (wrapper alloc) object.AllocSmall (intptr) <IL 0x00056, 0xffffffff>
  at PinList.MakeList (int) [0x0000b] in /Users/vargaz/git/mono/mono/tests/sgen-cementing-stress.cs:24
  at PinList.Work (PinList,PinList/Pinned[],int) [0x00018] in /Users/vargaz/git/mono/mono/tests/sgen-cementing-stress.cs:45
  at PinList.Work (PinList,PinList/Pinned[],int) [0x00049] in /Users/vargaz/git/mono/mono/tests/sgen-cementing-stress.cs:54
  at PinList.Work (PinList,PinList/Pinned[],int) [0x00049] in /Users/vargaz/git/mono/mono/tests/sgen-cementing-stress.cs:54
  at PinList.Work (PinList,PinList/Pinned[],int) [0x00049] in /Users/vargaz/git/mono/mono/tests/sgen-cementing-stress.cs:54
  at PinList.Work (PinList,PinList/Pinned[],int) [0x00049] in /Users/vargaz/git/mono/mono/tests/sgen-cementing-stress.cs:54
  at PinList.Work (PinList,PinList/Pinned[],int) [0x00049] in /Users/vargaz/git/mono/mono/tests/sgen-cementing-stress.cs:54
  at PinList.Work (PinList,PinList/Pinned[],int) [0x00049] in /Users/vargaz/git/mono/mono/tests/sgen-cementing-stress.cs:54
  at PinList.Work (PinList,PinList/Pinned[],int) [0x00049] in /Users/vargaz/git/mono/mono/tests/sgen-cementing-stress.cs:54
  at PinList.Work (PinList,PinList/Pinned[],int) [0x00049] in /Users/vargaz/git/mono/mono/tests/sgen-cementing-stress.cs:54
  at PinList.Work (PinList,PinList/Pinned[],int) [0x00049] in /Users/vargaz/git/mono/mono/tests/sgen-cementing-stress.cs:54
  at PinList.Work (PinList,PinList/Pinned[],int) [0x00049] in /Users/vargaz/git/mono/mono/tests/sgen-cementing-stress.cs:54
Comment 1 Mark Probst 2015-01-13 16:44:06 UTC
I cannot reproduce this with master on OSX.  I tried 32 and 64 bit.
Comment 2 Zoltan Varga 2015-01-13 16:50:46 UTC
This (or some variation of it) crashes on wrench:
http://wrench.mono-project.com/Wrench/WebServices/Download.aspx?workfile_id=3669164
Comment 3 Mark Probst 2015-01-13 17:06:05 UTC
That's a crash with the split nursery.

How often do you have to run that test on your machine to make it crash?
Comment 4 Zoltan Varga 2015-01-13 18:10:09 UTC
Its a pretty random crash.

Here is another crash with ms-conc:
http://wrench.mono-project.com/Wrench/WebServices/Download.aspx?workfile_id=3618493
Comment 5 Ludovic Henry 2017-07-12 23:09:10 UTC
Can we still reproduce with latest version of mono? Marking as resolved for now, if it occurs again, let's reopen it.