Bug 25591 - RaiseChild/LowerChild appear reversed on Android
Summary: RaiseChild/LowerChild appear reversed on Android
Status: VERIFIED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms (show other bugs)
Version: 1.3.0
Hardware: PC Windows
: Normal normal
Target Milestone: ---
Assignee: Bugzilla
URL:
: 26264 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-12-23 09:45 UTC by ron.jacobs@newellco.com
Modified: 2015-01-30 13:37 UTC (History)
9 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description ron.jacobs@newellco.com 2014-12-23 09:45:20 UTC
I found an issue with RaiseChild / LowerChild on Android. The functionality is reversed!

I had to do this to actually raise/lower a child:
#region RaiseChild defect
void ChildToFront(View view)
{
Device.OnPlatform(iOS: () => RaiseChild(view), Android: () => LowerChild(view));
}
void ChildToRear(View view)
{
Device.OnPlatform(iOS: () => LowerChild(view), Android: () => RaiseChild(view));
}
Comment 1 Ram Chandra 2014-12-31 11:54:47 UTC
I have checked this issue and I am able to reproduce this behavior.

When I used used the RaiseChild / LowerChild on Android I observed that RaiseChild / LowerChild functionality is not working properly. It's functionality is reversed.

Screencast: http://www.screencast.com/t/hBBiqxfF6Wg

Application output: https://gist.github.com/Rajneesh360Logica/28daa328fa2f45d2012c
Device Logs: https://gist.github.com/Rajneesh360Logica/83cbf8f747382075ae1c

Note: This is working fine on iOS.

Environment Info:

Microsoft Visual Studio Professional 2013
Version 12.0.30723.00 Update 3
Microsoft .NET Framework
Version 4.5.50938
Installed Version: Professional
Xamarin   3.8.150.0 (10cfd178d55287f09c85f5a1e604dfe20889a40f)
Xamarin.Android   4.20.0.28 (ba9bbbdd44cfdc4bf485e8885bd2ad24fba525f7)
Xamarin.iOS   8.4.0.0 (840a925103a0bf4a856507f13d5eaee3c1579c2f)
Comment 2 Rui Marinho 2015-01-15 07:02:45 UTC
Should be fixed in 1.3.2-pre1.2
Comment 3 Jason Smith [MSFT] 2015-01-16 22:10:22 UTC
he meant 1.3.2-pre1
Comment 4 Sadik Ali 2015-01-30 08:02:00 UTC
I have checked this issue with following builds:

Xamarin.Forms.1.3.2.6309-pre2

Microsoft Visual Studio Professional 2013
Version 12.0.30723.00 Update 3
Microsoft .NET Framework
Version 4.5.51641
Installed Version: Professional
Xamarin   3.9.236.0 (d6a2cae)
Xamarin.Android   4.20.0.34 (49a04b966feb40dfdba49d57ba16249b66d606a6)
Xamarin.iOS   8.6.0.0 (eb24bdcf5cba2c12b673a07e0a8cce368b9563b3)

I have checked the functionality of RaiseChild / LowerChild on Android and observed that both RaiseChild and LowerChild are working fine.

This issue has been fixed. Hence I am closing this issue.
Comment 5 Jon Goldberger [MSFT] 2015-01-30 13:37:30 UTC
*** Bug 26264 has been marked as a duplicate of this bug. ***