Bug 25544 - Documentation on method with co/contravariant parameters raises CS1569: Error generating XML documentation
Summary: Documentation on method with co/contravariant parameters raises CS1569: Error...
Status: RESOLVED FIXED
Alias: None
Product: Compilers
Classification: Mono
Component: C# (show other bugs)
Version: unspecified
Hardware: All All
: --- normal
Target Milestone: ---
Assignee: Marek Safar
URL:
Depends on:
Blocks:
 
Reported: 2014-12-19 20:05 UTC by Alexander Köplinger
Modified: 2015-01-02 17:18 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
test.cs (599 bytes, text/plain)
2014-12-19 20:05 UTC, Alexander Köplinger
Details

Description Alexander Köplinger 2014-12-19 20:05:26 UTC
Created attachment 9154 [details]
test.cs

Compiling the attached sample results in the follow compiler error:


$ mcs -target:library -doc:test.xml test.cs 
error CS1569: Error generating XML documentation file `test.xml' (`test.cs(7,24): BatchBlock<T>.ISourceBlock<T[]>.ConsumeMessage(ITargetBlock<T[]>)')
Compilation failed: 1 error(s), 0 warnings

Removing the xml doc comment from the ConsumeMessage() method makes the error go away.
Comment 1 Alexander Köplinger 2014-12-25 17:06:51 UTC
I found out that the issue is the nested array.

Here's a PR with a possible fix: https://github.com/mono/mono/pull/1480
Comment 2 Marek Safar 2015-01-02 17:18:32 UTC
Fixed in master

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.


Create a new report for Bug 25544 on Developer Community or GitHub if you have new information to add and do not yet see a matching report.

  • Export the original title and description: Developer Community HTML or GitHub Markdown
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments


Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Related Links: