Bug 25499 - Store the Provisioning Profile's Name instead of the GUID in .csproj file
Summary: Store the Provisioning Profile's Name instead of the GUID in .csproj file
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: iOS add-in (show other bugs)
Version: 5.4
Hardware: Macintosh Mac OS
: Low enhancement
Target Milestone: Future Cycle (TBD)
Assignee: Jeffrey Stedfast
URL:
Depends on:
Blocks:
 
Reported: 2014-12-18 10:33 UTC by Neal
Modified: 2016-11-08 17:25 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Neal 2014-12-18 10:33:41 UTC
Jeff,

I have a suggestion that I think will help solve some bundle signing issues.  I don't use "Automatic" profile types any more due to issues with my account with multiple team ID's, apps, etc. and it just isn't working well for my use.  Instead I pick the specific profile such as AppName Ad-Hoc which is the name assigned to the provision in the Apple iOS Dev portal.  

XamStudio is storing the GUID for that profile in the project file.  If I make any changes to the devices that are part of that profile such as removing a device and then refresh Xcode the GUID will change effectively breaking my signing in the project and probably a problem for CI systems.  If you instead store the selected provisioning profile name (not GUID) and do a name match then it should never break the project config.  This will also work across devs in the case where I update Xcode and they don't refresh but they do an update of the project from source control where the GUID is stored which they don't have.

Hope this makes sense but after moving away from the Automatic modes this problem has revealed itself and it looks like a simple fix.

FYI
Comment 1 Jeffrey Stedfast 2016-09-19 18:15:27 UTC
Looks like Xcode8 has started doing this as well for the same reason
Comment 2 Jeffrey Stedfast 2016-11-01 17:53:22 UTC
Sadly I didn't get around to this until too late in the cycle9 roadmap, but I do have stuff read to go for cycle10.

PR for Xamarin.iOS: https://github.com/xamarin/xamarin-macios/pull/1087
PR for Xamarin Studio: https://github.com/xamarin/md-addins/pull/1264
Comment 3 xamarin-release-manager 2016-11-08 17:25:59 UTC
Fixed in version 6.3.0.16 (master)

Author: Jeffrey Stedfast
Commit: 7d9847155d782ab82d41c91ab30f0c412a708f06 (xamarin/md-addins)
Included in Commit: 4cbe705836056f53f5f2d51668eb354fad5cc92e (mono/monodevelop)