Bug 25498 - System.IO.SynchronizedStream does not call Close on wrapped Stream
Summary: System.IO.SynchronizedStream does not call Close on wrapped Stream
Status: RESOLVED FIXED
Alias: None
Product: Class Libraries
Classification: Mono
Component: mscorlib (show other bugs)
Version: master
Hardware: PC Linux
: --- normal
Target Milestone: Untriaged
Assignee: Marek Safar
URL:
Depends on:
Blocks:
 
Reported: 2014-12-18 10:21 UTC by Grégoire Seux
Modified: 2015-01-13 09:00 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments

Description Grégoire Seux 2014-12-18 10:21:35 UTC
System.IO.SynchronizedStream does not override Close method from Stream.

This leads to unexpected behavior after calling Close on this stream.

For instance:

> var _stream = Stream.Synchronized(new MemoryStream());
> _stream.Close();
> _stream.CanRead // return true

usual streams do return false when CanRead is called after Close

This is due to Close not closing the underlying stream, whereas CanRead forward the call to it.
Comment 1 Marek Safar 2015-01-13 09:00:19 UTC
Fixed in master

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.


Create a new report for Bug 25498 on Developer Community or GitHub if you have new information to add and do not yet see a matching report.

  • Export the original title and description: Developer Community HTML or GitHub Markdown
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments


Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Related Links: