Bug 25488 - iOS AOT fails with "unknown opcode jmp in mono_arch_output_basic_block()" error
Summary: iOS AOT fails with "unknown opcode jmp in mono_arch_output_basic_block()" error
Status: RESOLVED NOT_REPRODUCIBLE
Alias: None
Product: Runtime
Classification: Mono
Component: General (show other bugs)
Version: 3.8.0
Hardware: PC Mac OS
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2014-12-18 04:31 UTC by Prashant Cholachagudda
Modified: 2018-02-28 22:39 UTC (History)
5 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NOT_REPRODUCIBLE

Description Prashant Cholachagudda 2014-12-18 04:31:36 UTC
We get asserts when we try to compile our project to run on hardware
(works on the simulator), and it turns out just trying to build a simple F#
project shows the same error:
 
Mono Ahead of Time compiler - compiling assembly
/Users/james/svox_workspace/newgit/softphones/Test64/obj/iPhone/Release/mtouch-cache/64/Build/FSharp.Core.dll
 
unknown opcode jmp in mono_arch_output_basic_block()
 
* Assertion: should not be reached at
../../../../../mono/mono/mini/../../../mono-extensions/mono/mini/mini-arm64.c:3854
 
Sample project https://www.dropbox.com/s/olcppaym5mpgr6m/Test64.tar?dl=0

Version Information:

Configuration:
 
=== Xamarin Studio ===
 
Version 5.7 (build 657)
Installation UUID: 6dda1873-b6da-4249-934b-53ec9898b482
Runtime:
Mono 3.12.0 ((detached/a813491)
GTK+ 2.24.23 (Raleigh theme)
 
Package version: 312000068
 
=== Apple Developer Tools ===
 
Xcode 6.1 (6604)
Build 6A1052d
 
=== Xamarin.iOS ===
 
Version: 8.6.0.36 (Business Edition)
Hash: fb82d4e
Branch:
Build date: 2014-12-16 22:30:17-0500
 
=== Xamarin.Android ===
 
Version: 4.20.0.28 (Starter Edition)
Android SDK: /Users/james/Library/Developer/Xamarin/android-sdk-mac_x86
Supported Android versions:
2.1 (API level 7)
2.2 (API level 8)
2.3 (API level 10)
3.1 (API level 12)
4.0 (API level 14)
4.0.3 (API level 15)
Java SDK: /usr
No Java runtime present, requesting install.
 
=== Xamarin.Mac ===
 
Not Installed
 
=== Build Information ===
 
Release ID: 507000657
Git revision: 012ec6963a2949d3773b96cee5bc4a05dbada096
Build date: 2014-12-16 15:34:30-05
Xamarin addins: 39ab76ee8d2bc1539d561fd800123124d5ee8bdb
 
=== Operating System ===
 
Mac OS X 10.10.0
Darwin James-Moores-iMac.local 14.0.0 Darwin Kernel Version 14.0.0
Fri Sep 19 00:26:44 PDT 2014
root:xnu-2782.1.97~2/RELEASE_X86_64 x86_64
Comment 2 Ludovic Henry 2018-02-28 22:39:12 UTC
We don't have access to the test case anymore. Can you still reproduce with latest version of Mono? If so, please provide test case and reopen. Thank you.