Bug 25480 - OutputPath property is not set for this project
Summary: OutputPath property is not set for this project
Status: VERIFIED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Project Model (show other bugs)
Version: 5.5
Hardware: PC Mac OS
: High normal
Target Milestone: (C7)
Assignee: David Karlaš
URL:
Depends on:
Blocks:
 
Reported: 2014-12-17 17:59 UTC by John Miller [MSFT]
Modified: 2016-09-09 10:57 UTC (History)
18 users (show)

See Also:
Tags:
Is this bug a regression?: ---
Last known good build:


Attachments

Description John Miller [MSFT] 2014-12-17 17:59:29 UTC
**Overview:**

   The OutputPath appears to be correct in the .csproj files, but occassionaly XS will fail to compile with the below error:

> /Library/Frameworks/Mono.framework/Versions/3.10.0/lib/mono/4.5/Microsoft.Common.targets: Error: 'OutputPath' property is not set for this project. Usually this is caused by invalid Configuration/Platform combination. Original values: Configuration: Debug Platform: iPhoneSimulator. 

**Steps to Reproduce:**

   Unknown.

**Actual Results:**

   The project cannot be compiled and the OutputPath appears to be set correctly. 

**Expected Results:**

   No errors. 

**Additional Information:**

   Attached are the (private) customer .csproj files. 
   The same .sln with the attached project files compiles and builds successfully if opened in Visual Studio 2013.
Comment 4 Jason Roe 2014-12-17 23:13:52 UTC
XS version is 5.5.4 (build 15)
Comment 6 Jon Goldberger [MSFT] 2015-02-02 15:58:54 UTC
I have seen this issue to. Reproduced using XamlSamples sample solution. See this forum thread:
http://forums.xamarin.com/discussion/comment/100329/#Comment_100329'

However adjusting the Configuration Mappings as suggested does not resolve the issue. 

I also noted an odd thing about Debug builds failing for the PCL when the IOS project is set to build with Debug|iPhoneSimulator. See screen cast: http://screencast.com/t/nWmmbY7yxAwZ

Build Output: https://gist.github.com/jgold6/71033dea39c75b0abd71


## Steps to reproduce:

1. Download the XamlSamples app: http://developer.xamarin.com/samples/XAMLSamples/
2. Open in Xamarin Studio on the Mac
3. Set the iOS project as the startup project.
4. Elect the Debug | IphoneSimulator configuration.
5. Launch iOS project to a simulator.

Expected result: App will build and launch.

Actual result: Project does not build. (See above listed build output)

## Note

All configuration mappings are set as suggested by hutch in the above linked forum post. 

In the screen cast you see that I can build the PCL by itself in Debug config as long as I do not have the iOS project build in Debug config. See above screencast.
Comment 7 Jon Goldberger [MSFT] 2015-02-02 15:59:25 UTC
Added more info.
Comment 8 Jon Goldberger [MSFT] 2015-02-02 16:00:31 UTC
Additional note: I tested the above in comment 6 with XS 5.7 and 5.7.1
Comment 9 Mikayla Hutchinson [MSFT] 2015-02-02 16:13:36 UTC
Should be fixed by https://github.com/mono/monodevelop/commit/7cd8785027d484a1ff7c735b5629dede048a72c8 but I don't have a Mac right now to test.
Comment 10 Mikayla Hutchinson [MSFT] 2015-02-02 16:48:21 UTC
Actually, that's not going to fix it.

Looks like, xbuild only runs AssignProjectConfiguration when it's building a sln file and is not running inside an IDE.

Whereas MSBuild always runs AssignProjectConfiguration, regardless whether CurrentSolutionConfigurationContents has a value or not.

So fixing that is going to need some work on xbuild.
Comment 11 Mikayla Hutchinson [MSFT] 2015-02-02 16:56:38 UTC
Another thought - maybe when we run the MSBuild task, it's somehow getting properties from the current project. And because it has no Platform property set, it might pick up the Platform from the referencing project.
Comment 12 Mikayla Hutchinson [MSFT] 2015-02-02 17:02:49 UTC
Scratch that, I don't think the Platform can be null, even though the builder checks for it.

This might work as a quick workaround for xbuild's AssignProjectConfiguration:

https://gist.github.com/mhutch/96acdcfabd16b69aa5ba
Comment 13 Ben Beckley 2015-02-12 18:54:39 UTC
I too have run into this issue while working with XAMLSamples. Jon's repro steps in comment 6 consistently bring the issue forth. I have also found that building the Android project first, and then building the iOS project results in no errors.

After encountering the OutputPath error, try following these steps to make the projects build:

1. Quit out of your Xamarin Studio
2. Open your Xamarin Studio and XAMLSamples project
3. Select XamlSamples.Android as your Startup Project
4. Build/Rebuild the project
5. Observe that there are no errors
6. Select XamlSamples.iOS as your Startup Project
7. Build/Rebuild the project
8. Observe that there are no errors

I have not noticed that cleaning projects/solution affects the outcome for these steps. The same goes with Release/Debug selection. 

This was with a fresh pull from xamarin-forms-samples master commit efb437d109. I am using XS 5.7.1.
Comment 14 Alessandro 2015-06-27 17:37:03 UTC
I have the same problem but I am not able to solve it...
There is a solution?

This is what I have

/Library/Frameworks/Mono.framework/Versions/4.0.1/lib/mono/4.5/Microsoft.Common.targets: Error: 'OutputPath' property is not set for this project. Usually this is caused by invalid Configuration/Platform combination. Original values: Configuration: Debug Platform: iPhone. (IWapp.Droid)
Comment 15 T.J. Purtell 2015-07-08 23:50:29 UTC
This is occurring for one of my team mates.  Spent a whole day reinstalling things, downgrading things, etc.  I think we started on an early June version, and are using the end of June version now.

It always fails in this way for him, but no one on my team has this issue.  I am wondering if there is something environment based happening here.
Comment 16 Dan Vanderboom 2015-09-17 15:52:30 UTC
I'm getting this error as well.

To reproduce:

1. Install Xamarin Studio v5.9.6 (build 23). Latest version at the time of this report.
2. Create new solution: Cross-platform App, "Blank Xamarin.Forms App".

Xamarin Studio creates the new solution with four projects: one for iOS, one for Android, a common Xamarin Forms project, and a UITests project.

3. Update all NuGet packages in all projects, including for Xamarin.Forms and Xamarin.TestCloud.Agent.
4. Switch to Unit Tests view: View menu, select "Unit Testing".
5. Press the "Run All" button in the Unit Tests window.

Two errors appear (one for the iOS project, another for the Android project): "OutputPath property is not set for this project. Usually this is caused by invalid Configuration/Platform combination..."
Comment 17 Dan Vanderboom 2015-09-18 10:13:41 UTC
When I saw that Xamarin Studio 5.9.7 was available today, I downloaded and installed it to find out if it would fix the error described in this bug report. It didn't help.

I then installed Xamarin Studio 5.9.5, and had the same problem. However, on another Mac where I have 5.9.5 installed, I performed the same test: created the same new Xamarin Forms project with unit tests, ran the unit tests, and it worked.

So clearly, with 5.9.5 failing on one machine and succeeding on another, something else in the environment must be causing the problem. I just have no idea what.
Comment 18 David Karlaš 2015-09-22 05:27:39 UTC
I fixed this in mono master and it will be part of Cycle 7. Workaround this problem is to correct file paths in your .sln file and in <ProjectReference> in .csproj have same chars casing like file system.

For example...
https://github.com/xamarin/xamarin-forms-samples/blob/master/XAMLSamples/XamlSamples.sln#L6
has value "XamlSamples\XamlSamples\XamlSamples.csproj" and 
https://github.com/xamarin/xamarin-forms-samples/blob/master/XAMLSamples/xamlsamples/xamlsamples.ios/XamlSamples.iOS.csproj#L86 has value Include="..\XamlSamples\XamlSamples.csproj".

Both have "XamlSamples" but file system has "xamlsamples"(lower case) see folder name here: https://github.com/xamarin/xamarin-forms-samples/tree/master/XAMLSamples which is lowercase...
Comment 19 David Karlaš 2015-09-22 05:29:17 UTC
Fixed in master with commits 76c6a08e730393927b6851709cdae1d397cbcc3a or 6c066a6580729eadc8c88f4e3d26f9c576ec4b8e.
Comment 20 David Karlaš 2015-09-23 10:46:50 UTC
Hi Dan,

I fixed problem with XamlSamples, but I'm not 100% anymore if you are having same problem... Can you try building solution outside Xamarin Studio with "xbuild" command from Terminal in folder where you .sln file is?

That way I will know if fix for XamlSamples fixes also your problem.

Thank you,
David
Comment 21 Dan Vanderboom 2015-09-24 11:01:04 UTC
Hi David, using a brand new Xamarin Forms solution and an update to Xamarin.iOS 9.0.1.20, I'm getting this OutputPath bug when trying to build the UITests project. When I build the solution using xbuild, it is successful.

I checked all of the paths for projects in the .sln file, and found that they matched with exact case, and still the problem exists. If the XamlSamples solution was set up with incorrect path casing, this doesn't seem to be the issue with newly created solutions.
Comment 22 Dan Vanderboom 2015-09-24 11:02:02 UTC
All current version information:

=== Xamarin Studio ===

Version 5.9.7 (build 9)
Installation UUID: 87834ea3-1dc5-42fa-a4fe-7ff662cf9fd0
Runtime:
	Mono 4.0.4 ((detached/cb6d6b2)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 400040002

=== Apple Developer Tools ===

Xcode 6.4 (7720)
Build 6E35b

=== Xamarin.iOS ===

Version: 9.0.1.20 (Business Edition)
Hash: d8e9592
Branch: master
Build date: 2015-09-18 23:22:05-0400

=== Xamarin.Android ===

Version: 5.1.6.7 (Business Edition)
Android SDK: /Users/dvanderboom/Library/Developer/Xamarin/android-sdk-macosx
	Supported Android versions:
		4.0.3 (API level 15)
		4.4   (API level 19)
		5.0   (API level 21)
Java SDK: /usr
java version "1.7.0_71"
Java(TM) SE Runtime Environment (build 1.7.0_71-b14)
Java HotSpot(TM) 64-Bit Server VM (build 24.71-b01, mixed mode)

=== Xamarin Android Player ===

Version: Unknown version
Location: /Applications/Xamarin Android Player.app

=== Xamarin.Mac ===

Not Installed

=== Build Information ===

Release ID: 509070009
Git revision: 31fa64709030b3edb971237780a452a4c69943c4
Build date: 2015-09-17 11:44:37-04
Xamarin addins: b105d33d8cd72911ff2cf3ee0b7715d37e5f19a6

=== Operating System ===

Mac OS X 10.10.5
Darwin OTSDEVMAC01.local 14.5.0 Darwin Kernel Version 14.5.0
    Wed Jul 29 02:26:53 PDT 2015
    root:xnu-2782.40.9~1/RELEASE_X86_64 x86_64
Comment 23 David Karlaš 2015-09-28 07:50:42 UTC
Hi Dan, you can test fix by installing this Mono https://www.dropbox.com/s/7lnvq7szu6x0i0a/MonoFramework-MDK-4.2.1.58.macos10.xamarin.x86%20%281%29.pkg

Otherwise you can wait for next update.
Comment 24 Iain Smith 2015-09-28 09:40:34 UTC
This works for me, just started getting this issue today and installing the mono version David posted above fixed it.
Comment 25 Dan Vanderboom 2015-09-28 15:15:42 UTC
Hi David, I installed the Mono version you provided, and I'm no longer getting the OutputPath error... and now my UITests will run as well. Great work! Thank you!
Comment 26 Dan Vanderboom 2015-10-05 13:12:13 UTC
Is there an early-preview link for Windows as well?

Has this fix been scheduled for a specific release? Can it be found yet in an alpha or beta channel?
Comment 27 David Karlaš 2015-10-06 02:50:17 UTC
It should be part of Cycle6 SR1, so it will be available in few weeks... But this is not needed on Windows... Is this bug happening also on Windows for you?
Comment 28 Dan Vanderboom 2015-10-08 17:29:03 UTC
I'm not sure it's exactly this same problem, but yes I did see an OutputPath error in Visual Studio. Unfortunately my laptop died yesterday so it will be a week or two before I get it back, hopefully with the hard drive still intact. I have screenshots I took of it happening there.
Comment 29 Parmendra Kumar 2015-10-29 09:28:15 UTC
To verify this issue I have tried to reproduce this issue and I am able to reproduce it.
Screencast: Screencast: http://www.screencast.com/t/k9prvoU0

And I have checked this issue with MonoFramework-MDK-4.2.1.58.macos10.xamarin.x86 and Its working fine.

Screencast: http://www.screencast.com/t/t4hpgjYvY


Thanks.!
Comment 30 Sunil Kumar 2015-11-02 07:31:48 UTC
As per comment 29, changing it's status to VERIFIED

Thanks!
Comment 31 David Karlaš 2015-11-05 11:17:25 UTC
This fix is being reverted for Cycle 6 since it caused regressions in other things, it will be fixed as part of Cycle 7 release.
Comment 32 David Karlaš 2015-12-16 20:57:15 UTC
So commit fixing this was in master(C7) all the time, bug 2 bugs caused by this commit were just fixed in 4.3.1 branch and few days ago also in master, so I'm marking this as Fixed for C7.
Comment 33 Parmendra Kumar 2016-02-03 16:54:10 UTC
Now I have checked this issue and I am successfully able to reproduce this issue with current stable and Verify this issue with latest Master build.

Reproduce:

Screencast: http://www.screencast.com/t/GaFRdust8
EnvironmentInfo: https://gist.github.com/Parmendrak/c05e00dbb49f50363c6e


Verify: 

Screencast: http://www.screencast.com/t/sR7iKaDVrhQ
EnvironmentInfo: https://gist.github.com/Parmendrak/738c44ec40cb51b52fe6


NOTE: To verify this issue I have used a sample attached in bug: https://bugzilla.xamarin.com/show_bug.cgi?id=27658 because of comment https://bugzilla.xamarin.com/show_bug.cgi?id=27658#c2


Hence I am closing this issue.
Comment 34 Parmendra Kumar 2016-03-29 11:48:57 UTC
I have checked this issue with C7 latest build and its working fine.

Screencast: http://www.screencast.com/t/4LQfmpq2Z

Environment Info: https://gist.github.com/Parmendrak/e24da0329422d83a9964
Comment 35 Prashant Cholachagudda 2016-04-15 05:42:31 UTC
@David Karlaš 

Is this fix available on Beta channel? I see this bug appear on latest Beta release

Steps to reproduce.

1. Create an iOS project
2. run following `xbuild` command
    $ xbuild <project_name> /p:Configuration=Release /p:Platform=iPhone


Build output
https://gist.github.com/prashantvc/cd24078de6d6f65a0671a11dbc671ee2
Comment 36 David Karlaš 2016-04-15 05:44:57 UTC
@Prashant Cholachagudda
Paths in logfile indicate you are using 4.2.3 which is not beta.
Comment 37 Aktar 2016-07-19 07:03:39 UTC
Hello, I'm having this issues with the last beta version.

Xamarin Studio Community
Version 6.0.2 (build 41)
Installation UUID: a3c95a91-ddc1-4bed-8905-cafe7ed7db25
Runtime:
	Mono 4.4.1 (mono-4.4.0-branch-c7sr0/4747417) (64-bit)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 404010000

Xamarin.Profiler
Version: 0.33.2
Location: /Applications/Xamarin Profiler.app/Contents/MacOS/Xamarin Profiler

Apple Developer Tools
Xcode 7.3.1 (10188.1)
Build 7D1014

Xamarin.Mac
Version: 2.8.2.10 (Xamarin Studio Community)

Xamarin.Android
Version: 6.1.2.0 (Xamarin Studio Community)
Android SDK: /Users/aktar/Library/Developer/Xamarin/android-sdk-macosx
	Supported Android versions:
		4.0.3  (API level 15)
		4.1    (API level 16)
		4.2    (API level 17)
		4.3    (API level 18)
		4.4    (API level 19)
		4.4.87 (API level 20)
		5.0    (API level 21)
		5.1    (API level 22)
		6.0    (API level 23)

SDK Tools Version: 25.1.7
SDK Platform Tools Version: 24
SDK Build Tools Version: 23.0.2

Java SDK: /usr
java version "1.8.0_92"
Java(TM) SE Runtime Environment (build 1.8.0_92-b14)
Java HotSpot(TM) 64-Bit Server VM (build 25.92-b14, mixed mode)

Android Designer EPL code available here:
https://github.com/xamarin/AndroidDesigner.EPL

Xamarin Android Player
Version: 0.6.5
Location: /Applications/Xamarin Android Player.app

Xamarin.iOS
Version: 9.8.2.10 (Xamarin Studio Community)
Hash: 843a527
Branch: cycle7
Build date: 2016-06-30 17:53:03-0400

Xamarin Inspector
Version: 0.9.0.0
Hash: d7fade8
Branch: master
Build date: Fri Jun 10 20:32:15 UTC 2016

Build Information
Release ID: 600020041
Git revision: c92f57f326843c4c6e475a26d627b240ab8580f9
Build date: 2016-06-27 13:53:32-04
Xamarin addins: 7d0b879d552ad481a3c02495f712ca4720fc4a44
Build lane: monodevelop-lion-cycle7

Operating System
Mac OS X 10.11.5
Darwin MacBook-Pro-Aktar.local 15.5.0 Darwin Kernel Version 15.5.0
    Tue Apr 19 18:36:36 PDT 2016
    root:xnu-3248.50.21~8/RELEASE_X86_64 x86_64

Enabled user installed addins
Xamarin Inspector 0.9.0.0
Comment 38 David Karlaš 2016-07-19 08:12:52 UTC
Hi Aktar,

can you try building this project from command line with "xbuild YourSolution.sln"? Does it work that way?

Can you also attach whole build log?

Thank you,
David
Comment 39 Aktar 2016-07-21 09:07:49 UTC
Hi David actually I'm trying to build a project with a custom target (named "PROD")
>cd /Users/aktar/Documents/applications/src/octets-international/Octets.iOS
>xbuild Octets.iOS.csproj /p:AllowUnsafeBlocks=true /p:Configuration="Release" /p:Platform=iPhone /p:BuildIpa=true /p:ProdTarget=RELEASE_QLF /t:PROD

I striped away all the targets except ResolveProjectReferences which contains the fails

XBuild Engine Version 14.0
Mono, Version 4.4.2.0
Copyright (C) 2005-2013 Various Mono authors

Build started 21/07/2016 10:32:14.
__________________________________________________
    Target PrepareForBuild:
    Target _DetectAppManifest:
    Target _DetectSdkLocations:
    Target _CoreCompileInterfaceDefinitions:
    Target _CoreCompileImageAssets:
    Target _CollectColladaAssets:
    Target _CoreCompileColladaAssets:
    Target _BeforeCoreCompileSceneKitAssets:
    Target _CoreCompileSceneKitAssets:
    Target _BeforeCompileTextureAtlases:
    Target _CoreCompileTextureAtlases:
    Target _CollectBundleResources:
    Target _CoreOptimizePngImages:
    Target _CoreOptimizePropertyLists:
    Target _CoreOptimizeLocalizationFiles:
    Target _CoreOptimizeLocalizationFiles:
    Target _CoreOptimizeLocalizationFiles:
    Target _CoreOptimizeLocalizationFiles:
    Target _CoreOptimizeLocalizationFiles:
    Target _CoreOptimizeLocalizationFiles:
    Target _CoreOptimizeLocalizationFiles:
    Target _CoreOptimizeLocalizationFiles:
    Target _CoreOptimizeLocalizationFiles:
    Target _CoreOptimizeLocalizationFiles:
    Target ResolveProjectReferences:
        Project "/Users/aktar/Documents/applications/src/octets-international/Octets.Interop/Octets.Interop.csproj" (default target(s)):
            Target _ValidateEssentialProperties:
/Library/Frameworks/Mono.framework/Versions/4.4.2/lib/mono/4.5/Microsoft.Common.targets: error : 'OutputPath' property is not set for this project. Usually this is caused by invalid Configuration/Platform combination. Original values: Configuration: Release Platform: iPhone.
            Task "Error" execution -- FAILED
            Done building target "_ValidateEssentialProperties" in project "/Users/aktar/Documents/applications/src/octets-international/Octets.Interop/Octets.Interop.csproj".-- FAILED
        Done building project "/Users/aktar/Documents/applications/src/octets-international/Octets.Interop/Octets.Interop.csproj".-- FAILED
        Project "/Users/aktar/Documents/applications/src/octets-international/Octets.Logic/Octets.Logic.csproj" (default target(s)):
            Target _ValidateEssentialProperties:
/Library/Frameworks/Mono.framework/Versions/4.4.2/lib/mono/4.5/Microsoft.Common.targets: error : 'OutputPath' property is not set for this project. Usually this is caused by invalid Configuration/Platform combination. Original values: Configuration: Release Platform: iPhone.
            Task "Error" execution -- FAILED
            Done building target "_ValidateEssentialProperties" in project "/Users/aktar/Documents/applications/src/octets-international/Octets.Logic/Octets.Logic.csproj".-- FAILED
        Done building project "/Users/aktar/Documents/applications/src/octets-international/Octets.Logic/Octets.Logic.csproj".-- FAILED
        Project "/Users/aktar/Documents/applications/src/octets-international/Octets.Models/Octets.Models.csproj" (default target(s)):
            Target _ValidateEssentialProperties:
/Library/Frameworks/Mono.framework/Versions/4.4.2/lib/mono/4.5/Microsoft.Common.targets: error : 'OutputPath' property is not set for this project. Usually this is caused by invalid Configuration/Platform combination. Original values: Configuration: Release Platform: iPhone.
            Task "Error" execution -- FAILED
            Done building target "_ValidateEssentialProperties" in project "/Users/aktar/Documents/applications/src/octets-international/Octets.Models/Octets.Models.csproj".-- FAILED
        Done building project "/Users/aktar/Documents/applications/src/octets-international/Octets.Models/Octets.Models.csproj".-- FAILED
        Project "/Users/aktar/Documents/applications/src/octets-international/Octets.ViewModels/Octets.ViewModels.csproj" (default target(s)):
            Target _ValidateEssentialProperties:
/Library/Frameworks/Mono.framework/Versions/4.4.2/lib/mono/4.5/Microsoft.Common.targets: error : 'OutputPath' property is not set for this project. Usually this is caused by invalid Configuration/Platform combination. Original values: Configuration: Release Platform: iPhone.
            Task "Error" execution -- FAILED
            Done building target "_ValidateEssentialProperties" in project "/Users/aktar/Documents/applications/src/octets-international/Octets.ViewModels/Octets.ViewModels.csproj".-- FAILED
        Done building project "/Users/aktar/Documents/applications/src/octets-international/Octets.ViewModels/Octets.ViewModels.csproj".-- FAILED
        Project "/Users/aktar/Documents/applications/src/octets-international/CircleProgressBar/CircleProgressBar.csproj" (default target(s)):
            Target _ValidateEssentialProperties:
/Library/Frameworks/Mono.framework/Versions/4.4.2/lib/mono/4.5/Microsoft.Common.targets: error : 'OutputPath' property is not set for this project. Usually this is caused by invalid Configuration/Platform combination. Original values: Configuration: Release Platform: iPhone.
            Task "Error" execution -- FAILED
            Done building target "_ValidateEssentialProperties" in project "/Users/aktar/Documents/applications/src/octets-international/CircleProgressBar/CircleProgressBar.csproj".-- FAILED
        Done building project "/Users/aktar/Documents/applications/src/octets-international/CircleProgressBar/CircleProgressBar.csproj".-- FAILED
    Task "MSBuild" execution -- FAILED
    Done building target "ResolveProjectReferences" in project "/Users/aktar/Documents/applications/src/octets-international/Octets.iOS/Octets.iOS.csproj".-- FAILED
Done building project "/Users/aktar/Documents/applications/src/octets-international/Octets.iOS/Octets.iOS.csproj".-- FAILED

Build FAILED.
Comment 40 Jan Nepras 2016-09-09 10:21:27 UTC
I am having th same output as @Aktar. Did you guys solve this problem?
Comment 41 David Karlaš 2016-09-09 10:42:41 UTC
@Aktar, you should call this command on .sln file(which maps iPhone configuration) or add iPhone configuration to your .csproj.

@Jan Can you open new bug, because this one is specific to problem when building inside Xamarin Studio?
Comment 42 Jan Nepras 2016-09-09 10:44:52 UTC
I have this output in my Build Agent. So I am not sure if this is a bug or wrong setup of my file.
Comment 43 Jan Nepras 2016-09-09 10:57:44 UTC
@David Karlaš I tried to call command on .sln file and it fixed the problem.

Note You need to log in before you can comment on or make changes to this bug.