Bug 25406 - "Error: No provisioning profiles have been detected" thrown when attempting to debug on iOS emulator.
Summary: "Error: No provisioning profiles have been detected" thrown when attempting t...
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: iOS add-in (show other bugs)
Version: 5.7
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: master
Assignee: Jeffrey Stedfast
URL:
Depends on:
Blocks:
 
Reported: 2014-12-15 17:28 UTC by Kent Green [MSFT]
Modified: 2015-01-28 11:49 UTC (History)
2 users (show)

See Also:
Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
My sample & Xamarin Studio log files (81.51 KB, application/zip)
2014-12-15 17:28 UTC, Kent Green [MSFT]
Details

Description Kent Green [MSFT] 2014-12-15 17:28:18 UTC
Created attachment 9082 [details]
My sample & Xamarin Studio log files

---Overview---
I am presently unable to debug projects using the iOS simulator in Xamarin Studio 5.7; it fails with this error message: 

"Error: No provisioning profiles have been detected. Please visit the iOS Provisioning Portal at https://developer.apple.com to create one."

It should be noted that I don't have any provisioning profiles, however this shouldn't prevent me from debugging in the simulator. 

---Steps to reproduce---
1. Make sure you're on the Alpha update channel.
2. Create a new iOS app. (I used the Unified Blank iPhone project, though I expect others would work as well.)
3. Attempt to debug the app to the iOS simulator (I used the iPhone 6 iOS 8.1.)
4. "No provisioning profiles" error thrown.

---Expected Behavior---
App should deploy in debug mode to the iOS simulator, like it does in the stable channel.

---Actual Behavior---
App fails with error about not having provisioning profiles.

=== Xamarin Studio ===

Version 5.7 (build 646)
Installation UUID: 8ef63a7c-1b18-40de-a334-7f78777fcb55
Runtime:
	Mono 3.12.0 ((detached/dc0ce1d)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 312000066

=== Apple Developer Tools ===

Xcode 6.1.1 (6611)
Build 6A2008a

=== Xamarin.Android ===

Version: 4.20.0.28 (Business Edition)
Android SDK: /Users/kentgreen/Library/Developer/Xamarin/android-sdk-macosx
	Supported Android versions:
		2.1    (API level 7)
		2.2    (API level 8)
		2.3    (API level 10)
		3.1    (API level 12)
		4.0    (API level 14)
		4.0.3  (API level 15)
		4.1    (API level 16)
		4.2    (API level 17)
		4.3    (API level 18)
		4.4    (API level 19)
		4.4.87 (API level 20)
		5.0    (API level 21)
Java SDK: /usr
java version "1.8.0_25"
Java(TM) SE Runtime Environment (build 1.8.0_25-b17)
Java HotSpot(TM) 64-Bit Server VM (build 25.25-b02, mixed mode)

=== Xamarin.Mac ===

Version: 1.11.1.201 (Business Edition)

=== Xamarin.iOS ===

Version: 8.6.0.22 (Business Edition)
Hash: 142934d
Branch: 
Build date: 2014-12-09 10:40:45-0500

=== Build Information ===

Release ID: 507000646
Git revision: 4574f534cc8c822ac1a4b2f31450250afb6511d3
Build date: 2014-12-09 16:28:52-05
Xamarin addins: c3c87b666323c163f0ad02618d1753533cf0a4f9

=== Operating System ===

Mac OS X 10.10.1
Darwin Kents-MacBook-Pro-2.local 14.0.0 Darwin Kernel Version 14.0.0
    Fri Sep 19 00:26:44 PDT 2014
    root:xnu-2782.1.97~2/RELEASE_X86_64 x86_64

---Additional Notes---
Adding log files & sample as an attachment.
Comment 1 Jeffrey Stedfast 2015-01-08 13:35:22 UTC
What you can do is edit your "iOS Build" settings in your Project Options and remove the "Entitlements.plist" string from the iPhoneSimulator configuration(s).

I've changed the code to not set that value by default for a future release.
Comment 2 Jeffrey Stedfast 2015-01-08 13:51:14 UTC
*** Bug 25841 has been marked as a duplicate of this bug. ***
Comment 8 Kent Green [MSFT] 2015-01-28 11:49:27 UTC
Restating relevant information from comment 7 to be publically visible:

a) The comment 1 workaround is only effective for Unified apps.
b) For Classic apps, you'll need to upgrade to Xamarin Studio 5.7.1. 
(Currently in the Alpha update channel.)

In either case, you shouldn't have to set up a provisioning profile; but doing so also stops the issue from occurring.

Note You need to log in before you can comment on or make changes to this bug.