Bug 25234 - WP8 - Light theme status bar disappears after DisplayAlert
Summary: WP8 - Light theme status bar disappears after DisplayAlert
Status: VERIFIED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: Windows (show other bugs)
Version: 1.4.2
Hardware: PC Windows
: Normal normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2014-12-10 10:38 UTC by Brad
Modified: 2016-04-11 14:55 UTC (History)
8 users (show)

Tags: AC
Is this bug a regression?: ---
Last known good build:


Attachments
Repro Project (94.20 KB, application/zip)
2014-12-10 10:38 UTC, Brad
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Brad 2014-12-10 10:38:43 UTC
Created attachment 9021 [details]
Repro Project

When using DisplayAlert with a WP8 app on a physical device or emulator that has the background theme set to Light, the status bar disappears after closing the alert. The status bar changes to just an empty black bar across the top.

Attached is a project to demonstrate the issue...again, please make sure the background theme for the device or emulator is set to Light because the problem doesn't occur with the Dark background theme.
Comment 1 Ram Chandra 2015-01-05 12:38:11 UTC
I have checked this issue and I am able to reproduce this issue.

When I change the background theme of device or emulator to "light", I observed that after closing the alert dialog, status bar disappears from the screen and just shows black and no values shows on it like time, battery etc.

Screencast: http://www.screencast.com/t/mTEGoOexPC

Debug logs: https://gist.github.com/RamChBachkheti/83eeb50a05a85be28f99

Additional Info: I am not getting this behavior when background theme is set to "dark".

Please let me know if I can provide more info to this issue.

Environment Info:

Microsoft Visual Studio Professional 2013
Version 12.0.30723.00 Update 3
Microsoft .NET Framework
Version 4.5.51641
Installed Version: Professional
Xamarin   3.8.150.0 (10cfd178d55287f09c85f5a1e604dfe20889a40f)
Xamarin.Android   4.20.0.28 (ba9bbbdd44cfdc4bf485e8885bd2ad24fba525f7)
Xamarin.iOS   8.4.0.0 (840a925103a0bf4a856507f13d5eaee3c1579c2f)
Xamarin.iOS Unified Migration   1.0
Comment 2 Ali Bazzi 2015-06-03 12:30:24 UTC
I have the same issue, you should save the color of status bar before you do your internal things to display the Alert, after the displaying of alert is finished, you should set back the saved color.
you assume that the status bar color is always black, but you ignore the light theme case by that.
Comment 3 Rui Marinho 2016-03-29 21:25:38 UTC
Should be fixed in 2.2-pre1
Comment 4 Parmendra Kumar 2016-04-11 14:55:06 UTC
I have checked this issue with xamarin.forms 2.2-pre2 and its working fine.

Hence closing this issue.