Bug 25205 - [Android] Frame OutlineColor cannot be changed dynamically
Summary: [Android] Frame OutlineColor cannot be changed dynamically
Status: RESOLVED DUPLICATE of bug 33764
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms (show other bugs)
Version: 1.2.3
Hardware: PC Mac OS
: Normal normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2014-12-09 15:59 UTC by Jon Douglas [MSFT]
Modified: 2016-03-31 21:34 UTC (History)
7 users (show)

Tags: android visual frame ac
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 33764

Description Jon Douglas [MSFT] 2014-12-09 15:59:59 UTC
*Description

It seems that the OutlineColor property of a Frame can be dynamically changed in iOS, but not so much in Android. Given the reproduction, this works fine on iOS, but does not update on Android. The current work-around is to make a custom renderer.

*Reproduction

https://www.dropbox.com/s/f15drhhuzxphaej/FrameOutline.zip?dl=0

*Xamarin.Forms Version

1.2.3.6257
Comment 1 Parmendra Kumar 2014-12-23 11:06:07 UTC
I have check this issue with attached sample and I am also getting same behavior mentioned in the bug description.

Xamarin.Forms Version: 1.2.3.6257

Screencast: http://www.screencast.com/t/nKjjlTtoZFXL

Application Output: https://gist.github.com/Parmendrak/5bb41e4f01c644290a6d
BuildLog: https://gist.github.com/Parmendrak/c637ff9960305c7dfab3
IdeLog: https://gist.github.com/Parmendrak/e0b433b4b637f642e20e

Environment info:

=== Xamarin Studio ===

Version 5.5.4 (build 15)
Installation UUID: 1a096c6f-0678-402e-89b2-a2c10f7e80e4
Runtime:
	Mono 3.10.0 ((detached/92c4884)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 310000031

=== Xamarin.Android ===

Version: 4.20.0.28 (Enterprise Edition)
Android SDK: /Users/360_macmini/Desktop/android-sdk-macosx
	Supported Android versions:
		2.1    (API level 7)
		2.2    (API level 8)
		2.3    (API level 10)
		3.1    (API level 12)
		3.2    (API level 13)
		4.0    (API level 14)
		4.0.3  (API level 15)
		4.1    (API level 16)
		4.2    (API level 17)
		4.3    (API level 18)
		4.4    (API level 19)
		4.4.87 (API level 20)
		5.0    (API level 21)
Java SDK: /usr
java version "1.7.0_65"
Java(TM) SE Runtime Environment (build 1.7.0_65-b17)
Java HotSpot(TM) 64-Bit Server VM (build 24.65-b04, mixed mode)

=== Apple Developer Tools ===

Xcode 5.1 (5084)
Build 5B130a

=== Xamarin.iOS ===

Version: 8.4.0.47 (Enterprise Edition)
Hash: 7244769
Branch: 
Build date: 2014-12-11 14:54:30-0500

=== Xamarin.Mac ===

Version: 1.10.0.18 (Enterprise Edition)

=== Build Information ===

Release ID: 505040015
Git revision: f93940a35458a18052f1a25e106e62ca970d9c40
Build date: 2014-11-19 15:32:41-05
Xamarin addins: dc23cbd91a3a0e1d326328e1229e86c942a49ec8

=== Operating System ===

Mac OS X 10.9.4
Darwin ShrutiMac.local 13.3.0 Darwin Kernel Version 13.3.0
    Tue Jun  3 21:27:35 PDT 2014
    root:xnu-2422.110.17~1/RELEASE_X86_64 x86_64
Comment 2 adrianknight89 2016-01-28 23:36:29 UTC
I observe this behavior as well. Android does not respect OutlineColor changes. iOS works fine. Please also fix https://bugzilla.xamarin.com/show_bug.cgi?id=30765
Comment 3 Samantha Houts [MSFT] 2016-03-31 21:34:32 UTC
Thank you for taking the time to submit this report. After reviewing the description of this bug, we believe it no longer affects the current version of Xamarin.Forms. If you are still experiencing the issue after updating your packages, please reopen this report with an attached reproduction.
 
For your convenience, we have created some reproduction best practices viewable here: https://gist.github.com/jassmith/92405c300e54a01dcc6d

Warm regards,
Xamarin Forms Team

*** This bug has been marked as a duplicate of bug 33764 ***