Bug 25051 - cannot compile code which uses named parameters in a function call
Summary: cannot compile code which uses named parameters in a function call
Status: RESOLVED DUPLICATE of bug 24784
Alias: None
Product: Compilers
Classification: Mono
Component: C# (show other bugs)
Version: unspecified
Hardware: PC Mac OS
: --- normal
Target Milestone: ---
Assignee: Marek Safar
URL:
Depends on:
Blocks:
 
Reported: 2014-12-03 14:23 UTC by Alan McGovern
Modified: 2014-12-03 14:46 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 24784

Description Alan McGovern 2014-12-03 14:23:21 UTC
This code cannot be compiled with mono/master or mono/3.12, but can be compiled with mono 3.10:

https://github.com/oxyplot/oxyplot/blob/develop/Source/OxyPlot/PlotModel/PlotModel.Rendering.cs#L214

The specific line (pasted here for convenience) is:
rc.DrawMultilineText(p0 + new ScreenVector(0, fontSize * 1.5), errorMessage, this.TextColor, fontSize: fontSize, dy: fontSize * 1.25);

and the compile error is:

PlotModel/PlotModel.Rendering.cs(214,140): error CS1525: Unexpected symbol `1.25'
Comment 1 Alan McGovern 2014-12-03 14:46:34 UTC
This is probably a dupe

*** This bug has been marked as a duplicate of bug 24784 ***