Bug 24784 - Multiplication when passing optional parameter is now failing to compile
Summary: Multiplication when passing optional parameter is now failing to compile
Status: VERIFIED FIXED
Alias: None
Product: Installers
Classification: Mono
Component: General (show other bugs)
Version: unspecified
Hardware: Macintosh Mac OS
: Highest blocker
Target Milestone: 3.12.0
Assignee: Bugzilla
URL:
: 25051 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-11-24 19:13 UTC by Peter Collins
Modified: 2014-12-08 14:30 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments

Description Peter Collins 2014-11-24 19:13:29 UTC
The following simple console project repro is failing to compile after installing mono 3.12-series (32 bit). This does not fail to compile against the current stable desktop mono 3.10.

Error:
/Users/petercollins/Projects/SimpleIntRepro/SimpleIntRepro/Program.cs(42,42): Error CS1525: Unexpected symbol `1000' (CS1525) (SimpleIntRepro)


Repro:
public static int NonOptionalParam (int seconds)
{
	return OptionalParam (value: seconds * 1000);
}

public static int OptionalParam (int value = 0)
{
	return value;
}


Environment:
OSX Mavericks
mono-mac-3.12.0-branch-32 / 84068e57b
Comment 1 Rodrigo Kumpera 2014-11-25 16:02:16 UTC
Marek, could you take a look at this one?

Thanks.
Comment 2 Marek Safar 2014-11-26 17:02:14 UTC
Fixed in master and 3.12 branch
Comment 3 Alan McGovern 2014-12-03 14:46:34 UTC
*** Bug 25051 has been marked as a duplicate of this bug. ***
Comment 4 PJ 2014-12-03 14:50:31 UTC
While it's true that this was a compiler bug, the issue does need to be tracked for the Desktop Mono 3.12 release, so I'm moving the bug back there.

Since the bug is resolved (comment 2), I'm assuming I can move it to RESOLVED, so I'm doing that.
Comment 5 Ram Chandra 2014-12-08 14:30:30 UTC
I have checked this issue with following builds:

Mac OS X 10.9.5
Xamarin Studio: 5.7 (build 640)
Mono 3.12.0 ((detached/ef27535)
GTK+ 2.24.23 (Raleigh theme)
Package version: 312000064
=== Build Information ===

Release ID: 507000640
Git revision: 4f3f3f5fb9e31ed94e209ebcf9d9584460193d7a
Build date: 2014-12-05 17:17:05-05
Xamarin addins: 5d2ee5bbe804eb424744303b81aff2f78c72d884

Screencast: http://screencast.com/t/fzyFBmIam

Now XS is able to compile when try to do multiplication with the optional parameter. 

This issue has been fixed. Hence I am closing this issue.

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.


Create a new report for Bug 24784 on Developer Community or GitHub if you have new information to add and do not yet see a matching report.

  • Export the original title and description: Developer Community HTML or GitHub Markdown
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments


Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Related Links: