Bug 24755 - Mono often crashes under Linux kernel 3.14 and higher
Summary: Mono often crashes under Linux kernel 3.14 and higher
Status: RESOLVED NOT_REPRODUCIBLE
Alias: None
Product: Runtime
Classification: Mono
Component: General (show other bugs)
Version: 3.8.0
Hardware: PC Linux
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2014-11-23 02:04 UTC by Oren Hurvitz
Modified: 2018-03-01 05:53 UTC (History)
6 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NOT_REPRODUCIBLE

Description Oren Hurvitz 2014-11-23 02:04:33 UTC
Mono often crashes on newer Linux kernels.

Mono versions where this bug was tested and happens: 3.4, 3.8, 3.10

Linux kernels where Mono crashes: 3.14, 3.16

Linux kernels where Mono *doesn't* crash: 3.10, 3.11

Here's an example of one of the crashes: http://pastebin.com/Rcxy6WrS
(It was sent by a different user than me)

I've verified that the kernel is the problem by changing the kernel version back and forth on the same machine.
Comment 1 Michael Cerquoni 2015-04-22 15:34:57 UTC
We have many people experiencing similar issues. http://opensimulator.org/mantis/view.php?id=7519
Comment 2 p.gloor 2015-05-22 05:50:11 UTC
I made a number of tests with Mono 3.2.8 and 4.0.1 and can confirm the issue on 64-bit 3.13 and 3.16 kernels of Ubuntu 14.04.2 LTS (GNU/Linux 3.13.0-52-generic x86_64), Ubuntu 14.04.2 LTS (GNU/Linux 3.16.0-37-generic x86_64) and Debian 8 (3.16.0-4-amd64). So far, I could not reproduce a problem with 32-bit systems.
Comment 3 Zadark 2016-05-07 17:01:22 UTC
A patch for Opensim has been provided http://opensimulator.org/mantis/view.php?id=7900 (Crash due to setting Thread.name after thread start.) The patch has been successfully demonstrated on a number of system configuration. The crash condition returns when the patch is reverted. Conclude this issue is resolved.
Comment 4 Ludovic Henry 2018-02-28 22:32:37 UTC
Can you still reproduce with latest version of Mono? If so please provide a test case so we can try to reproduce locally. Thank you.
Comment 5 Oren Hurvitz 2018-03-01 05:52:23 UTC
The problem no longer happens in current Linux kernels.
Comment 6 Oren Hurvitz 2018-03-01 05:53:26 UTC
Appears fixed.