Bug 24511 - mcs hangs during compile
Summary: mcs hangs during compile
Status: RESOLVED FIXED
Alias: None
Product: Compilers
Classification: Mono
Component: C# (show other bugs)
Version: unspecified
Hardware: PC Linux
: --- normal
Target Milestone: ---
Assignee: Marek Safar
URL:
: 24566 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-11-13 19:14 UTC by Arsen.Shnurkov
Modified: 2014-11-18 07:18 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments

Description Arsen.Shnurkov 2014-11-13 19:14:18 UTC
http://stackoverflow.com/questions/26913972/why-htmlparsersharp-project-from-github-are-compiled-so-long-with-mcs

mcs is from mono 3.10.1,
HtmlParserSharp is from here - https://github.com/jflam/HtmlParserSharp

it compile with 100% CPU utilization for 15 minutes already, and I think it will never end.

The command line was

    /usr/bin/mcs /noconfig "/r:/usr/lib/mono/4.5/mscorlib.dll" -nostdlib "/out:/home/user/github.com/HtmlParserSharp/HtmlParserSharp/bin/Release/HtmlParser.dll" "/r:/usr/lib/mono/4.5/System.dll" "/r:/usr/lib/mono/4.5/System.Core.dll" "/r:/usr/lib/mono/4.5/System.Xml.Linq.dll" "/r:/usr/lib/mono/4.5/System.Data.DataSetExtensions.dll" "/r:/usr/lib/mono/4.5/System.Data.dll" "/r:/usr/lib/mono/4.5/System.Xml.dll" "/r:/usr/lib/mono/4.5/System.Core.dll" /nologo /warn:4 /debug:pdbonly /optimize+ /codepage:utf8 "/define:TRACE" /t:library "/home/user/github.com/HtmlParserSharp/HtmlParserSharp/Core/AttributeName.cs" "/home/user/github.com/HtmlParserSharp/HtmlParserSharp/Core/CharsetState.cs" "/home/user/github.com/HtmlParserSharp/HtmlParserSharp/Core/CoalescingTreeBuilder.cs" "/home/user/github.com/HtmlParserSharp/HtmlParserSharp/Common/DoctypeExpectation.cs" "/home/user/github.com/HtmlParserSharp/HtmlParserSharp/Common/DocumentMode.cs" "/home/user/github.com/HtmlParserSharp/HtmlParserSharp/Common/DocumentModeEventArgs.cs" "/home/user/github.com/HtmlParserSharp/HtmlParserSharp/Common/EncodingDetectedEventArgs.cs" "/home/user/github.com/HtmlParserSharp/HtmlParserSharp/Common/XmlViolationPolicy.cs" "/home/user/github.com/HtmlParserSharp/HtmlParserSharp/Core/DispatchGroup.cs" "/home/user/github.com/HtmlParserSharp/HtmlParserSharp/Core/DomTreeBuilder.cs" "/home/user/github.com/HtmlParserSharp/HtmlParserSharp/Core/ElementName.cs" "/home/user/github.com/HtmlParserSharp/HtmlParserSharp/Core/HtmlAttributes.cs" "/home/user/github.com/HtmlParserSharp/HtmlParserSharp/Core/InsertionMode.cs" "/home/user/github.com/HtmlParserSharp/HtmlParserSharp/Program.cs" "/home/user/github.com/HtmlParserSharp/HtmlParserSharp/Core/ILocator.cs" "/home/user/github.com/HtmlParserSharp/HtmlParserSharp/Common/ITokenHandler.cs" "/home/user/github.com/HtmlParserSharp/HtmlParserSharp/Core/ITreeBuilderState.cs" "/home/user/github.com/HtmlParserSharp/HtmlParserSharp/Core/Locator.cs" "/home/user/github.com/HtmlParserSharp/HtmlParserSharp/Core/NamedCharacterAccel.cs" "/home/user/github.com/HtmlParserSharp/HtmlParserSharp/Core/NamedCharacters.cs" "/home/user/github.com/HtmlParserSharp/HtmlParserSharp/Core/NCName.cs" "/home/user/github.com/HtmlParserSharp/HtmlParserSharp/Common/Attributes.cs" "/home/user/github.com/HtmlParserSharp/HtmlParserSharp/Common/ParserErrorEventArgs.cs" "/home/user/github.com/HtmlParserSharp/HtmlParserSharp/Core/Portability.cs" "/home/user/github.com/HtmlParserSharp/HtmlParserSharp/Properties/AssemblyInfo.cs" "/home/user/github.com/HtmlParserSharp/HtmlParserSharp/SimpleHtmlParser.cs" "/home/user/github.com/HtmlParserSharp/HtmlParserSharp/Core/StackNode.cs" "/home/user/github.com/HtmlParserSharp/HtmlParserSharp/Core/StateSnapshot.cs" "/home/user/github.com/HtmlParserSharp/HtmlParserSharp/Core/TaintableLocator.cs" "/home/user/github.com/HtmlParserSharp/HtmlParserSharp/Core/Tokenizer.cs" "/home/user/github.com/HtmlParserSharp/HtmlParserSharp/Core/TreeBuilder.cs" "/home/user/github.com/HtmlParserSharp/HtmlParserSharp/Core/TreeBuilderConstants.cs" "/home/user/github.com/HtmlParserSharp/HtmlParserSharp/Core/UTF16Buffer.cs"

6 hours later - compilation still not completed/finished.
Comment 1 Marek Safar 2014-11-18 04:30:48 UTC
Fixed in master, compiles under 2 seconds on my machine now.
Comment 2 Marek Safar 2014-11-18 07:18:59 UTC
*** Bug 24566 has been marked as a duplicate of this bug. ***

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.


Create a new report for Bug 24511 on Developer Community or GitHub if you have new information to add and do not yet see a matching report.

  • Export the original title and description: Developer Community HTML or GitHub Markdown
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments


Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Related Links: