Bug 24479 - Accented characters in solution directories cause "Product name mismatch" license failure in Visual Studio
Summary: Accented characters in solution directories cause "Product name mismatch" lic...
Status: VERIFIED FIXED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Activation (show other bugs)
Version: 3.7
Hardware: PC Windows
: Low enhancement
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2014-11-12 21:48 UTC by Brendan Zagaeski (Xamarin Support)
Modified: 2016-12-23 21:18 UTC (History)
5 users (show)

See Also:
Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Test case (14.67 KB, application/zip)
2014-11-12 21:48 UTC, Brendan Zagaeski (Xamarin Support)
Details

Description Brendan Zagaeski (Xamarin Support) 2014-11-12 21:48:51 UTC
Created attachment 8710 [details]
Test case

Accented characters in solution directories cause "Product name mismatch" license failure in Visual Studio.


This is closely related to bug 14918 but probably a separate issue.


## Regression status

Probably *not* a regression (tested Xamarin 3.3.47 and Xamarin 3.8.134).


## Steps to reproduce

1. Create a new Xamarin.iOS or Xamarin.Android app in Visual Studio.

2. Quit Visual Studio.

3. Rename the solution directory so that it includes an accented character. For example: "AndroidAppé". (Example solution attached. Be sure to unzip the example on Windows.)

4. Open the solution in Visual Studio.


## Result

The Xamarin.iOS and Xamarin.Android licenses are reported to be invalid.

### devenv*.log for an iOS project

> Xamarin.VisualStudio.Shell.ShellPackage Error: 0 : [2014-11-12 20:49:18.4] Read invalid license: iOS Unknown. Product name mismatch
>
> Xamarin.VisualStudio.Shell.ShellPackage Error: 0 : [2014-11-12 20:49:18.6] Error in license sync
> System.AggregateException: One or more errors occurred. ---> System.NullReferenceException: Object reference not set to an instance of an object.
>    at Xamarin.Components.Ide.Activation.ActivationHandler.<FetchEntitlements>b__2b(Task`1 t)
>    at System.Threading.Tasks.ContinuationResultTaskFromResultTask`2.InnerInvoke()
>    at System.Threading.Tasks.Task.Execute()
>    --- End of inner exception stack trace ---
>    at System.Threading.Tasks.Task.ThrowIfExceptional(Boolean includeTaskCanceledExceptions)
>    at System.Threading.Tasks.Task`1.GetResultCore(Boolean waitCompletionNotification)
>    at System.Threading.Tasks.Task`1.get_Result()
>    at Xamarin.Components.Ide.Activation.ActivationHandler.UpdateSyncedEntitlements(Task`1 t)
> ---> (Inner Exception #0) System.NullReferenceException: Object reference not set to an instance of an object.
>    at Xamarin.Components.Ide.Activation.ActivationHandler.<FetchEntitlements>b__2b(Task`1 t)
>    at System.Threading.Tasks.ContinuationResultTaskFromResultTask`2.InnerInvoke()
>    at System.Threading.Tasks.Task.Execute()<---

### devenv*.log for an Android project

> Xamarin.VisualStudio.Shell.ShellPackage Error: 0 : [2014-11-12 21:19:52.8] Read invalid license: Android Unknown. Product name mismatch
> 
> Xamarin.VisualStudio.Shell.ShellPackage Error: 0 : [2014-11-12 21:19:53.0] Error in license sync
> System.AggregateException: One or more errors occurred. ---> System.NullReferenceException: Object reference not set to an instance of an object.
>    at Xamarin.Components.Ide.Activation.ActivationHandler.<FetchEntitlements>b__2b(Task`1 t)
>    at System.Threading.Tasks.ContinuationResultTaskFromResultTask`2.InnerInvoke()
>    at System.Threading.Tasks.Task.Execute()
>    --- End of inner exception stack trace ---
>    at System.Threading.Tasks.Task.ThrowIfExceptional(Boolean includeTaskCanceledExceptions)
>    at System.Threading.Tasks.Task`1.GetResultCore(Boolean waitCompletionNotification)
>    at System.Threading.Tasks.Task`1.get_Result()
>    at Xamarin.Components.Ide.Activation.ActivationHandler.UpdateSyncedEntitlements(Task`1 t)
> ---> (Inner Exception #0) System.NullReferenceException: Object reference not set to an instance of an object.
>    at Xamarin.Components.Ide.Activation.ActivationHandler.<FetchEntitlements>b__2b(Task`1 t)
>    at System.Threading.Tasks.ContinuationResultTaskFromResultTask`2.InnerInvoke()
>    at System.Threading.Tasks.Task.Execute()<---



## Additional result: no error in Xamarin Studio on Windows

Opening the attached test case in Xamarin Studio on Windows does *not* cause any licensing errors. (Note that the project does _not_ build successfully, but that's a slightly different issue reported as bug 14918).


## Version information


### XamarinVS

Xamarin   3.8.134.0 (cfc660e0d4c66629c689afd6e17902301cd38fc3)
Xamarin.Android   4.20.0.24 (812ca1351e7d7fecd7708f7831742c32047e5ab3)
Xamarin.iOS   8.4.0.0 (7771b97c1b03eee3745930f42910ec4f30e2c668)

Microsoft Visual Studio Professional 2013
Version 12.0.30723.00 Update 3
Microsoft .NET Framework
Version 4.5.51641

Windows 8.1 64-bit


### Xamarin Studio

Xamarin Studio Version 5.5.4 (build 13)
Installation UUID: 7f8c60a5-1fbd-4cae-9a84-f90cc5025132
Runtime:
	Microsoft .NET 4.0.30319.34014
	GTK+ 2.24.22 (MS-Windows theme)
	GTK# 2.12.26

=== Build Information ===

Release ID: 505040013
Git revision: e3f694bbe83524db6d7e8cae11bff54773daf8ab
Build date: 2014-11-10 02:06:41-05
Xamarin addins: f7574394ab210968f35256aa4ff98f7bf4ed7fa9
Comment 1 Brendan Zagaeski (Xamarin Support) 2014-11-12 21:50:39 UTC
Marking as low priority for now because this is not a regression.
Comment 2 Rajneesh Kumar 2014-11-13 01:18:40 UTC
I have checked this issue and able to reproduce. To reproduce this issue I have followed the steps provided in bug description.

After following all the steps when I open the solution in VS I observed that the Xamarin.iOS  licenses is reported to be invalid. Here is the screencast for the same, please refer it.

Screencast:(VS): http://www.screencast.com/t/2YFrOYRkpfls

Additional Information:When opening the attached test case in Xamarin Studio on Windows does't get any licensing errors, but I am unable to build the project successfully.

Getting Following Error:
 C:\Program Files (x86)\MSBuild\Xamarin\Android\Xamarin.Android.Common.targets(5,5): Error XA0000: Unexpected error - Please file a bug report at http://bugzilla.xamarin.com. Reason: System.IO.DirectoryNotFoundException: Directory 'C:\Users\Rajneesh\Downloads\AndroidApp\AndroidAppé\AndroidApp\bin\Debug' not found. (XA0000) (AndroidApp)

Screencast:(XS): http://www.screencast.com/t/2RkTnvQg

App O/P(VS):https://gist.github.com/Rajneesh360Logica/d1212e5918cae544889f

devenv*.log for an iOS project
https://gist.github.com/Rajneesh360Logica/eb42bfa7de5a8f72cc4d

XS log: https://gist.github.com/Rajneesh360Logica/739ed5cce1e9a422e0e6

Environment Info:

Microsoft Visual Studio Professional 2013
Version 12.0.30723.00 Update 3
Microsoft .NET Framework
Version 4.5.50938

Xamarin   3.8.134.0 (cfc660e0d4c66629c689afd6e17902301cd38fc3)
Visual Studio extension to enable development for Xamarin.iOS and Xamarin.Android.

Xamarin.Android   4.20.0.24 (812ca1351e7d7fecd7708f7831742c32047e5ab3)
Visual Studio plugin to enable development for Xamarin.Android.

Xamarin.iOS   8.4.0.0 (7771b97c1b03eee3745930f42910ec4f30e2c668)
Visual Studio extension to enable development for Xamarin.iOS.


=== Xamarin Studio ===

Version 5.5.4 (build 13)
Installation UUID: a7e29e93-6348-4126-9ebc-b2777c96a552
Runtime:
	Microsoft .NET 4.0.30319.18408
	GTK+ 2.24.22 (MS-Windows theme)
	GTK# 2.12.26

=== Xamarin.Android ===

Version: 4.20.0 (Starter Edition)
Android SDK: E:\android-sdk
	Supported Android versions:
		4.0.3  (API level 15)
		4.4.87 (API level 20)
Java SDK: C:\Program Files (x86)\Java\jdk1.6.0_39
java version "1.6.0_39"
Java(TM) SE Runtime Environment (build 1.6.0_39-b04)
Java HotSpot(TM) Client VM (build 20.14-b01, mixed mode)

=== Build Information ===

Release ID: 505040013
Git revision: e3f694bbe83524db6d7e8cae11bff54773daf8ab
Build date: 2014-11-11 11:03:54-05
Xamarin addins: f7574394ab210968f35256aa4ff98f7bf4ed7fa9

=== Operating System ===

Windows 6.2.9200.0 (64-bit)
Comment 5 Brendan Zagaeski (Xamarin Support) 2016-12-23 21:16:38 UTC
For a bit of "fun" to finish up this week, I'm cleaning up a few old bugs I filed.




## Verification status: Verified fixed in Cycle 8


GOOD: XamarinVS 4.2.1.64  (872717c)  (Cycle 8 SR 1)  (November 16, 2016)

The log files do _not_ show any errors, the user's licenses remain _valid_, and the user is _able_ to continue to use standalone Xamarin Business level entitlements.


BAD:  XamarinVS 4.0.1.147 (1cc3a99)  (Cycle 6 SR 2)  (March 18, 2016)

The log files show errors about "Product name mismatch", the user's licenses are marked as invalid, and the user is no longer able to use Xamarin Business level entitlements.




## Additional test environment info (brief)

Microsoft Visual Studio Professional 2013
Version 12.0.30723.00 Update 3
Microsoft .NET Framework
Version 4.6.01055

Windows 8.1 (64-bit) Version 6.3 (Build 9600)

Note You need to log in before you can comment on or make changes to this bug.