Bug 24431 - CultureInfo constructor error message decimal and hex lcid should be different
Summary: CultureInfo constructor error message decimal and hex lcid should be different
Status: RESOLVED FIXED
Alias: None
Product: Class Libraries
Classification: Mono
Component: mscorlib (show other bugs)
Version: master
Hardware: PC Windows
: --- normal
Target Milestone: Untriaged
Assignee: Marek Safar
URL:
Depends on:
Blocks:
 
Reported: 2014-11-11 05:48 UTC by Robert van der Boon
Modified: 2014-11-11 09:54 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments

Description Robert van der Boon 2014-11-11 05:48:40 UTC
In private CultureInfo (int culture, bool useUserOverride, bool read_only) if the int culture parameter is not supported, then the message that gets logged is something like:
 Culture ID 4155 (0x4155) is not a supported culture.
while this should have been:
 Culture ID 4155 (0x103B) is not a supported culture.

This is caused by a regression introduced with eeeab3446fc26969d3ee639f2ca2ce670bffd71c

I found this while trying to deserialize a CultureInfo on Linux/Mono when that CultureInfo was (binary) serialized on Windows/Microsoft.Net.
Comment 1 Marek Safar 2014-11-11 09:54:32 UTC
Fixed in master

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.


Create a new report for Bug 24431 on Developer Community or GitHub if you have new information to add and do not yet see a matching report.

  • Export the original title and description: Developer Community HTML or GitHub Markdown
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments


Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Related Links: