Bug 24417 - Changing "Project Properties -> iOS IPA Options -> Package name" prevents IPA from being copied back to Windows
Summary: Changing "Project Properties -> iOS IPA Options -> Package name" prevents IPA...
Status: VERIFIED FIXED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: iOS (show other bugs)
Version: 3.7
Hardware: PC Windows
: Low normal
Target Milestone: 3.11.1 (C5SR1)
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2014-11-10 19:22 UTC by Brendan Zagaeski (Xamarin Team, assistant)
Modified: 2015-05-08 07:32 UTC (History)
7 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Screencast of steps to reproduce (997.05 KB, application/x-shockwave-flash)
2014-11-24 13:34 UTC, Brendan Zagaeski (Xamarin Team, assistant)
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Brendan Zagaeski (Xamarin Team, assistant) 2014-11-10 19:22:05 UTC
Changing "Project Properties -> iOS IPA Options -> Package name" prevents IPA from being copied back to Windows

The Visual Studio IDE build process has recently added a nice feature where it will copy the final IPA from the Mac build host back over to the Windows side. This bug is to tidy up a loose end where customizing the IPA output location via "Project Properties -> iOS IPA Options -> Package name" breaks the new feature.


This bug breaks the new IPA copying feature with the same symptoms as bug 24416, but it might have a different underlying cause.


## Steps to reproduce

1. Create a new "Visual C# -> iOS -> Classic API -> iPhone -> Single View App".

2. Set the "Build -> Configuration Manager" to the "Ad-Hoc|iPhone" configuration.

3. Change "Project Properties -> iOS IPA Options -> Package name" to "iPhoneApp1-1.0.ipa", for example.

4. Build the project.



## Results

The IPA file is created successfully on the Mac build host, but it is not copied to the Windows side:

> C:\Source\iPhoneApp1> dir iPhoneApp1\bin\iPhone\Ad-Hoc\iPhoneApp1-1.0.ipa
...
> 11/10/2014  07:14 PM                 0 iPhoneApp1-1.0.ipa



## Expected results

The IPA file is copied to the Windows side.

For example, if you remove the custom "Package name" entered at step 3, the IPA file is copied back successfully:

> C:\Source\iPhoneApp1> dir iPhoneApp1\bin\iPhone\Ad-Hoc\iPhoneApp1-1.0.ipa
...
> 11/10/2014  07:15 PM         1,048,414 iPhoneApp1-1.0.ipa



## Version information


### Windows

Xamarin   3.7.248.0 (8ca7d11db8a6f874c6cd2de6d9ca0f511867ce91)
Xamarin.Android   4.18.1.3 (5474129af31e9d3a86cb7482c7c5c7a30ad315f1)
Xamarin.iOS   8.4.0.0 (209abebbd8f1a292d042420edb45fa5fbd3f017b)

Microsoft Visual Studio Professional 2013
Version 12.0.30723.00 Update 3
Microsoft .NET Framework
Version 4.5.51641


### Mac build host
Xamarin.iOS 8.4.0.15
Hash: 08968c4
Build date: 2014-10-20 21:48:06-0400

Mono 3.10.0 (detached/e204655)
Xcode 6.0.1 (6528), Build 6A317
Mac OS X 10.9.5
Comment 1 Saurabh 2014-11-24 00:05:18 UTC
I have checked this Issue with latest stable builds and I am seeing .ipa file on Windows as well. I have followed steps mentioned above and I am successfully able to see generated IPA file on both Mac and Windows. This is the screencast of IPA file on Windows: http://screencast.com/t/VQK1Mh8qN


@Brendan, Are you still getting this Issue on latest stable builds?

XVS 3.8.150
X.iOS 8.4.0.45
Xcode 6.1
Comment 2 Brendan Zagaeski (Xamarin Team, assistant) 2014-11-24 13:34:58 UTC
Created attachment 8849 [details]
Screencast of steps to reproduce

Yes, I can still produce the issue on the latest stable builds. Here's a screencast of the process.


It looks like the missing piece from the attempt to repro in comment 1 might have been step 3?

> Change "Project Properties -> iOS IPA Options -> Package name" to
> "iPhoneApp1-1.0.ipa", for example.


## Up-to-date version information

Xamarin   3.8.150.0 (10cfd178d55287f09c85f5a1e604dfe20889a40f)
Xamarin.Android   4.20.0.28 (ba9bbbdd44cfdc4bf485e8885bd2ad24fba525f7)
Xamarin.iOS   8.4.0.0 (840a925103a0bf4a856507f13d5eaee3c1579c2f)

### Mac build host

Note: I tested with 8.4.0.43 first and then grabbed 8.4.0.45 from Wrench since that's not (yet) published to the stable channel.

Xamarin.iOS 8.4.0.45 (Business Edition)
Hash: f36d1ed
Build date: 2014-11-18 17:47:28-0500

Mono 3.10.0 ((detached/92c4884)
Xcode 6.1 (6604), Build 6A1052d
Mac OS X 10.9.5
Comment 3 Brendan Zagaeski (Xamarin Team, assistant) 2014-11-24 13:35:33 UTC
Marking as NEW per comment 2.
Comment 4 Prashant manu 2014-12-30 01:49:23 UTC
We have checked as per comment 2. On Changing "Project Properties -> iOS IPA Options -> Package name" prevents IPA from being copied back to Windows.

Screencast: http://screencast.com/t/WkgxIaoQl32B

Supplement Info:
VS trace log: https://gist.github.com/saurabh360/5952d50826c9384485ab

Environment Info:
XI 8.4.0.43
Xamarin   3.8.150.0 (10cfd178d55287f09c85f5a1e604dfe20889a40f)
Visual Studio extension to enable development for Xamarin.iOS and Xamarin.Android.

Xamarin.Android   4.20.0.28 (ba9bbbdd44cfdc4bf485e8885bd2ad24fba525f7)
Visual Studio plugin to enable development for Xamarin.Android.

Xamarin.iOS   8.4.0.0 (840a925103a0bf4a856507f13d5eaee3c1579c2f)
Visual Studio extension to enable development for Xamarin.iOS.
Comment 5 Brendan Zagaeski (Xamarin Team, assistant) 2015-05-07 00:42:11 UTC
According to my tests, this issue has been fixed on the current Alpha build:

XamarinVS 3.11.507.0 (dfac85e) + Xamarin.iOS 8.10.1.24 (1b48440)

Presumably this fix is a happy side-effect of the fix for Bug 24416.


So I'm updating target milestone and RESOLVED status accordingly.
Comment 6 Mohit Kheterpal 2015-05-08 07:32:01 UTC
I have checked this issue and observed that this issue is working fine with C5SR1 build of XVS i.e. 
Xamarin.VisualStudio_3.11.544_ce43650cee4a4f67154852e7d02cf8e5eff07584.msi

As shown in screencast : http://screencast.com/t/F1FBGjFX

Hence closing this issue.