Bug 240 - libsqlite3.dylib not found
Summary: libsqlite3.dylib not found
Status: RESOLVED FIXED
Alias: None
Product: iOS
Classification: Xamarin
Component: XI runtime (show other bugs)
Version: 4.x
Hardware: PC Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2011-08-09 08:41 UTC by Mike Bluestein
Modified: 2011-08-09 08:50 UTC (History)
2 users (show)

See Also:
Tags: SQLite
Is this bug a regression?: ---
Last known good build:


Attachments

Description Mike Bluestein 2011-08-09 08:41:42 UTC
I'm getting a DLLNotFoundException in the simulator. 

Unhandled Exception: System.DllNotFoundException: /Developer/Platforms/iPhoneSimulator.platform/Developer/SDKs/iPhoneSimulator3.2.sdk/usr/lib/libsqlite3.dylib
  at (wrapper managed-to-native) Mono.Data.Sqlite.UnsafeNativeMethods:sqlite3_open_v2 (byte[],intptr&,int,intptr)
  at Mono.Data.Sqlite.SQLite3.Open (System.String strFilename, SQLiteOpenFlagsEnum flags, Int32 maxPoolSize, Boolean usePool) [0x00040] in /Developer/MonoTouch/Source/mono/mcs/class/Mono.Data.Sqlite/Mono.Data.Sqlite_2.0/SQLite3.cs:119 
  at Mono.Data.Sqlite.SqliteConnection.Open () [0x0021a] in /Developer/MonoTouch/Source/mono/mcs/class/Mono.Data.Sqlite/Mono.Data.Sqlite_2.0/SQLiteConnection.cs:876 

This is on Lion with Xcode 4.1, iOS 4.3, Mono 2.10.3 MonoDevelop 2.4.2 and MonoTouch 4.0.4.1. MonoTouch seems to be looking for it in the iOS 3.2 simulator, which I don't have on this machine. Nothing is set for 3.2 in the project. Work-around is just to create the 3.2 directory and copy the libsqlite3.dylib from the 4.3 sdk.
Comment 1 Rolf Bjarne Kvinge [MSFT] 2011-08-09 08:50:54 UTC
This has been fixed already and will be in the upcoming 4.1 release.

Notice (2018-05-21): bugzilla.xamarin.com will be switching to read-only mode on Thursday, 2018-05-25 22:00 UTC.

Please join us on Visual Studio Developer Community and GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs and copy them to the new locations as needed for follow-up. The See Also field on each Bugzilla bug will be updated with a link to its new location when applicable.

After Bugzilla is read-only, if you have new information to add for a bug that does not yet have a matching issue on Developer Community or GitHub, you can create a follow-up issue in the new location. Copy and paste the title and description from this bug, and then add your new details. You can get a pre-formatted version of the title and description here:

In special cases you might also want the comments:

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Note You need to log in before you can comment on or make changes to this bug.