Bug 23934 - FileSystemInfo.LastWriteTimeUtc throws IOException on Dates before 1970
Summary: FileSystemInfo.LastWriteTimeUtc throws IOException on Dates before 1970
Status: RESOLVED DUPLICATE of bug 40368
Alias: None
Product: Class Libraries
Classification: Mono
Component: mscorlib (show other bugs)
Version: unspecified
Hardware: PC Linux
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2014-10-20 10:07 UTC by Till Lorentzen
Modified: 2016-04-16 07:46 UTC (History)
2 users (show)

See Also:
Tags:
Is this bug a regression?: ---
Last known good build:


Attachments

Description Till Lorentzen 2014-10-20 10:07:44 UTC
On Ubuntu 14.04 LTS on ext4 file system the following call throws an IOException (invalid parameter):

var file = new FileInfo(Path.Combine("/", "home", Environment.UserName, Path.GetRandomFileName());
file.LastWriteTimeUtc = new DateTime(1902, 1, 1);

This works fine:

file.LastWriteTimeUtc = new DateTime(1972, 1, 1);

Best regards
Comment 1 Marek Safar 2016-04-16 07:46:50 UTC

*** This bug has been marked as a duplicate of bug 40368 ***

Note You need to log in before you can comment on or make changes to this bug.