Bug 23727 - Xam.Android throwing GenerateJavaStubs error
Summary: Xam.Android throwing GenerateJavaStubs error
Status: RESOLVED DUPLICATE of bug 23617
Alias: None
Product: Android
Classification: Xamarin
Component: BCL Class Libraries (show other bugs)
Version: 4.18.0
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: ---
Assignee: Jonathan Pryor
URL:
Depends on:
Blocks:
 
Reported: 2014-10-09 19:14 UTC by Paul Johnson
Modified: 2014-10-09 23:55 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 23617

Description Paul Johnson 2014-10-09 19:14:42 UTC
Using 4.99, building an app is giving the following error

Target _GenerateJavaStubs:
		  ResolvedAssemblies:
		    obj/Debug/android/assets/ftrack2.dll
		    obj/Debug/android/assets/System.dll
		    obj/Debug/android/assets/System.Xml.dll
		    obj/Debug/android/assets/Mono.Android.dll
		    obj/Debug/android/assets/System.Web.Services.dll
		    obj/Debug/android/assets/System.Runtime.Serialization.dll
		    obj/Debug/android/assets/System.ServiceModel.Web.dll
		    obj/Debug/android/assets/System.ServiceModel.dll
		    obj/Debug/android/assets/System.Net.Http.dll
		    obj/Debug/android/assets/Xamarin.Android.Support.v13.dll
		    obj/Debug/android/assets/Xamarin.Android.Support.v7.MediaRouter.dll
		    obj/Debug/android/assets/GooglePlayServicesLib.dll
		    obj/Debug/android/assets/Xamarin.Android.Support.v7.AppCompat.dll
		    obj/Debug/android/assets/System.Net.Http.Extensions.dll
		    obj/Debug/android/assets/Microsoft.WindowsAzure.Mobile.dll
		    obj/Debug/android/assets/Newtonsoft.Json.dll
		    obj/Debug/android/assets/System.Core.dll
		    obj/Debug/android/assets/mscorlib.dll
		    obj/Debug/android/assets/System.Net.dll
		    obj/Debug/android/assets/Microsoft.CSharp.dll
		    obj/Debug/android/assets/Mono.CSharp.dll
		    obj/Debug/android/assets/System.ComponentModel.DataAnnotations.dll
		    obj/Debug/android/assets/System.Numerics.dll
		    obj/Debug/android/assets/System.ComponentModel.Composition.dll
		    obj/Debug/android/assets/System.Xml.Linq.dll
		  ResolvedUserAssemblies:
		    obj/Debug/android/assets/ftrack2.dll
		    obj/Debug/android/assets/Xamarin.Android.Support.v13.dll
		    obj/Debug/android/assets/Xamarin.Android.Support.v7.MediaRouter.dll
		    obj/Debug/android/assets/GooglePlayServicesLib.dll
		    obj/Debug/android/assets/Xamarin.Android.Support.v7.AppCompat.dll
		    obj/Debug/android/assets/System.Net.Http.Extensions.dll
		    obj/Debug/android/assets/Microsoft.WindowsAzure.Mobile.dll
		    obj/Debug/android/assets/Newtonsoft.Json.dll
/Library/Frameworks/Mono.framework/External/xbuild/Xamarin/Android/Xamarin.Android.Common.targets: error : Error executing task GenerateJavaStubs: Could not load assembly 'System.Runtime, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a'. Perhaps it doesn't exist in the Mono for Android profile?
: error : Error building target _GenerateJavaStubs: Object reference not set to an instance of an object

4.18 does not produce this error

=== Xamarin Studio ===

Version 5.6.1 (build 5)
Installation UUID: f3d1a29c-1ba2-4a83-a193-1087efe91a85
Runtime:
	Mono 3.10.0 ((detached/633e444)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 310000020

=== Apple Developer Tools ===

Xcode 6.1 (6539)
Build 6A1046a

=== Xamarin.iOS ===

Version: 8.2.0.193 (Business Edition)
Hash: 959c1e4
Branch: 
Build date: 2014-10-03 00:25:37-0400

=== Xamarin.Android ===

Version: 4.99.0 (Business Edition)
Android SDK: /Users/PFJ/Library/Developer/Xamarin/android-sdk-mac_x86
	Supported Android versions:
		1.6    (API level 4)
		2.1    (API level 7)
		2.2    (API level 8)
		2.3    (API level 10)
		3.0    (API level 11)
		3.1    (API level 12)
		3.2    (API level 13)
		4.0    (API level 14)
		4.0.3  (API level 15)
		4.1    (API level 16)
		4.2    (API level 17)
		4.3    (API level 18)
		4.4    (API level 19)
		4.4.87 (API level 20)
		4.5    (API level 21)
Java SDK: /usr
java version "1.6.0_51"
Java(TM) SE Runtime Environment (build 1.6.0_51-b11-457)
Java HotSpot(TM) 64-Bit Server VM (build 20.51-b01-457, mixed mode)

=== Xamarin.Mac ===

Version: 1.11.0.1 (Business Edition)

=== Build Information ===

Release ID: 506010005
Git revision: 4a603dc77610b9eff2a41582146c56b69a81ceba
Build date: 2014-10-09 11:07:06-04

=== Operating System ===

Mac OS X 10.10.0
Darwin Pauls-iMac.local 14.0.0 Darwin Kernel Version 14.0.0
    Sat Sep 27 03:58:47 PDT 2014
    root:xnu-2782.1.97~11/RELEASE_X86_64 x86_64
Comment 1 Jonathan Pryor 2014-10-09 23:55:15 UTC

*** This bug has been marked as a duplicate of bug 23617 ***