Bug 23663 - different exceptions for HttpClient SendAsync, The server stopped the handshake, Error: SendFailure (Error writing headers), Error: NameResolutionFailure
Summary: different exceptions for HttpClient SendAsync, The server stopped the handsha...
Status: RESOLVED NORESPONSE
Alias: None
Product: Class Libraries
Classification: Mono
Component: System (show other bugs)
Version: unspecified
Hardware: All All
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2014-10-07 04:25 UTC by Efe Cem Kocabas
Modified: 2018-03-13 11:07 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
exception 1 (1.95 KB, text/plain)
2014-10-07 04:27 UTC, Efe Cem Kocabas
Details
exception 2 (800 bytes, text/plain)
2014-10-07 04:27 UTC, Efe Cem Kocabas
Details
exception 3 (1.53 KB, text/plain)
2014-10-07 04:28 UTC, Efe Cem Kocabas
Details
exception 4 (1.21 KB, text/plain)
2014-10-07 04:28 UTC, Efe Cem Kocabas
Details
exception 5 (1.51 KB, text/plain)
2014-10-07 04:28 UTC, Efe Cem Kocabas
Details
exception 6 (1.52 KB, text/plain)
2014-10-07 04:28 UTC, Efe Cem Kocabas
Details
exception 7 (1.51 KB, text/plain)
2014-10-07 04:29 UTC, Efe Cem Kocabas
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NORESPONSE

Description Efe Cem Kocabas 2014-10-07 04:25:00 UTC
With the latest version of Xamarin, we're getting different exceptions for both Android and iOS project while calling web services with SSL. You can find some of those exceptions as an attachment.

The key points are

 - Development environment is Xamarin + MvvmCross
 - We're getting exceptions only when the app starts. After a successful request, it does not result with an exception anymore.
 - It is not related with the web service url, because any web service results with the same exceptions on the startup.
 - Those exceptions occur only in debug mode in development environment, however although the published products are in release mode, we're logging the exceptions in live products. it is not a specific version of device OS or device model.
 - We're thinking that this issue might be related with this one
    https://bugzilla.xamarin.com/show_bug.cgi?id=15135

It is a kind of show stopper for us.
Comment 1 Efe Cem Kocabas 2014-10-07 04:27:29 UTC
Created attachment 8327 [details]
exception 1
Comment 2 Efe Cem Kocabas 2014-10-07 04:27:44 UTC
Created attachment 8328 [details]
exception 2
Comment 3 Efe Cem Kocabas 2014-10-07 04:28:00 UTC
Created attachment 8329 [details]
exception 3
Comment 4 Efe Cem Kocabas 2014-10-07 04:28:19 UTC
Created attachment 8330 [details]
exception 4
Comment 5 Efe Cem Kocabas 2014-10-07 04:28:35 UTC
Created attachment 8331 [details]
exception 5
Comment 6 Efe Cem Kocabas 2014-10-07 04:28:52 UTC
Created attachment 8332 [details]
exception 6
Comment 7 Efe Cem Kocabas 2014-10-07 04:29:13 UTC
Created attachment 8333 [details]
exception 7
Comment 8 Efe Cem Kocabas 2014-10-07 05:14:20 UTC
Some additional info about the environment.

For Android, We are using Visual Studio with the versions;

Xamarin   3.6.262.0 (21b7dba8736246dfd10e3f19a92ed68f1b30abfd)
Xamarin.Android   4.16.0.17 (2a7b68212b17c903160fbd8e0106babb299d1be3)
Xamarin.iOS   8.0.66.0 (3e201c8aa14879773f966f483329bcda49fd3a41)

and For iOS we're using Xamarin Studio

=== Xamarin Studio ===

Version 5.5 (build 227)
Installation UUID: 3dfe71c9-8c75-40a8-8d42-0d9f2db765bf
Runtime:
    Mono 3.10.0 ((detached/47db868)
    GTK+ 2.24.23 (Raleigh theme)

    Package version: 310000019

=== Xamarin.Android ===

Version: 4.18.0 (Business Edition)
Android SDK: /Users/efecemkocabas/Library/Developer/Xamarin/android-sdk-mac_x86
    Supported Android versions:
        2.1   (API level 7)
        2.2   (API level :sunglasses:
        2.3   (API level 10)
        3.1   (API level 12)
        4.0   (API level 14)
        4.0.3 (API level 15)
        4.4   (API level 19)
Java SDK: /usr
java version "1.6.0_65"
Java(TM) SE Runtime Environment (build 1.6.0_65-b14-462-11M4609)
Java HotSpot(TM) 64-Bit Server VM (build 20.65-b04-462, mixed mode)

=== Apple Developer Tools ===

Xcode 6.0.1 (6528)
Build 6A317

=== Xamarin.iOS ===

Version: 8.2.0.193 (Business Edition)
Hash: 959c1e4
Branch: 
Build date: 2014-10-03 00:25:37-0400

=== Xamarin.Mac ===

Version:

=== Build Information ===

Release ID: 505000227
Git revision: 7b721eeec7a2fa4c4f4de0ecd2aed4dc25edac95
Build date: 2014-10-02 15:53:38-04
Xamarin addins: 99ed56b428b31eba1efaace4d82188d6f334e6ca

=== Operating System ===

Mac OS X 10.9.4
Darwin efes-mbp.mynet 13.3.0 Darwin Kernel Version 13.3.0
   Tue Jun  3 21:27:35 PDT 2014
   root:xnu-2422.110.17~1/RELEASE_X86_64 x86_64
Comment 9 Marek Safar 2014-10-07 10:17:38 UTC
Without any repro it's hard to say what step breaks. The issue does not look like HttpClient specific.
Comment 10 Marek Safar 2018-03-13 11:07:07 UTC
We have not received the requested information. If you are still experiencing this issue please provide all the requested information and reopen the bug report.

Thank you!