Bug 23617 - Can't build in Release mode: Error executing task GenerateJavaStubs: Could not load assembly 'Xamarin.Android.Support.v4
Summary: Can't build in Release mode: Error executing task GenerateJavaStubs: Could no...
Status: RESOLVED FIXED
Alias: None
Product: Android
Classification: Xamarin
Component: General (show other bugs)
Version: 4.20.0
Hardware: Macintosh Mac OS
: Normal normal
Target Milestone: 5.1
Assignee: Radek Doulik
URL:
: 23727 23919 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-10-04 15:32 UTC by Magnus Johansson
Modified: 2015-02-02 12:50 UTC (History)
7 users (show)

See Also:
Tags:
Is this bug a regression?: ---
Last known good build:


Attachments

Description Magnus Johansson 2014-10-04 15:32:05 UTC
Description of Problem:
Whenever I try to build in Release mode, I get:
Error executing task GenerateJavaStubs: Could not load assembly 'Xamarin.Android.Support.v4, Version=1.0.0.0, Culture=neutral, PublicKeyToken='. Perhaps it doesn't exist in the Mono for Android profile? 


Steps to reproduce the problem:
1. Create an Forms app, add package Android Support v4
2. Set linker to Link all (Release)
4. Build in Release mode


Actual Results:
/Library/Frameworks/Mono.framework/External/xbuild/Xamarin/Android/Xamarin.Android.Common.targets: Error: Error executing task GenerateJavaStubs: Could not load assembly 'Xamarin.Android.Support.v4, Version=1.0.0.0, Culture=neutral, PublicKeyToken='. Perhaps it doesn't exist in the Mono for Android profile? 


Expected Results:
Should Link

How often does this happen? 
Every time

Additional Information:
Comment 1 Parmendra Kumar 2014-10-06 06:19:00 UTC
I have checked this issue and I am able to reproduce it. To reproduce this, I have followed steps mentioned in the bug description. 

Screencast:http://www.screencast.com/t/pY6vn9vXHa6
Error: https://gist.github.com/anonymous/0606a73846cee8d54937
Build Log:https://gist.github.com/anonymous/69b19e7f5e6db183f4ba
IDE Log:https://gist.github.com/anonymous/8aa32be460459aef1aca

Environment Info:
=== Xamarin Studio ===

Version 5.5 (build 227)
Installation UUID: 1a096c6f-0678-402e-89b2-a2c10f7e80e4
Runtime:
	Mono 3.10.0 ((detached/47db868)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 310000019

=== Apple Developer Tools ===

Xcode 6.0.1 (6528)
Build 6A317

=== Xamarin.iOS ===

Version: 8.2.0.193 (Business Edition)
Hash: 959c1e4
Branch: 
Build date: 2014-10-03 00:25:37-0400

=== Xamarin.Android ===

Version: 4.18.0 (Business Edition)
Android SDK: /Users/360_macmini/Desktop/android-sdk-macosx
	Supported Android versions:
		2.1    (API level 7)
		2.2    (API level 8)
		2.3    (API level 10)
		3.1    (API level 12)
		3.2    (API level 13)
		4.0    (API level 14)
		4.0.3  (API level 15)
		4.1    (API level 16)
		4.2    (API level 17)
		4.3    (API level 18)
		4.4    (API level 19)
		4.4.87 (API level 20)
Java SDK: /usr
java version "1.6.0_65"
Java(TM) SE Runtime Environment (build 1.6.0_65-b14-462-11M4609)
Java HotSpot(TM) 64-Bit Server VM (build 20.65-b04-462, mixed mode)

=== Xamarin.Mac ===

Version: 1.10.0.13 (Business Edition)

=== Build Information ===

Release ID: 505000227
Git revision: 7b721eeec7a2fa4c4f4de0ecd2aed4dc25edac95
Build date: 2014-10-02 15:53:38-04
Xamarin addins: 99ed56b428b31eba1efaace4d82188d6f334e6ca

=== Operating System ===

Mac OS X 10.9.4
Darwin ShrutiMac.local 13.3.0 Darwin Kernel Version 13.3.0
    Tue Jun  3 21:27:35 PDT 2014
    root:xnu-2422.110.17~1/RELEASE_X86_64 x86_64
Comment 2 Greg Munn 2014-10-07 10:39:38 UTC
I just tested this with a slightly different environment, which worked for me. 

BUT, I noticed that the Xamarin.Android.Support.v4 package had an update available, so I updated it (v19.0.2 > v20.0.0.4) and now I get the same error.

http://screencast.com/t/PnmWKPAoef1
Comment 3 Jonathan Pryor 2014-10-08 11:18:21 UTC
The "problem" is the <LinkAssemblies/> task, which is entirely removing the Xamarin.Android.Support.v4.dll assembly.
Comment 4 Jonathan Pryor 2014-10-09 23:55:15 UTC
*** Bug 23727 has been marked as a duplicate of this bug. ***
Comment 5 Radek Doulik 2014-10-16 14:15:29 UTC
this now fixed in master by commits

840487dd904a5552f77dcc7388b27c37ca09169f
fa4a36f4b5932c7647f2f766af10ec0e6abdd148
Comment 6 Jonathan Pryor 2014-11-03 22:40:44 UTC
*** Bug 23919 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.