Bug 23585 - [Android] ListView not updated when ObservableCollection is modified
Summary: [Android] ListView not updated when ObservableCollection is modified
Status: VERIFIED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms (show other bugs)
Version: 1.2.3
Hardware: PC Mac OS
: Normal normal
Target Milestone: 1.3.3
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2014-10-03 12:29 UTC by John Miller [MSFT]
Modified: 2015-02-18 14:41 UTC (History)
10 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description John Miller [MSFT] 2014-10-03 12:29:04 UTC
**Overview:**

   In the attached (private) project, when a ListView item is removed from the collection it does not disappear in the ListView on Android. On iOS, it works. 

**Steps to Reproduce:**

   Please see private comments for instructions.

**Actual Results:**

   The cells are not removed, but the ItemsSource collection does reflect the correct data. 

**Expected Results:**

   The cells should disappear on Android, same as in iOS. 

**Build Date & Platform:**

   XF 1.2.3

**Additional Information:**

   I could not reproduce this in a smaller sample, so the customers project has been attached privately.
Comment 6 John Michael Hauck 2015-01-23 14:00:12 UTC
In hopes of moving this forward, I've reproduced the problem here:

https://github.com/JohnMichaelHauck/XamarinFormsBug01/commit/19a92d5fb08ad77b926c3c44e2641f76f3c28b12
Comment 7 John Michael Hauck 2015-01-27 13:25:59 UTC
This commit shows that this problem still exists when using Forms 1.3.2.6299-pre1:

https://github.com/JohnMichaelHauck/XamarinFormsBug01/commit/53116211f0fcca2132b0d27f742031ee4ce47356
Comment 8 Jason Smith [MSFT] 2015-01-29 22:21:30 UTC
Should be fixed in 1.3.3-pre1
Comment 9 Ram Chandra 2015-02-04 07:21:51 UTC
To verify this issue, I have checked this issue with the help of attached project in Comment7 with following builds:

Xamarin.Forms: 1.3.3.6318-pre1

Mac OS X 10.10.0
Xamarin Studio: 5.7.1 (build 16)
Mono 3.12.0 ((detached/a813491)
GTK+ 2.24.23 (Raleigh theme)
Package version: 312000068
Xamarin.Android : 4.20.0.28 (Business Edition)
=== Build Information ===
Release ID: 507010016
Git revision: f12fcaf4707ab436bee2df6263eb5333197b262c
Build date: 2015-02-01 21:06:05-05
Xamarin addins: f7b7d34419c9ec24501bfa7c658e80a6305613e0

I observed the when I flip the switch and go to result tab it shows the correct data. I tried this several times and observed that when switch is off, it shows the 2 item in Result tab and when switch is on it shows the 5 items in Result tab.

This issue has been fixed. Hence I am closing this issue.