Bug 23541 - Parallel HTTP requests fail after two responses
Summary: Parallel HTTP requests fail after two responses
Status: CONFIRMED
Alias: None
Product: Android
Classification: Xamarin
Component: General (show other bugs)
Version: 4.18.0
Hardware: PC Mac OS
: Normal normal
Target Milestone: ---
Assignee: Jonathan Pryor
URL:
Depends on:
Blocks:
 
Reported: 2014-10-01 23:37 UTC by Cody Beyer (MSFT)
Modified: 2014-12-02 02:49 UTC (History)
4 users (show)

See Also:
Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
TestCase (12.56 KB, application/zip)
2014-10-01 23:37 UTC, Cody Beyer (MSFT)
Details

Description Cody Beyer (MSFT) 2014-10-01 23:37:28 UTC
Created attachment 8280 [details]
TestCase

In the attached test case, four calls are made through http request, while only two are ever returned.

Steps to reproduce:
Build attached project
Deploy to Emulator or Device

Expected Result:
Each request has a corresponding response, demonstrated by log output of "Submitting Request: " and "Response Number:"

Actual Result:
Only the first two have responses, the subsequent requests fail to return a response

Thanks!
Comment 2 Arpit Jha 2014-10-03 02:07:47 UTC
I have checked this issue and able to reproduce it with the help of bug description.

I observed that for two request able to get response but after unable to get the response.

Screencast regarding same :
http://screencast.com/t/PaRZrsLa4lO

Environment Info :
=== Xamarin Studio ===

Version 5.5 (build 225)
Installation UUID: 45555ffd-f3f0-4f29-9543-e369d711ab7d
Runtime:
	Mono 3.10.0 ((detached/47db868)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 310000019

=== Apple Developer Tools ===

Xcode 6.0.1 (6528)
Build 6A317

=== Xamarin.iOS ===

Version: 8.2.0.191 (Trial Edition)
Hash: ff9d4a0
Branch: 
Build date: 2014-10-01 01:14:53-0400

=== Xamarin.Android ===

Version: 4.18.0 (Starter Edition)
Android SDK: /Users/xamarin77/Desktop/android-sdk-macosx
	Supported Android versions:
		2.1    (API level 7)
		2.2    (API level 8)
		2.3    (API level 10)
		3.1    (API level 12)
		3.2    (API level 13)
		4.0    (API level 14)
		4.0.3  (API level 15)
		4.1    (API level 16)
		4.2    (API level 17)
		4.3    (API level 18)
		4.4    (API level 19)
		4.4.87 (API level 20)
		4.5    (API level 21)
Java SDK: /usr
java version "1.7.0_65"
Java(TM) SE Runtime Environment (build 1.7.0_65-b17)
Java HotSpot(TM) 64-Bit Server VM (build 24.65-b04, mixed mode)

=== Xamarin.Mac ===

Version: 1.11.0.1 (Starter Edition)

=== Build Information ===

Release ID: 505000225
Git revision: 50a525f6fca1b6ad5bd4da1ab2f2b0083240826d
Build date: 2014-09-30 12:07:18-04
Xamarin addins: bcebe330d7d264c5241c3d9b459aaf3bfd8ac4e0

=== Operating System ===

Mac OS X 10.9.5
Darwin Xamarin77s-Mac-mini.local 13.4.0 Darwin Kernel Version 13.4.0
    Sun Aug 17 19:50:11 PDT 2014
    root:xnu-2422.115.4~1/RELEASE_X86_64 x86_64
Comment 3 T.J. Purtell 2014-12-02 02:44:13 UTC
Likely this issue https://bugzilla.xamarin.com/show_bug.cgi?id=22724 ... didn't make it to any released channel AFAIK
Comment 4 T.J. Purtell 2014-12-02 02:49:10 UTC
oh wow, nevermind, this test case doesn't even use http client, so its not the same, but it sounded just like the behavior i saw

Note You need to log in before you can comment on or make changes to this bug.