Bug 23191 - SIGILL error being shown in application output when deployed to device
Summary: SIGILL error being shown in application output when deployed to device
Status: RESOLVED DUPLICATE of bug 1102
Alias: None
Product: iOS
Classification: Xamarin
Component: XI runtime (show other bugs)
Version: master
Hardware: All All
: Normal normal
Target Milestone: Untriaged
Assignee: Zoltan Varga
URL:
Depends on:
Blocks:
 
Reported: 2014-09-19 10:36 UTC by Dominic N [MSFT]
Modified: 2017-01-17 19:46 UTC (History)
4 users (show)

See Also:
Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Try/Catch was added around the line causing error to produce this more detailed result (188.41 KB, image/png)
2014-09-19 10:36 UTC, Dominic N [MSFT]
Details

Description Dominic N [MSFT] 2014-09-19 10:36:28 UTC
Created attachment 8120 [details]
Try/Catch was added around the line causing error to produce this more detailed result

A customer sent in a project that was throwing an error as follows:

2014-09-18 15:36:43.865 AgriData[633:6107] An exception was thrown by the type initializer for Adm.Core.ViewModel.ViewModelBag
An exception was thrown by the type initializer for Adm.Core.ViewModel.ViewModelBag

The project must be run on device to produce this error. Upon further investigation with a try / catch, we were able to produce a more detailed error as shown by the provided attachment.

We are seeing a SIGILL error.

Project sample from customer will be attached privately.


## Version Information

=== Xamarin Studio ===

Version 5.4 (build 239)
Installation UUID: ee07b9c8-41e3-496f-a1ab-e8a3ed3db20f
Runtime:
	Mono 3.8.0 ((no/45d0ba1)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 308000009

=== Apple Developer Tools ===

Xcode 6.0.1 (6528)
Build 6A317

=== Xamarin.Mac ===

Version: 1.11.0.1 (Business Edition)

=== Xamarin.Android ===

Version: 4.17.0 (Business Edition)
Android SDK: /Users/dominicnahous/Library/Developer/Xamarin/android-sdk-macosx
	Supported Android versions:
		2.1   (API level 7)
		2.2   (API level 8)
		2.3   (API level 10)
		3.1   (API level 12)
		4.0   (API level 14)
		4.0.3 (API level 15)
		4.2   (API level 17)
		4.4   (API level 19)
Java SDK: /usr
java version "1.6.0_65"
Java(TM) SE Runtime Environment (build 1.6.0_65-b14-462-11M4609)
Java HotSpot(TM) 64-Bit Server VM (build 20.65-b04-462, mixed mode)

=== Xamarin.iOS ===

Version: 8.0.0.60 (Business Edition)
Hash: b26679f
Branch: 
Build date: 2014-09-16 12:47:14-0400

=== Build Information ===

Release ID: 504000239
Git revision: 338110385bb89c5774e89ffcb15d8f2039e7fbcd
Build date: 2014-09-16 12:25:53-04
Xamarin addins: 05241f5ab70cf79388a0f113bc6877780ed1024a

=== Operating System ===

Mac OS X 10.9.4
Darwin Dominics-MacBook-Pro.local 13.3.0 Darwin Kernel Version 13.3.0
    Tue Jun  3 21:27:35 PDT 2014
    root:xnu-2422.110.17~1/RELEASE_X86_64 x86_64
Comment 2 Sebastien Pouliot 2014-09-19 11:08:18 UTC
@Dominic have you tried to build the attached project ? I'm getting 70 errors due to missing files (resources).
Comment 3 Dominic N [MSFT] 2014-09-19 11:28:20 UTC
@Sebastien - my apologies. I attached the file sent directly from the customer. I forgot I had to delete some references to get it running. Just cleaned it up and will be attaching it privately. Thanks!
Comment 5 Sebastien Pouliot 2014-09-19 13:54:21 UTC
Zoltan, the SIGILL still occurs using monotouch/master (dda2612fc43c4585ed1731b40b47c9f456db4bae)
Happens only on device/AOT, simulator/JIT is fine.
Comment 6 Zoltan Varga 2014-09-19 15:04:17 UTC
This is the usual 'code is too large error', the Adm.Core.dll assembly is compiled to native code which is over 16mb of length in debug mode due to some huge methods in
Adm.Core/TempData/ProductData.cs.

We should probably detect this in the AOT compiler and error out.
Comment 7 Sebastien Pouliot 2017-01-17 19:46:26 UTC
A large part of those issue are failing at build time (and we error out, even if it's not always clear why).

*** This bug has been marked as a duplicate of bug 1102 ***

Note You need to log in before you can comment on or make changes to this bug.