Bug 22946 - Debug error with assembly directory
Summary: Debug error with assembly directory
Status: RESOLVED DUPLICATE of bug 14918
Alias: None
Product: Android
Classification: Xamarin
Component: Debugger (show other bugs)
Version: 4.18.0
Hardware: PC Windows
: Normal normal
Target Milestone: ---
Assignee: dean.ellis
URL:
Depends on:
Blocks:
 
Reported: 2014-09-12 13:36 UTC by JEMB
Modified: 2014-09-15 06:06 UTC (History)
2 users (show)

See Also:
Tags:
Is this bug a regression?: ---
Last known good build:


Attachments

Description JEMB 2014-09-12 13:36:19 UTC
Hi,

It's my first Bug. When a debug an android app I get this error:

C:\Program Files (x86)\MSBuild\Xamarin\Android\Xamarin.Android.Common.targets(224,5): monodroid error XA0000: Unexpected error - Please file a bug report at http://bugzilla.xamarin.com. Reason: System.IO.DirectoryNotFoundException: Directory 'C:\Users\Jesús\Documents\Xamarin Studio\Phoneword\Phoneword_Droid\bin\Debug' not found.

This directory is wrong: C:\Users\Jesús\Documents\Xamarin Studio\Phoneword\Phoneword_Droid\bin\Debug
The real directory with these files content is in: C:\Users\Jesús\Documents\Xamarin Studio\Phoneword\Phoneword_Droid\bin\Debug

Where can I change this route?
Why does it change 'ú' character to 'ú'? Any encoding error?

Thanks for your response
Comment 1 Sadik Ali 2014-09-15 06:02:21 UTC
I have checked this issue and able to reproduce this. To reproduce this I have followed the steps given below:

1. Open VS
2. Create an android blank application 
3. Build and run the application
4. Now create a folder name "Jesús"
5. Copy you android project in this folder
6. Build the application and run it again
7. You will get the following exception:

1>Unexpected error - Please file a bug report at http://bugzilla.xamarin.com. Reason: Could not find a part of the path "C:\Users\Admin\Desktop\Jesús\InvalidChar\InvalidChar\obj\Debug\android\bin\resources_and_assemblies".

I observed that in the above application path the name of the folder is different(Jesús) in place of ("Jesús"). Means that 'ú' character change to 'ú'

Screencast: http://www.screencast.com/t/eaAna2xTt

Environment Info:
Microsoft Visual Studio Professional 2012
Version 11.0.61030.00 Update 4
Microsoft .NET Framework
Version 4.5.50938

Installed Version: Professional

LightSwitch for Visual Studio 2012   04938-004-0033001-02837
Microsoft LightSwitch for Visual Studio 2012

Office Developer Tools   04938-004-0033001-02837
Microsoft Office Developer Tools

Team Explorer for Visual Studio 2012   04938-004-0033001-02837
Microsoft Team Explorer for Visual Studio 2012

Visual Basic 2012   04938-004-0033001-02837
Microsoft Visual Basic 2012

Visual C# 2012   04938-004-0033001-02837
Microsoft Visual C# 2012

Visual C++ 2012   04938-004-0033001-02837
Microsoft Visual C++ 2012

Visual F# 2012   04938-004-0033001-02837
Microsoft Visual F# 2012

Visual Studio 2012 Code Analysis Spell Checker   04938-004-0033001-02837
Microsoft® Visual Studio® 2012 Code Analysis Spell Checker

Portions of International CorrectSpell™ spelling correction system © 1993 by Lernout & Hauspie Speech Products N.V. All rights reserved.

The American Heritage® Dictionary of the English Language, Third Edition Copyright © 1992 Houghton Mifflin Company. Electronic version licensed from Lernout & Hauspie Speech Products N.V. All rights reserved.

Visual Studio 2012 SharePoint Developer Tools   04938-004-0033001-02837
Microsoft Visual Studio 2012 SharePoint Developer Tools

ASP.NET and Web Tools   2012.3.41009
Microsoft Web Developer Tools contains the following components:
Support for creating and opening ASP.NET web projects
Browser Link: A communication channel between Visual Studio and browsers
Editor extensions for HTML, CSS, and JavaScript
Page Inspector: Inspection tool for ASP.NET web projects
Scaffolding: A framework for building and running code generators
Server Explorer extensions for Windows Azure Web Sites
Web publishing: Extensions for publishing ASP.NET web projects to hosting providers, on-premises servers, or Windows Azure

NuGet Package Manager   2.8.50313.31
NuGet Package Manager in Visual Studio. For more information about NuGet, visit http://docs.nuget.org/.

PreEmptive Analytics Visualizer   1.0
Microsoft Visual Studio extension to visualize aggregated summaries from the PreEmptive Analytics product.

SQL Server Data Tools   11.1.20627.00
Microsoft SQL Server Data Tools

Workflow Manager Tools 1.0   1.0
This package contains the necessary Visual Studio integration components for Workflow Manager.

Xamarin   3.5.58.0 (6b70b1e28c5a733187f7659220da4c0ff61ab2b1)
Visual Studio extension to enable development for Xamarin.iOS and Xamarin.Android
Comment 2 dean.ellis 2014-09-15 06:06:28 UTC
Its a known issue with Accented characters. This seems to be a duplicate of #bug 14918.

*** This bug has been marked as a duplicate of bug 14918 ***

Note You need to log in before you can comment on or make changes to this bug.