Bug 22942 - [iOS8] Input view is not shown
Summary: [iOS8] Input view is not shown
Status: CONFIRMED
Alias: None
Product: iOS
Classification: Xamarin
Component: Xamarin.iOS.dll (show other bugs)
Version: XI 8.0.0
Hardware: PC Mac OS
: Normal normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2014-09-12 12:37 UTC by John Miller [MSFT]
Modified: 2014-11-03 05:16 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Test Project (12.85 KB, application/zip)
2014-09-12 12:37 UTC, John Miller [MSFT]
Details
Screenshot 1 (48.65 KB, image/png)
2014-09-12 12:38 UTC, John Miller [MSFT]
Details
Screenshot 2 (42.70 KB, image/png)
2014-09-12 12:38 UTC, John Miller [MSFT]
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report for Bug 22942 on Developer Community or GitHub if you have new information to add and do not yet see a matching new report.

If the latest results still closely match this report, you can use the original description:

  • Export the original title and description: Developer Community HTML or GitHub Markdown
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments

Related Links:
Status:
CONFIRMED

Description John Miller [MSFT] 2014-09-12 12:37:48 UTC
Created attachment 8036 [details]
Test Project

**Overview:**

   In Xamarin 8.0, connecting a hardware keyboard will hide the custom inputs too. On iOS 7 and earlier the expected behavior occurs.

**Steps to Reproduce:**

   1. Run the attached sample on iOS 8.
   2. Open a keyboard / use an attached bluetooth keyboard.

**Actual Results:**

   The custom input views are hidden.

**Expected Results:**

   The expected behavior is that when a hardware keyboard is connected it will only replace the default keyboards. Custom inputviews should still be shown.

**Build Date & Platform:**

   XI 8

**Additional Information:**

   Attached is a test project and two screenshots showing the behavior.
Comment 1 John Miller [MSFT] 2014-09-12 12:38:02 UTC
Created attachment 8037 [details]
Screenshot 1
Comment 2 John Miller [MSFT] 2014-09-12 12:38:15 UTC
Created attachment 8038 [details]
Screenshot 2
Comment 3 Sebastien Pouliot 2014-09-12 14:43:24 UTC
We do not do any special handling for this. Did you look if Xcode/ObjC app behave the same ?
Comment 4 Sebastien Pouliot 2014-09-16 09:40:51 UTC
A quick googling gave me this:

http://stackoverflow.com/q/25834851/220643

It makes a lot of sense. Can you try this and report back ?
Comment 5 John Miller [MSFT] 2014-10-02 17:26:34 UTC
@Sebastien,

I was able to reproduce the issue using the attached Test Project and the iPhone 5s iOS 8 simulator. After disabling the "Connect Hardware Keyboard" setting, the input is shown correctly. 

I assume that setting simulates what a external connected keyboard would be doing, which suggests there is an issue somewhere. The input view should still be shown, as it is with other simulators. 

I am not sure if a obj-c app reproduces the same behavior or not.
Comment 6 Shruti 2014-11-03 05:16:13 UTC
I have checked this issue with attached project and able to reproduce it. I have checked it with  enabling and disabling 'Connect Hardware Keyboard' setting and observed that  Input view is now showing. 

Screencast : http://screencast.com/t/Quxx1yX1do4

Environment Info : 
=== Xamarin Studio ===

Version 5.5.3 (build 6)
Installation UUID: 67eaf3b4-f8a7-4ab4-a9df-3197350ca5dc
Runtime:
	Mono 3.10.0 ((detached/fe854ad)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 310000025

=== Xamarin.Android ===

Version: 4.18.1 (Business Edition)
Android SDK: /Users/ixamarin78/Desktop/android-sdk-macosx
	Supported Android versions:
		2.1    (API level 7)
		2.2    (API level 8)
		2.3    (API level 10)
		3.1    (API level 12)
		3.2    (API level 13)
		4.0    (API level 14)
		4.0.3  (API level 15)
		4.1    (API level 16)
		4.2    (API level 17)
		4.3    (API level 18)
		4.4    (API level 19)
		4.4.87 (API level 20)
		4.5    (API level 21)
Java SDK: /usr
java version "1.6.0_65"
Java(TM) SE Runtime Environment (build 1.6.0_65-b14-462-11M4609)
Java HotSpot(TM) 64-Bit Server VM (build 20.65-b04-462, mixed mode)

=== Apple Developer Tools ===

Xcode 6.1 (6604)
Build 6A1052d

=== Xamarin.iOS ===

Version: 8.4.0.15 (Business Edition)
Hash: 08968c4
Branch: 
Build date: 2014-10-20 21:48:06-0400

=== Xamarin.Mac ===

Version: 1.11.1.3 (Business Edition)

=== Build Information ===

Release ID: 505030006
Git revision: fbe3e9453daf6a3bb9a9709ed22bec35f7c9056b
Build date: 2014-10-23 13:08:38-04
Xamarin addins: e44add2b39de4dd57c0742bb2e620dfad84c64c6

=== Operating System ===

Mac OS X 10.9.4
Darwin XamnewiMac.local 13.3.0 Darwin Kernel Version 13.3.0
    Tue Jun  3 21:27:35 PDT 2014
    root:xnu-2422.110.17~1/RELEASE_X86_64 x86_64

Hence, I am confirming this issue.