Bug 22308 - Make GetAttributeCompletions parse full XElement for all attributes
Summary: Make GetAttributeCompletions parse full XElement for all attributes
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: XML Editor (show other bugs)
Version: Trunk
Hardware: PC Mac OS
: Low enhancement
Target Milestone: master
Assignee: Bugzilla
URL:
: 22399 58761 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-08-22 13:54 UTC by Jérémie Laval
Modified: 2017-10-05 06:02 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Jérémie Laval 2014-08-22 13:54:41 UTC
The GetAttributeCompletions call has a very handy existingAtts parameter but due to the way the parser stop parsing at the caret, if you start adding new attributes in the middle of an existing attributes list like so:

<foo
   attr1="foo"
   at$
   attr2="bar" />

Then only the attr1="foo" attribute will find its way into the dictionary.
Comment 1 Mikayla Hutchinson [MSFT] 2014-08-22 15:36:59 UTC
The problem is the next attribute is a syntax error.

We'd need some kind of extra-tolerant mode, or maybe cache and inspect with the previous value parse unit.
Comment 2 David Karlaš 2017-09-08 14:15:33 UTC
*** Bug 22399 has been marked as a duplicate of this bug. ***
Comment 3 David Karlaš 2017-09-08 14:15:50 UTC
*** Bug 58761 has been marked as a duplicate of this bug. ***
Comment 4 xamarin-release-manager 2017-10-05 06:02:27 UTC
Fixed in version 7.4.0.241 (master)

Author: David Karlas??
Commit: 02905ab6a08d68d361cede575d66953c9fbf8342 (mono/monodevelop)