Bug 22150 - lvregs_len < 1024 assertion was triggered with large method
Summary: lvregs_len < 1024 assertion was triggered with large method
Status: RESOLVED NOT_REPRODUCIBLE
Alias: None
Product: Android
Classification: Xamarin
Component: Mono runtime / AOT Compiler (show other bugs)
Version: 4.16.0
Hardware: PC Windows
: Normal normal
Target Milestone: ---
Assignee: Jonathan Pryor
URL:
Depends on:
Blocks:
 
Reported: 2014-08-17 15:35 UTC by Joe
Modified: 2017-06-27 19:17 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NOT_REPRODUCIBLE

Description Joe 2014-08-17 15:35:16 UTC
Assert: https://github.com/mono/mono/blob/a8a518752e1e9651d51fc682d94e3b6c6cb85599/mono/mini/method-to-ir.c#L13585

I have a rather large hash function composed of over 1000 lines of xors, shifts, ors, etc. I was able to work around it by splitting the processing into another method call. I was not able to reproduce this while the debugger was attached.
Comment 1 Prashant manu 2014-08-18 10:57:18 UTC
Could you please provide us the test steps you followed. If possible please
attach a small complete project that demonstrates this behavior.

Also can you please add the logs from the following places?:
On XS IDE Log  Location: XS>Help> Open Log Directory> IDE.log file (with latest
timestamp)
AndroidTools log: XS->Help->Open Log Directory->AndroidTools.log

If using VS, 
IDE log: Location: C:\User\AppData\Local\Xamarin\Log\ 
(Devenev file with latest timestamp)
Android Trace log: Location: \AppData\Local\Xamarin\Log\XamarinAndroid

This will help us efficiently confirm and fix this bug.
Comment 2 Chris Hardy [MSFT] 2017-06-27 19:17:42 UTC
Because we have not received a reply to our request for more information we are closing this issue. If you are still encountering this issue, please reopen the ticket with the requested information. Thanks!