Bug 21896 - Testing an Async method always shows as successful even if it should fail, and then an exception is thrown after async method returns
Summary: Testing an Async method always shows as successful even if it should fail, an...
Status: CONFIRMED
Alias: None
Product: iOS
Classification: Xamarin
Component: Xamarin.iOS.dll (show other bugs)
Version: 7.2.5
Hardware: PC Mac OS
: Normal normal
Target Milestone: Untriaged
Assignee: Sebastien Pouliot
URL:
Depends on:
Blocks:
 
Reported: 2014-08-06 20:32 UTC by Jon Goldberger [MSFT]
Modified: 2014-08-07 03:11 UTC (History)
2 users (show)

See Also:
Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Test Test Project (6.69 KB, application/zip)
2014-08-06 20:32 UTC, Jon Goldberger [MSFT]
Details
Stack Trace part 1 (125.17 KB, image/jpeg)
2014-08-06 20:33 UTC, Jon Goldberger [MSFT]
Details
Stack Trace part 2 (23.99 KB, image/jpeg)
2014-08-06 20:33 UTC, Jon Goldberger [MSFT]
Details

Description Jon Goldberger [MSFT] 2014-08-06 20:32:27 UTC
Created attachment 7612 [details]
Test Test Project

Steps to reproduce:

1. Open the attached test project.
2. Open the Unit Tests panel and run all tests.

Expected result: XCheckAsyncMethod_StringReturn() test will fail.
Actual result: Test shows as successful and later, after async method returns (presumably) the below exception is thrown:

> RemotingException: Unix transport error.

I can't copy and paste the stack trace, so I am attaching images. TestAsyncStackTrace1.jpg and TestAsyncStackTrace2.jpg (couldn't get the long line in one screen, so the second image just has what was cut off in the first.)

My version info:

=== Xamarin Studio ===

Version 5.2 (build 386)
Installation UUID: 2dc9022f-f9a8-424f-8284-bf224cbbfde0
Runtime:
	Mono 3.6.0 ((no/f540f8a)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 306000039

=== Xamarin.Android ===

Version: 4.14.0 (Business Edition)
Android SDK: /Users/apple/Library/Developer/Xamarin/android-sdk-mac_x86
	Supported Android versions:
		2.2   (API level 8)
		2.3   (API level 10)
		3.1   (API level 12)
		3.2   (API level 13)
		4.0   (API level 14)
		4.0.3 (API level 15)
		4.1   (API level 16)
		4.2   (API level 17)
		4.3   (API level 18)
		4.4   (API level 19)
Java SDK: /usr
java version "1.6.0_65"
Java(TM) SE Runtime Environment (build 1.6.0_65-b14-462-11M4609)
Java HotSpot(TM) 64-Bit Server VM (build 20.65-b04-462, mixed mode)

=== Apple Developer Tools ===

Xcode 5.1.1 (5085)
Build 5B1008

=== Xamarin.iOS ===

Version: 7.2.6.28 (Business Edition)
Hash: 606f31a
Branch: 
Build date: 2014-08-01 15:27:48-0400

=== Xamarin.Mac ===

Version: 1.8.1.6

=== Build Information ===

Release ID: 502000386
Git revision: e6a54dee5376e6e7a2d9982695b060fddc09e65d
Build date: 2014-08-04 14:03:28-04
Xamarin addins: 2b5a5c26ac2ee74c6e91a8d24ef44d0ca9cb74d0

=== Operating System ===

Mac OS X 10.9.4
Darwin Jonathans-MacBook-Pro.local 13.3.0 Darwin Kernel Version 13.3.0
    Tue Jun  3 21:27:35 PDT 2014
    root:xnu-2422.110.17~1/RELEASE_X86_64 x86_64
Comment 1 Jon Goldberger [MSFT] 2014-08-06 20:33:08 UTC
Created attachment 7613 [details]
Stack Trace part 1
Comment 2 Jon Goldberger [MSFT] 2014-08-06 20:33:27 UTC
Created attachment 7614 [details]
Stack Trace part 2
Comment 4 Rajneesh Kumar 2014-08-07 03:11:29 UTC
I have checked this issue and able to reproduce this. To reproduce this I have followed the steps mentioned in the bug description.

1. Open the attached test project.
2. Build the project
3. Open unit test panal 
4. Run all tests
5. Issue gets reproduce

This is the Screencast : http://www.screencast.com/t/7DckA6CS

Environment Info:

=== Xamarin Studio ===

Version 5.2 (build 386)
Installation UUID: 952292e8-1484-4c56-b664-6ff701bef591
Runtime:
	Mono 3.8.0 ((no/9ffca33)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 308000002

=== Apple Developer Tools ===

Xcode 5.1.1 (5085)
Build 5B1008

=== Xamarin.iOS ===

Version: 7.2.6.28 (Business Edition)
Hash: 606f31a
Branch: 
Build date: 2014-08-01 15:27:48-0400

=== Xamarin.Mac ===

Version: 1.10.0.4 (Starter Edition)

=== Xamarin.Android ===

Version: 4.16.0 (Business Edition)
Android SDK: /Users/xamarin76/Desktop/android-sdk-macosx
	Supported Android versions:
		2.1   (API level 7)
		2.2   (API level 8)
		2.3   (API level 10)
		3.1   (API level 12)
		3.2   (API level 13)
		4.0   (API level 14)
		4.0.3 (API level 15)
		4.1   (API level 16)
		4.2   (API level 17)
		4.3   (API level 18)
		4.4   (API level 19)
Java SDK: /usr
java version "1.7.0_60"
Java(TM) SE Runtime Environment (build 1.7.0_60-b19)
Java HotSpot(TM) 64-Bit Server VM (build 24.60-b09, mixed mode)

=== Build Information ===

Release ID: 502000386
Git revision: e6a54dee5376e6e7a2d9982695b060fddc09e65d
Build date: 2014-08-04 14:03:28-04
Xamarin addins: 2b5a5c26ac2ee74c6e91a8d24ef44d0ca9cb74d0

=== Operating System ===

Mac OS X 10.9.3
Darwin Xamarin76s-Mac-mini.local 13.2.0 Darwin Kernel Version 13.2.0
    Thu Apr 17 23:03:13 PDT 2014
    root:xnu-2422.100.13~1/RELEASE_X86_64 x86_64

Note You need to log in before you can comment on or make changes to this bug.